Helping people with computers... one answer at a time.

It's easy to keep Windows Instant Messenger from signing in automatically.

How can I keep Windows Instant Messenger from signing on automatically?

My approach would be to turn off the option that starts Windows Instant Messenger when you login . That's at Options, Preferences, Run Windows Messenger when Windows Starts.

Then just run Windows Instant Messenger when you want to, and exit it when you're done.

Article C2095 - July 3, 2004 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

36 Comments
Rosie
July 25, 2004 12:34 PM

how do you stop it signing in when you connect to the internet though?

Leo
July 25, 2004 1:35 PM

In that same options dialog box there's an option specifically for that too.

chuck
August 4, 2004 2:04 PM

When I am in outlook express my and try to open a link on an email my instant messanger prompts me to sign on. It will not let me open the link. How can I correct this.

Thank you.
Chuck

Leo
August 4, 2004 4:26 PM

That's odd. Are you sure it's not the standard connection dialog as opposed to messenger sign-on? Its it true for any link or just some? I'd also turn off the "automatically log on to Windows Messenger" option in OE's Tools.Options.General .

Leanne
August 10, 2004 7:40 PM

how do you stop windows messenger from giving the option of signing me in automatically... i accidentaly pressed the "sign me in automatically" button at a friends house and i don't know how to reverse it!

Leo
August 14, 2004 5:13 PM

http://ask-leo.com/archives/000194.html should help.

Bush
August 28, 2004 12:03 AM

how do you stop windows messenger from giving the option of signing me in automatically

Leo
August 28, 2004 9:28 AM

Was the article at the top of the page you entered yoru commend on unclear? It answers your question.

I'd really appreciate knowing if I'm missing something. Thanks,

Miles
September 1, 2004 4:05 PM

If you are running Windows XP you could install service pack 2, this effectively stops windows messenger auto signing in. I have just installed SP2 and my problem is I cant get it to auto sign in anymore...sob~!!
Miles

E-Man
September 28, 2004 9:12 AM

to not sign urself in automaticaly jus go to sign in with another name and put in a bogus password and check sign in automaticaly and it wont sign u in anymore

bri
October 14, 2004 7:01 PM

i hav taken off the auto login for windows messenger at startup and also untick the option allow program to run in the background but it still secretly(background) logs on to main user account
any ideas ppl?

Ishmod
December 7, 2004 5:57 PM

Click on Tools >> Options >> Accounts >>

Highlight Communications Services instead of Net Passport.

Remove your login info from the window.

If you like using the Windows Messenger use MSN Messenger instead. It doesn't have this problem It looks better and has more options.

Good Luck.

CARLO
March 19, 2005 12:18 PM

This is the way to stop any version of MSN to log on automatically.
Go to CONTROL PANEL, and then to USER ACCOUNTS, once there click on ADMINISTRATOR and inside there you will see a tab where it say RELATED TASKS, click in the first one, which is MANAGE MY METWORK PASSWORDS and delete the account who is loging on automatically.
If it doesn't work, delete the one which say PASSPORT NET.

SORRY ABOUT MY ENGLISH...I HOPE I CAN HELP YOU GUYS LIKE YOU HELP ME IN MY BEGININS IN THIS COUNTRY

Victor
March 31, 2005 12:45 PM

CARLO,the option of deleting the account who is loging automatically dose not resolve.You are correct to say to remove the one which says PASSPORT NET.Thank you.Victor Riquelme

Lynne
April 8, 2005 3:49 PM

Thanks for the info on the signing in automatically. It worked great!

laura
April 13, 2005 4:44 AM

everyones talkin to my mates on msn cause it signs me in atomaticly iv tryed every thing but i dont no how to stop it can u help me plz.

envy
April 15, 2005 2:51 AM

Go to

* Control Panel
* User Accounts
* Computer Administor
* Manage my network password (this is one the top left hand corner, under Related Tasks)
*click on the email address that is signing in automatically then remove it.

Mr_Imagin
May 23, 2005 11:32 PM

Thanks for the aritcle.. I've been trying to resolve this problem for a while now. Keep up the good work!

Joe
June 13, 2005 4:31 PM

Thanks Carlo :)

starry
June 16, 2005 10:50 AM

Thank you, Carlo. Your tip really works!

Shanna
April 3, 2006 4:48 PM

OMG ... You saved my life!! Like seriouslyyy!! Thank you very muchh!!

ash
June 13, 2006 7:38 PM

hi there ive got a problem with my msn sometimes randomly when im talkin to my friends it suddenly signs me out. and when i sign back in again after couple of mins it happens again. it normally happens around like 5-6 times a night or more if sumthings wrong with it. ive uninstalled and reinstalled msn messenger like 10 times and still no change and now its really frustrating me. please help me.

moloy
January 24, 2007 7:47 AM

sometimes i leave my computer without logging off, so i just leave it on standby so that other people can use there accounts, but when i sign back onto my account later, windows messenger (not msn live messenger) has signed itself in. how can i stop it from doing this?

Akhil
August 31, 2007 4:04 PM

hi, my windows live messenger keeps signin me out every couple minutes randomly when im talkin to friends, i tryed uninstalling it a reinstalling it, and also tryed repairing it but nothing seems to work, it getting quite annoying, any help would be much apreciated

Lauren
November 18, 2007 12:23 PM

That does not work, windows messenger still signs me in automatically.

Kieran
January 16, 2008 9:52 AM

hi, my windows live messenger keeps signin me out every couple minutes randomly when im talkin to friends, i tryed uninstalling it a reinstalling it, and also tryed repairing it but nothing seems to work, it getting quite annoying, any help would be much apreciated

M
February 9, 2008 8:01 PM

That was a crappy crappy suggestion, Leo. That's like saying the best way to protect your PIN when it's 1111 is to only pull out your bank card when you need it, NOT MAKE A SECURE PIN.

M
February 9, 2008 8:03 PM

Crap! My comment bounced off the real answer. You nede to disable the .net crap (and I mean crap) in the Control Panel.

Tom
July 16, 2008 9:55 AM

I will bump Carlo's comment as it helped me a lot. Leo, your answer was totally worthless.

This is the way to stop any version of MSN to log on automatically.
Go to CONTROL PANEL, and then to USER ACCOUNTS, once there click on ADMINISTRATOR and inside there you will see a tab where it say RELATED TASKS, click in the first one, which is MANAGE MY METWORK PASSWORDS and delete the account who is loging on automatically.
If it doesn't work, delete the one which say PASSPORT NET

bosh
July 22, 2008 12:10 PM

Tom, that was the answer I was looking for!!! As you cant stop IM from logging in automatically, once you have accidentally signed in with the 'remember me' ticked, this is the only solution to stop it from signing in with your details. Of course, you might not be the admin account, in which case, just do the same in the account that you want to stop the IM auto sign in.
Thanks TOM!

mustafa
August 14, 2008 3:10 AM

Thanks Tom u r the real life saver. Leo that was a bad suggestion.

J
February 1, 2009 1:26 PM

I had to go about it a very very slightly different way:
Control Panel > User Accounts > Then change the Tab from Users to Advanced > Manage Passwords > Delete the one called Passport Net

cindy
February 25, 2009 4:16 PM

my windows live messenger keeps signing me out every couple of minutes saying that i've signed in to another computer what can i do about this problem?

Yasmin
October 25, 2009 10:21 AM

Hi

My wlm keeps signing me out every minute and its really annyoing as i want to chat to my friends.
i havr tried evrything in the book.
nothing seems to work
what can i do
please help :(

Necole
March 15, 2010 8:19 PM

Does this apply to windows 7? and if so where is options? Internet options? I dont see preferences under internet options...please help windows live is automatically starting up on login and I dont use it...it takes too long to load...thanks

Jessica.
July 29, 2010 10:54 AM

I have windows live messenger. I always appear offline when I sign into my account. But after a few minutes, my status changes to online automatically, my display name changes to my first name and my display picture is gone.
I've tried to change my password, but the problem still remains.
Please help!!!

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.