Helping people with computers... one answer at a time.

Your computer can automatically dial the internet for two reasons: it's configured to, or you have spyware. Both should be checked.

How can I stop my computer from connecting to the internet automatically?

Well, that depends on who's doing it.

The most common self-inflicted auto-dial is in Internet Options in either Internet Explorer or Outlook Express. In IE, Select Tools, Internet Options, and then the Connections tab. In the Dialup and Virtual Private Network Settings should be an option to "Never dial a connection".

The most common "accidental" auto-dial is spyware. Run a spyware checker such as Spybot Search and Destroy, or AdAware to check for spyware.

Update:

A reader suggested this possible solution as well:

In Windows, go to Start, All Programs, Accessories, Communications, and then Network Connections. Once there select Advanced on the menu bar, then Dial-Up Preferences, then check both boxes: "Always ask me before autodialing" and "Disable autodial while I am logged on". Then click OK.

Article C1964 - May 30, 2004 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

12 Comments
jeff
October 30, 2005 7:48 AM

my computer still dials automatically even with "never dial a connection" !

K.Rajendran
March 19, 2006 7:24 PM

How can I stop my computer from connecting to the internet automatically and How Can I Block Internet to My Computer and let me work with Local Area Network

maria
April 10, 2006 12:57 AM

I have been very upset with this same situation, everyone says the same thing, click on "never dial a connection." ok I've got it figured out. hope this helps... (you might want to write this down)
go to start, go to All Programs, select accessories, move over to communications, then network connections, click advanced, down to dial up preferences, then check both boxes: ask me before autdial & disable autodial while I am logged in, then OK. whoooo! Alrighty give it a try, Maria

Andrea
September 30, 2006 2:15 PM

How can I get my printer to stop loading everytime I turn it on? A few months ago I downloaded some update features and the printer has not scanned anything since. It's a HP all in one and if you know anything that might could help, that'd be great!

sujana
February 5, 2008 8:26 PM

Hi,

i ve done all the steps as given above to stop my computer from connecting to internet, but i think it is set up problem, i initially made, wherein automatically logging into internet was prefered. Now i am unable to come out of it.

Please Help!!!!

Natalie Baker
January 14, 2009 1:40 PM

Hi there, I had the same problem but was able to resolve it this way. When dial up is connecting automatically, hit the cancel button before it starts to dial. It displays opening port before it starts to dial with a cancel button underneath. After clicking on canel,it returns you to the origional dial up screen and you can untick connect automatically. It should not happen again.

Yvonne Dette
October 20, 2009 2:37 PM

I'm having a problem with the security tab on my Internet connection. On the Security Options under typical recommended settings I have checked the don't allow unsecured password - when I have done this it wont connect to the Internet, if I unchecked it and check Allow Unsecured password it seems to connect straight away. Why am I having this problem? can someone explain please. I have gone in and deleted the ISP and then started a new connection but it seems to go back to the same problem -Allow unsecured password..

RAHUL
January 1, 2010 1:31 AM

Actually, i wnat to information to stop internet connection. in my office we are using Local internet connection I am boss of my office but my collegue also use net I want to his internet connection how to stop his connection

Jack
July 4, 2011 11:42 AM

What is Microsoft "INDEXING?" I get the feeling that Microsoft takes all my data, organizes it to suit them, and then ALLOWS me a copy. Are all my data on a satellite somewhere? Can I interfere with Microsoft's access to my data?

Mark J
July 5, 2011 10:17 AM

@Jack
Microsoft Windows indexes the information which is stored on your hard drive, and keeps the index on your hard drive. If Microsoft did copy any data from your computer without your permission, they would be liable for criminal charges. I think they are more interested in making money selling software, than in stealing your data.

Anelito D. Labrador
August 15, 2011 1:13 AM

i have a problem with my laptop. when i connected to the internet, i noticed that it is sending connections which i have not opened any applications yet like internet browsers but i noticed the downloading and uploading status is running into a high bandwidth.. i dont know how to check if there are any other opened applications which i might overviewed. i have bittorrent and frostwire softwares but i havent opened it both yet thats why i am wondering my connection is so active and when i disconnect the internet, it stopped..how can i resolve this problem?please i need ur advice..thank u so much and god bless..

Mark J
August 15, 2011 11:55 AM

@Anelito
It could be many things. It's possible that it's simply a program doing an automatic update or it could be malware accessing the internet.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.