Helping people with computers... one answer at a time.

When you visit the Google search engine and start typing, you'll likely see a dropdown list of search terms. Those might be history, or something else.

I've done everything mentioned in your article to clear my search history, and yet when I visit Google and start typing something to search for I still get a history list underneath what I'm typing. How do I make that stop once and for all?

You're not a alone, I get this a lot. The problem isn't so much about clearing history, as it is a misunderstanding.

I'm guessing that you're not seeing history at all. What you're seeing instead is Google trying to be helpful.

Here's an example:

Google making search term suggestions as I type

I've typed "lsass", and you can see that there's a drop down list of additional terms underneath what I've typed so far. As I type, that list changes, much like a history list might.

"It's just Google trying to be helpful."

Except it's not history.

What's happening here is that as you type Google is making suggestions on popular search terms that match what you've typed so far. This has nothing to do with your previous searches or your history. This is simply Google saying "hey, you've typed XXXX so far, and here are the most popular search terms that also begin with XXXX".

Why? So you can just click on the suggestions rather than having to type them out. Or maybe you'll see something that's actually a better representation of what you're looking for. Or perhaps you'll note that there are lots of results for one term and not another, and decide to search for that instead.

It's just Google trying to be helpful.

And, in very Google-like fashion, you can turn it off if you don't like it.

Next to the search box you've been typing click the link labeled "Preferences".

On the resulting page, scroll down until you see the "Query Suggestions" option:

Google's Query Suggesions option

To turn it off, simply click on the "Do not ..." option, and then click on the Save Preferences button further down the page.

Note: this is a per-machine setting, and it's most likely stored in a cookie. Don't be surprised to see it come back as you move from machine to machine, or if you periodically clean out your cookies.

Article C3616 - January 10, 2009 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

14 Comments
Murray Braun
January 13, 2009 8:39 AM

I have seen this on my laptop but not on my desktop. I do not even have the "query suggestions" option on my desktop. I accept all cookies. Could it relate to the resolution set on the desktop? My desktop is lower than my laptop.

Brian Hopwood
January 13, 2009 9:02 AM

The solution above is all very well IF and only IF you can actually scroll down to something which says Query Suggestions. On MY Google page there is nothing of that ilk on view !!!!!!

Allan Woodcock
January 13, 2009 10:46 AM

Brian Hopwood said "On MY Google page there is nothing of that ilk on view !!!!!!"

It's the same on my desktop.

Geoff Perston
January 13, 2009 11:18 AM

Add me to the list LOL.

My Google search page doesn't show any "Query Suggestions" option either!

Kitty Ashenbrenner
January 13, 2009 2:01 PM

To clear the search history in Firefox, click the downward arrow within the white box that you type in and you will see your history listed and in the bottom right hand corner is a clickable link that says "Clear search history".
In Firefox 3, next to the actual white box that you type in, is the a little "g" followed by the word "Search" then a tiny downward arrow. Click on the arrow and scroll to the bottom and select "manage", then on the window that opens, choose the "search" tab and uncheck the box next to "Save search history on my computer".

chmacka
January 13, 2009 4:30 PM

In gmail account, under settings > accounts > Google Account settings > Web History there is a list of every page you opened from google and everything you searched for from google while you were logged in with your gmail account. (This list doesn't get deleted when you clear your browser cache.

This information is only collected while you're logged in to your Google account (doesn't have to be GMail, any Google account will do), and there are options to turn it off completely. I've got an article on it: Google's Web History might surprise you.
- Leo
14-Jan-2009

Arthur
January 13, 2009 5:19 PM

If you don't see the effects of Query Suggestions, it likely means you don't have Google Toolbar 5. Earlier Toolbar versions do not have this feature.

Barry Sparks
January 13, 2009 7:35 PM

Tools-Internet Options-Delete-Delete Forms.
Search history is deleted.

Tom
January 14, 2009 4:48 AM

Leo,

If you clear out cookies, you'll be constantly reactivating the option. I have a Google shortcut that I use in SeaMonkey and I modified the URL thus:

http://www.google.com/webhp?complete=0

Much simpler and doesn't depend on a cookie.

Tom -- Vista, CA -- USA

Pollyanna
January 14, 2009 11:12 PM

For Firefox with Google toolbar:

Right click in toolbar space. Find options at bottom of list:

"Clear Search History" - click to clear your personal searches.

"Show Suggestions" - check or uncheck to allow or disallow the drop down lists showing popular Google searches by others,

Graham Knott
January 15, 2009 9:56 AM

Hi, Well, regarding trying to switch off this mythical Query preferences radio button set up in Google Preferences, I dutifully downloaded the Google Toolbar 5 (as suggested above). And Lo and behold... still NO Query Preferences radio buttons in Google Preferences!!! So where do I go from here, anyone? (Leo?)

william w.
January 20, 2009 5:48 AM

all help is directed at removing history. I need help to save it! I lose it every time I restart or reboot.

Anonymous
March 14, 2009 1:25 PM

i accidentally deleted history from google drop down list...is there any way i can get it back? i tried system restore and set my computer to an earlier time ...drop down still blank

Nietzsche
June 17, 2009 5:48 AM

If it's really a history list underneath what you're typing, try using professional software - History Killer Pro

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.