Helping people with computers... one answer at a time.

Live preview shows a small version of a running application's window when you hover the mouse over its taskbar icon. I'll look at turning that off.

My question is about the annoying (in my opinion) pop-ups that come up whenever you hover your mouse over any open icon on the task bar (they show a thumbnail of the open page). I would really like to know how to safely disable this feature. I have searched Google, but the solutions given seem a bit scary. From my searches, I know that this is a problem for many users.

I did some looking around (as you did) and I found that you're definitely not alone.

Personally, I find it handy and appreciate it.

But as we've seen time and time again, one person's feature is another person's annoyance.

Unfortunately for this particular feature, there's no simple switch to throw to turn it on or off (Which I can also understand, because there's no way that Microsoft could possibly introduce a UI setting for every possible feature or tweak).

So, we have to improvise.

Live Taskbar Previews

First, a quick clarification of the feature that we're talking about.

Windows 7 Live Taskbar Preview

The concept is simple: If you hover your mouse over the icon of a running program in your taskbar, a small preview window showing the current contents of that application appears.

Quoting Microsoft:

In Windows 7, you can point to a taskbar button to see a live preview of its open windows-including webpages and live video. Move your mouse over a thumbnail to preview the window full screen, and click it to go open the window. You can even close windows and pause video and songs from the thumbnail previews-a big time saver.

Like I said, to me, it's kinda handy.

To others, the fact that it obscures what's behind it is more annoying than helpful.

There are two approaches to dealing with this feature.

The sledgehammer: Turn off Aero

Live Taskbar Preview is part of the Aero feature set that provides glassy-looking window borders, some fancier task switching looks, and so on.

One way to deal with this is to simply turn Aero off.

Right-click an empty area on your desktop and click Personalize:

Windows 7 Personalization, highlighting basic themes

Simply choose a theme from the "Basic and High Contrast Themes" section. You can then re-apply any custom background image or other changes that you've made.

Live Taskbar Preview will no longer happen.

The scalpel: Edit the registry

This doesn't so much remove the feature as move it out of the way for a while.

Using the registry editor, we can add a value that tells Windows how long to delay the display of the live preview. Normally, it's instantaneous, but we can set it to be some amount of time. That way, it's less likely to happen.

  • Back up. Take a system backup or at a minimum, make a registry backup by creating a restore point. Always back up prior to making any registry changes.

  • Run the registry editor. (Start -> Run and enter "regedit" followed by Enter, or type Windows Key + R and enter "regedit" followed by Enter).

  • Navigate to HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ Advanced by clicking on the small right-pointing triangle next to each element in turn, until you reach "Advanced". Click Advanced:

    Regedit opened to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

  • With Advanced selected as shown above, click the Edit menu, then the New menu item, and then the DWORD (32-bit) Value sub-menu item:

    Regedit New menu

  • Enter ExtendedUIHoverTime (exactly) as the name of the newly created registry key and press Enter:

    New ExtendedUIHoverTime key

  • Right-click ExtendedUIHoverTime and click Modify...:

    Modifying the setting for ExtendedUIHoverTime

    Make sure that Decimal is selected and enter the number of milliseconds that Windows should wait before displaying the live preview. In the example above, I've entered 20000 to make the delay 20 seconds.

  • Click OK and close the registry editor.

  • You may need to reboot for this new setting to take effect.

Now, when you hover over a running application in the task bar, you'll simply get the window title in a tooltip:

Windows Live Preview turned off

That will disappear after the normal tooltip timeout; sometime later, after the timeout that you specified above, the Live Preview will be displayed.

Avoiding the scalpel, but...

If you trust me, and only if you trust me, click this link:

extendeduihovertime.reg

That's a link to a ".reg" file that, when run, will add the ExtendedUIHoverTime setting with a time of 20 seconds.

Because downloading ".reg" files from the internet is often considered a security issue, your anti-malware tools may complain. If that happens, you should be able to right-click, save that to a folder on your machine, and then double-click on the file to run it.

In either case, you'll be presented with the following warning:

Regsitry modification warning

If you click Yes, then the registry value will be added and you'll get this confirmation:

Registry change confirmation

You still may need to reboot for the change to become effective.

Article C5037 - January 11, 2012 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

9 Comments
Ken B
January 12, 2012 11:17 AM

There must be some way (perhaps at the application level) to turn this off. My Win7 box shows the previews just as you describe above, _except_ for Safari, which instead shows a list of tabs, without previews, regardless of which Safari window they're in.

Mike
January 13, 2012 11:36 AM

Ahh, crap. I was hoping it was an article telling me how to stop those annoying popups when I pass my mouse over some mini-link or whatever it would be called. An example would be "hard disk" in your Caveat box. Just happening to pass the cursor past it causes it to pop up and then it stays there until I specifically hit the Close button.

I suppose I could tighten the popup blocker, but that causes me to take special steps to authorize a popup that I actually CLICK on. Of course, the quick answer is just avoid passing the mouse all over the page. Harder to do than it sounds.

Really, if that's my only problem in my computer life, I sure can't complain. Still...

Connor
January 13, 2012 3:30 PM

Another option to this problem is to disable the desktop Window Manager. Instead of a whole window coming up when you hover your mouse over an icon in the taskbar, just the name of the program appears. It is still basically the same, but the windows are a lot smaller. To do this go to start and type in "services.msc" and hit enter. Hit yes to the UAC if it comes up and then in the window that pops up navigate to "Desktop Window Manager". Click on it and on the left part of the window there is some information about it. One of the options is to stop the service. Click that, wait a few seconds for it to finish, and you are done. To start it again, go to the same place and hit start.

John S.
January 13, 2012 7:12 PM

After reading this and then reading it again, (i still may be missing something?) Why would one "hover" over the icon unless one would want to view what was open? In which case wouldn't the window pop up be a handy tool? Instead of clicking on it and bringing up the screen showing what it actually is? How could this action be considered "annoying"?
As Mike stated above, "Just don't hover over the icon" If you can't control your mouse that well, there are settings in the Ease Of Access Center that make the mouse more user friendly. Just sayin'

The complaints that I hear are from people who move the mouse out of the way while they do something else, only to accidentally (and apparently frequently) have one of these popups obscure what they're working on because they happened to put the mouse in the wrong palce.
Leo
14-Jan-2012
Mark
January 13, 2012 9:50 PM

There is actually an easier way to do it than that. All you have to do is right click the taskbar and go to properties. When there uncheck the Aero selection thus turning off the preview screens appearing.

That actually turns off more than just thus, but if it works, great.
Leo
14-Jan-2012
DuLee
January 14, 2012 3:44 AM

As I have mentioned many times before -- and will probably mention many times again -- I love ask-leo. But I also like my head spinning!

Good gosh, don't hack your registry. Just do what Mark said!

Lee I
January 14, 2012 3:18 PM

Good grief. These little previews are the handiest things in the world. I only have 8 windows open at the moment and do frequent switching between applications and among windows in the same application. Isn't that what they invented Windows for?

Paul
January 16, 2012 6:39 AM

i've been looking for a way to stop those preview popups ever since i got win 7 the month it was released! i'm in the group leo mentioned above: "people who move the mouse out of the way while they do something else, only to accidentally (and apparently frequently) have one of these popups obscure what they're working on because they happened to put the mouse in the wrong place." In my case it even opened those windows full screen some times (don't ask me Why!) I knew about the manual registry tweak but not that simple link Leo gave us to do it "automatically" and that's what i did and it worked great...Thanks Leo!

fahad
February 3, 2012 8:04 AM

thaaaaanks very much :))

i did exactly the same you did above
eccept for the value, i typed 90000
and it worked very well

thanks again you genius

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.