Helping people with computers... one answer at a time.

Outlook tries to protect you from opening certain types of attachments, even if you know they're safe. A registry change puts you back in control.

How do I force Outlook to open "potentially unsafe attachments" that I know are ok?

As discussed in an earlier article Outlook tries to protect you from viruses by blocking access to files which have certain extensions like ".exe" for example, because they could carry a virus and infect your machine.

Watch The Video

Click the video above for a one minute video showing you how to add the Level1Remove entry to your registry as described in this article. (Windows Media 9 format, 654,896 bytes.)

I'd Like Your Comments: let me know if you find the video above useful, or if you have suggestions to make this technique more helpfull. Thanks!

Microsoft's official recommendation is that you have whomever sent you the file rename or zip it and send it again. And to be honest that's probably still the safest approach overall.

However that's just not an option sometimes. Fortunately there is a registry setting you can add that will instruct outlook to treat extensions that you specify as safe.

Before we go mucking about in the registry I'll caution you that the registry is a critical component of the operating system, and it's possible to render your system totally useless if you make the wrong changes. Microsoft provides instructions for backing up the registry here.

That having been said, the steps I'm about to outline are relatively simple if you follow along carefully.

  • Start the registry editor by pressing the Start button, Run, typing regedit and pressing OK.
  • In Registry Editor, expand, in turn:
        HKEY_CURRENT_USER
          Software
            Microsoft
              Office
                11.0        (Office 2003. For Office XP, expand "10.0")
                  Outlook
    
    Expand each entry by clicking on the boxed plus sign to it's left. If that's a boxed minus sign then it's already expanded.
  • Now click on the Security entry.
  • On Registry Editor's menu bar select Edit, New, and String Value.
  • Replace the default name of "New Value #1" with "Level1Remove".
  • Right-click on Level1Remove and select Modify.
  • Enter the list of file extensions that you want to gain access to. The list is semi-colon separated. For example if you wanted to allow access to both ".url" and ".exe" files then you would enter ".url;.exe".
  • Exit Registry Editor and you're done. You may need to restart Outlook if it was running while you were doing this.

Remember: once you have enabled access to a particular file type, you are assuming responsibility for making sure that an attachment is safe before you open or run it.

Article C1864 - November 23, 2003 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

35 Comments
Dave Rowley
January 22, 2004 3:44 AM

Hi, just used the Level1Remove tip for outlook attachments blocking. Thanks, great working solution.

regards

Dave Rowley

shishon
May 2, 2004 1:04 PM

hi
done it but still i don't see the attached file.
am i supposed to see the attach that was sent befor the change was made?
i will be more then happy if someone can help me in retriving this file that outlook has blocked
i need it for my work
thank you
shishon

Leo
May 2, 2004 2:58 PM

You should verify that you've changed the correct version within the registrey (11.0, 10.0, whever corresponds to your version of Outlook). And you will need to exit and restart outlook. Assuming you've followed the instructions exactly (they are picky), it *should* work.

Alan
May 27, 2004 4:26 AM

Yes, but Outlook still forces me to save them to disc rather than just open them - how can I get round this as its a pain?
eg in my registry Level1Remove I have .doc and .xls which only allows them to be saved to disc. I do not have .ppt in the entry so I get the option to save or open.

Hemant Binnani
June 1, 2004 11:37 PM

Hey guys, it really worked.

Intially I set it in 10.0, but after doint the required changes in 11.0 for MSO2003 it is working fine.

Make sure that you check the file for AV before using it.

As usual MS is always creates the problem

Hemant Binnani

Narxx
June 12, 2004 10:00 PM

Thanks for the article, it works.
I always forget how to set it after formating my C:\ drive (where my OS is). So good to have Google finding me such useful pages. Again - thanks for the info. I'll probably come back to this page after my next format.

Have a nice day everyone.

Razer
June 22, 2004 3:25 PM

This will work to open .jpg automaticly?!

Leo
June 22, 2004 4:43 PM

Not sure what you're asking. Jpgs are not normally marked as unsafe attachments, and should generally just work. You might also want to see this article: http://ask-leo.com/archives/000255.html

Bob Blanchard
July 19, 2004 9:38 AM

Leo: I'm getting the same results as Alan (May 27, 2004 post above)--I can receive the attachments, but Outlook forces me to save them to disk before opening. Is there any way around this?

Leo
July 19, 2004 9:52 AM

I actually don't have an answer for that one yet.

Vandy
September 30, 2004 8:48 AM

Level1Remove does make the attachments visible but it's not designed to treat them as safe. Instead, you are prompted to save them before they can be opened. I've done a fair amount of web browsing and searching and can find no way around the forced savings. Americans are such lousey savers it's probably a good idea. Even so, I still find it obnoxious but I never was the lowest common denominator.

Ron
October 21, 2004 5:06 AM

I have the same problem as a couple of others. I did the regedit, which I have done for a couple of previous versions. But I still can't open JPGs. The only options offered are "Save to disk" or "Cancel".

This is a real pain and I hope someone can find a fix. I don't usually want to save any of the pics, just view them and delete the email. And I know that jpgs can now spread a virus, but I am willing to take that chance.

Rita Hoeffner
October 27, 2004 7:31 AM

I was having this same, really irritating, problem as well. Something said in an earlier post made me think of a possible solution that worked!

When Alan said he didn't have .ppt in the list Outlook opened this file with no problem. So...I just removed all the entries in that line, but left the Level 1 Remove change.

Everything opens just fine now! Geeze, Microsoft trying to save me from myself is almost more than I can stand! LOL Hope this helps others.

Rose
April 14, 2005 11:45 AM

I am getting same result as Alan even after regedit, I saw Rita's post and wiped out all entries but left the Level1Remove there and still doesn't open them automatically. If someone comes across a fix PLEASE POST IT! :)

Bruce
April 18, 2005 1:38 PM

Hi all -

I had the same frustration as Rose. I made all the REGEDIT changes, DLd a few "tools", but nothing. What I DID notice that .jpg, .jpeg, etc,. files were NOT listed in either the MS KB article's Level 1 (unsafe) list. Aha....

Looking at this article more closely:

http://support.microsoft.com/kb/829982

I realized that .jpg files are Level _2_ files. That is, they are not "unsafe" (just plain _blocked_), BUT they still force you to save to disk.

So, the solution: Using the same procedure to add "Level1Remove", add another registry key, called "Level2Remove" (no quotes), and enter the .jpg;.jpeg, etc extensions. Worked for me! (XPPro SP2, Outlook 2003).

Dean
April 21, 2005 3:04 AM

To fix the forced saving of zip files in Outlook 2003: in the Level1Remove you need to REMOVE the .ZIP value from the list of file extensions!

Doesn't seem logical eh? Well for some reason it worked for me.. hope this help some other folks too.

Tosca
June 8, 2005 2:10 AM

I had the same problem.
Entered both level1remove and level2remove and left them blank.

BINGO!!! Can open attachments!
Thank F for that!

Owen
June 10, 2005 5:13 AM

You may also be interested in downloading a shareware program called Outlook Picture Viewer which lets you look at multiple pictures with your own viewer directly out of Outlook. This is much better than having to open each individually when you get a group of pictures. Thanks for the tip about clearing the Level1 and Level2 entries. Now I can open anything!

Patrick
June 24, 2005 10:40 AM

The reason you can open your *.jpg files after you remove them from the level1remove string is, I believe, they aren't level 1 files to begin with. Putting them in that string makes them level 2 files, but if they aren't in the key they are no-level files.

Files that are level 1 to begin with, like *.exe files, can't be accessed if they aren't in the level1remove list. If you add them to a level2remove string you will still not be able to see them, and if you have them in both they will act as they did with only the level1remove string. I don't think there is a "level2remove" string. I think it does nothing and the no-level status of *.jpg files confused the posters above. No matter what I do I can't find a way to make true level 1 files accessible directly from the e-mail.

Mark
June 28, 2005 1:56 PM

Have any of you tried going to the Tools menu then Options selecting the Security tab and unchecking the switch that says

"Do not allow attachments to be saved or opened that could potentially be a virus" ???

I had this problem just yesterday and turning of the switch fixed it.

James
July 21, 2005 8:01 PM

I find it interesting that Microsoft considers Access databases among its "unsafe" attachments, but not Word documents.

Did they really feel that Word is less likely than Access to have a malicious program embedded? Or was it just that they couldn't possibly block the attachment of Word documents without blackening their own eye and driving everyone away from Outlook?

Therefore, (IMHO) attachment blocking isn't a true protection mechanism, and is therefore worthless. Users who think they are protected by this useless POC have a false sense of security that does them more harm than good.

Leave protection to an anti-virus program, and don't irritate me with half-baked "protection" mechanisms that get in my way more than they help me.

.

Max J
August 31, 2005 5:41 AM

Actually our installation of Outlook/Exchange 2003 does a tremendously successful job of blocking perfectly safe Word documents. Added entertainment value is added by the fact that going through all of this level 1 - level 2 nonsense has ABSOLUTELY NO EFFECT whatever. Zipping also has no effect; but resaving the same document as an RTF? That works.

Kudos to Microsoft for blowing another hole in my ongoing dream of software rationalization.

James
February 6, 2006 6:37 PM

There's alot of confusion re the level 1 and 2 remove stuff. For a definiatve understanding of the issue see:

http://www.infocellar.com/msoffice/outlook-attachments.htm

Roy van den Boorn
April 24, 2006 8:41 AM

Hi all,

can someone perhaps help me out here. I am trying to open an attached RTF file in outlook. The system gives the following error message when I try to do so:

"This object was created in Outlook. This application is not available to open this object. Make sure the application is properly installed and that it is not been deleted, moved, or renamed."

Now the strange thing is that the other people that receive the same email, have no problem in opening the attached RTF file. They have the same version of Outlook.

If someone could email me the solution (info@tunnelvision-web.com) this would really be appreciated!!!!!

Thanks all!
Regards
Roy

Julian
June 7, 2006 4:48 PM

Hi, I'm trying to grant the files permissions for all the outlook's users at a time, instead of doing one by one on the hkey current user, because I have a terminal server running severals Outlooks.
I'd like to know if it is possible, also if it is possible to open the file that I will allow to be opened without being saved into the harddrive first.
I really will appreciate any help.
Thanks in advance
Julian

Harun
January 18, 2007 12:59 AM

Export all messages to Outlook Express.

Simon
July 3, 2007 1:29 PM

Thanks - Just saved me losing business to the tune of $600!

SUAD
February 5, 2008 1:51 AM

Thank you for this good informaition , but still the problem exist , i can not oopen either url or xnk allatments in outlook 2007 .

Dave Cash
July 28, 2008 6:01 AM

Thanks for this, this will help us alot supporting our users.

Thanks from dmwworld.com

Jimmy
August 13, 2008 3:13 PM

This came in handy today. Trying to get at a SSL certificate file in a email attachment. I will link back to your site on my blog at http://www.qvlweb.blogspot.com
Thanks

Bob
December 4, 2008 9:45 AM

Your Tip works :) .. Thank you

Jeff
January 20, 2010 10:58 AM

Thank you for this clear and helpful tip. I was hoping it would apply retroactively to an email already in my inbox but apparently not. Also, I was surprised that I couldnt forward the message to another address and open the .pst file but I guess that makes sense as my server blocked it up front?

Yngve
May 29, 2010 2:16 AM

Thanks.
This solved my problem.
However .pdf files where not listed by outlook as dangerous files. Still my system kept blocking them until I manually listed .pdf with Level1Remove.

I will never cease to be amazed by all the silly and stupid things M$ software does witout requesting permission or atleast informing the user about.

Michael
December 1, 2010 12:00 PM

THANK YOU! How insane that there isn't a bit in the Outlook GUI somewhere to toggle this ...mmmm... "feature"! You da man, Leo.

G
March 11, 2011 6:28 AM

this was written fro 2003 or xp versions of office but it works for 2007 and probably 2010. 2007 is 12 in the registry and my guess is 2010 is 13.
Helpful Tip don't put quotes in the extentions list you type in not ".url;.exe" but url;.exe

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.