Helping people with computers... one answer at a time.

Some folks like to run programs maximized; taking up the entire screen. If a program doesn't do that automatically, here are some steps that may help.

How do I make sure that when I open any windows application, it opens "full screen" (maximized) ? It would be a time saver if I didn't have to always hit the maximize button.

Indeed it would. And while there are a couple of caveats, there's actually a fairly simple way to make this happen for most programs.

Right click on the shortcut or menu item you use to start the program:

Right click on a program shortcut

Now, click on properties:

Properties of a program shortcut

Note the item labeled Run that's set to "Normal Window". Change that to "Maximized":

Properties of a program shortcut, with Run Maximize shown

Hit OK.

The program should now start up maximized.

Naturally, you could also select "minimized" to have the program start that way instead.

As I said, there are a couple of caveats:

  • Some programs override this. By that I mean that when they start, they explicitly decide whether they want to be minimized, maximized or "normal". The upshot is that they effectively ignore this setting. You'll need to check with that particular program if there's a way to alter this behavior.

  • This works on programs, and shortcuts to program, but not documents or other files. For example if you have a shortcut to a Microsoft Word document on your desktop you will not see the Run option. However if you have a shortcut to Microsoft Word itself, you will.

  • Shortcuts in your start menu count. By that I mean, if in your start menu you have a shortcut to an application, you can right click on that menu item and click on properties, just as if it were a shortcut on your desktop of somewhere else.

Article C2910 - January 25, 2007 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

32 Comments
June
January 27, 2007 6:40 AM

I don't have a computer, I only have WEBtv. can I use the maximze button for all incoming message that are too small for me to read,(as I don't have windows?)

Charlie Griffith
January 27, 2007 7:07 AM

I've just tried your "always maximized" proceedure using I.E.7 and, when right clicking at the beginning (your first step) I get a very short, abbreviated drop-down menu which has "properties", but when that is clicked, get another truncated menu not at all like the one you indicate. Without the needed options. So, another classic frustration with I.E. Right at the start. Can you help this recent Geezer convert to C O M P U T E R S ?
Best regards
C.

Tom
January 27, 2007 7:24 AM

Duh! I was about to send this same question in, and it was just that?!?! Smack myself on the head. Thanks Leo! Now, I just need to figure out why my status bar in IE keeps disappearing!

chris faulkner
January 28, 2007 3:32 AM

Also part of the answer might be.... open C:\tools\folder options\view, uder advanced settings, click on Remember each folders settings.

George Philp
January 28, 2007 4:03 PM

I have used IE Maximizer from Jonstan Dahl for
maximize IE for a number of years.
The program is free and is available at the following web Site.
Thanks, George

http://www.jiisoft.com/index.asp

North
June 14, 2007 6:13 AM

Thanks, simple and effective.

Chris
October 22, 2007 9:03 PM

I have tried the above. There is no "Short Cut" Tab. Now what? Fact is, my Property box is no where simuliar to Loe's description.

juan
December 19, 2007 2:00 PM

very helpfull !!!

Markus
February 14, 2008 7:02 AM

When you right click on a shurtcut the tab you will be on from start is the shortcut tab. You will next to "Run" be able to choose Maximized

K H
November 25, 2008 4:00 PM

I have went through multiple web pages including microsoft found this web page and answered my issue.
god only knows why I could not figure this out !
the transition between a new computer and vista got me fluttered I guess
I just wanted to say thank you for posting this.

kdsdata
November 27, 2008 7:32 PM

I have done this, as it's them same as XP, however my Vista Home Premium version ignores the setting. All the windows, all the time. Any other suggestions? Any help will be appreciated, because I now have a 22" LCD screen and hate to have the windows open only in "Normal" mode.

Steve Hawes
January 6, 2009 9:37 PM

The correct shortcut to George Philip's link is :
http://www.jiisoft.com/iemaximizer/Download.aspx
And it does work.

M Cruz
February 5, 2009 4:35 PM

When I right click on explorer there is nothing that says shortcut on there. I have windows XP.
This is really making me nuts. I've also tried extending the corners and them closing and restarting and it keeps happening. Thanks for any help you can give.

Pete Ross
February 26, 2009 10:44 PM

If Windows do not open to full size in IE7/8, follow these instructions.

Open a webpage. Stretch it out to full size. Don't use maximize.
Choose any link on that webpage and right-click, select open in a new window.
Stretch that second window out to the desired size- don't use maximize.
Close the first IE window. Then close that second resized window. This should take care of the problem.

THOMCAT7777
May 26, 2009 4:34 PM

HOW TO,, PRESET THE SIZE OF SHORTCUT WINDOWS

RIGHT CLICK INTERNET EXPLORER,, GO TO PROPERTIES,, ON THE RUN LINE,, SET IT TO OPEN IN "NORMAL WINDOW"...

THEN OPEN IE-7 -- SET TO RESTORE DOWN,, = "THE MIDDLE OF THE THREE BOXES AT THE TOP RIGHT",, -- THEN,, USING THE MOUSE,, DRAG THE WINDOW TO THE SIZE THAT 'YOU WANT IT TO BE"...

CLOSE IE AND TRY SOME SHORTCUT'S... IT WORK'S ?? GO BACK TO IE PROPERTIE'S,, SET TO "OPEN MAXIMIZED".

Freda Wyss
June 19, 2009 2:29 PM

I use Vista - I can not get internet explorer or other web pages to open maximized. I tried your suggestion and it did not work. It worked okay in the past so I presume I have done something. Thank you

Jim Grim
July 5, 2009 4:41 PM

This does not work for all browsers shown, as soon as Vista closes, and restarts, any changes made are as they were when it restarts. The properties remain unchanged, the the actual results aren't there.

Besides, shouldn't Vista, by nature, "remember" the last view setting?

I don't use IE at all. I use Firefox, which this works for, as long as it is the default browser.

My original reason was to open all my folders and files views Maximized. This doesn't answer how to open anything in explorer.exe (not iexplorer) always maximized, which is a fair bigger problem for me! Isn't windows explorer considered an app too?

masaloi
January 26, 2010 1:04 PM

You can download AUTOSIZER from here.... http://www.southbaypc.com/AutoSizer/

singe
January 26, 2010 1:22 PM

Another simple way is to:
Oppen a Doc, broswer page or whatever.
Maximise it (apologies if you cannot)
Click on Cntrl AND then close it using the the Close (red cross) button at the top right of the screen.
When you open it, it has "remebers " to amximise.

Hope it helps.

Though I do use Autosizer on another laptop and like that too.

Steve Capps
January 26, 2010 3:40 PM

I have been happy with a little start-up application (free!) called IE Windows Maximizer. See
http://www.jiisoft.com/iemaximizer/Default.aspx

Terry
January 26, 2010 4:40 PM

I'd wondered about that off and on also. Tonight I did what you said and it worked perfectly.

tks

Pamkins
May 3, 2010 5:48 PM

I opened Incredimail and manually changed it to the size I wanted. Then clicked Control and the X to shut down. Then reopened and it opened exactly the size I wanted. Didnt like it maximized. YES YES YES IT WORKED!

Connie Panico
September 29, 2010 6:13 PM

Hi! This happened to me once before but for some reason I was able to maximize the page again?
Don't ask me what the blazes I did lol..but I did
something wrong to get my shrunken page and then
again to get it full screen? I tried what you said to do on here..but, unfortunately it did not work.
I know *patience* is a virtue..but lately I don't
have that much patience anymore (must be my age)
lol..

Jim
December 18, 2010 12:55 PM

(This is for Windows 7)
Right click on your internet explorer icon then mouse up to internet explorer and right click on it. Then click properites then go to the shortcut tab in the drop down box you will see run more than likly saying normal wind change it to maximized save and your done!

Steve
January 2, 2011 11:55 PM

Its IE problem not windows try a new browser it worked for me.

JP
May 13, 2011 3:26 PM

I've been having the same trouble (and I recall having this trouble once before on another laptop I used in previous years). I tried to follow the steps laid out here but discovered they didn't work for me. I think part of the problem is I'm using Windows Vista, so right-clicking on the Windows application I want to maximize (in my case, MS Word) gives me a different menu. I did manage to find the selection that gives me the options "Normal", "Minimized", and "Maximized", but when I changed it the first time it told me I needed to be an administrator to change the settings. Then I went into "Properties" and selected "Administrator" under "Security" options and tried to implement the same change...but then tested it by opening up a new Word document and it still opened up at half-size. Arrrrrrrgh!

JP
May 13, 2011 3:33 PM

(Post-script to accompany my previous post:)

...So what else can I do to fix my particular problem?

LOL
June 8, 2011 2:55 PM

click and hold a corner of the window you want maximized. drag it to the size you want. hold down ctrl and click file exit (do not use the x in the upper right). your window should open the same size now.

Mark
June 22, 2011 7:36 AM

LOL,
Thanks for the memory jogger. I recall holding a key down while closing, but forgot which key. Also, this only works when you manually resize the window instead of clicking the maximize button. Thanks.

John
June 24, 2011 7:35 PM

I tried to "click and hold a corner of the window(Explore) from start at the bottom left corner of the desktop I want maximized. drag it to the I you want. hold down ctrl and click file exit but when reopening it went back to small.

Lucy B
August 4, 2011 2:19 PM

THANK YOU for this, I have been annoyed by this for weeks!

Don C
May 2, 2012 7:56 PM

I tried the solution in IE browser properties. I tried draging it and starting it with the cnt. button. I tried draging it and starting it with the shift button,but still comes up minimized. I'm running windows 7 and IE8.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.