Helping people with computers... one answer at a time.

IE9 takes advantage of your graphics card to draw on the screen more quickly. It's nifty when it works and frustrating when it doesn't. We'll turn it off.

My Toshiba laptop was bought in January with Windows 7 & IE9 installed, but the IE9 has never worked. I've rolled back to IE8 and that's fine (except now Gmail doesn't support IE8). Windows Updates demands that I install IE9. The problem with IE9 is that the tabs load and show properly across the top, but the screens below are blank. Some windows show a couple of pics from the website in the tab, but then these won't go away even if you change the tab... it's just a frozen blank screen. I can't do searches or view anything. I've tried uninstalling and reinstalling; I've also tried resetting to default settings - no luck.

It is possible to tell Windows to stop bugging you about the IE9 update.

The problem with that is that it's not really solving anything, just delaying it. It might be a fine interim solution, but sooner or later, you're going to want to update to IE9 or one of its successors.

The symptoms remind me that IE9 added some functionality that - when working properly - would make it faster. Perhaps it's not working properly.

The good news is that we can turn it off.

Hardware acceleration

Hardware is faster than software. Software is more flexible, but as game developers have known for years, if you can have a piece of hardware that's dedicated to helping you do what you do - like perhaps draw things on the screen - your application can run significantly faster.

I mention games and drawing things on the screen because that's exactly what IE9 has started to take advantage of. If your machine has a video card with what's called a "GPU", or Graphics Processing Unit, IE9 may elect to use it to perform some of the work of putting things on the screen.

The net result is that IE9 is faster and uses less of the CPU (your computer's Central Processing Unit), leaving that more available for other programs.

When it works.

Turn off acceleration

In IE9, click the gear icon and then Internet options:

Internet Options menu item in IE9

In the resulting Internet Options dialog, click the Advanced tab:

Use software rendering instead of GPU rendering

At the top of the advanced list of options in a section labeled Accelerated graphics is a checkbox: "Use software rendering instead of GPU rendering".

Make sure that checkbox is checked, to force IE9 to do things in software rather than using the GPU.

After changing it, the asterisk means that you'll have to restart IE9 for the change to take effect.

See if that doesn't help things.

The Result

I don't always hear back from folks, but I asked this particular person to let me know because I wasn't 100% sure that this was the actual solution.

The response:

It worked!
Thank you soooooo much!
Now I can use IE9 for the first time and stop Windows from hassling me about updating my IE.

Put simply, IE9 wasn't compatible with the graphics card (or vice versa, depending on how you want to look at these things). Simply disabling the accelerated graphics returned IE9 to the older way of doing things.

Article C4973 - November 5, 2011 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

14 Comments
Mike Choma
November 8, 2011 8:46 AM

I have an issue with IE9 too. When I try to open a new tab, I receive a script error message all the time. The weird thing about this is that it only happens on one of two user profiles (both are administrators). My profile runs IE9 without any problems but running IE9 in my wife's user profile causes the script errors. For this reason I still am running IE8 on my Dell Inspiron 15R laptop running Win 2007 64-bit. Could this solution re: hardware acceleration be causing the problem with my computer too?

Probably not. My guess is you have a different set of browser addons installed, or have different anti-malware settings that often interfere.
Leo
10-Nov-2011
Drew
November 8, 2011 10:33 AM

When you have problems with Microsoft software it's worth visiting the Microsoft Fix it Solution Center. There are downloads or information to fix common problems.
http://support.microsoft.com/fixit/#tab0

Doug
November 8, 2011 3:01 PM

Shouldn't that be "make sure box is checked" concerning turning "off" hardware acceleration ??

Oh. Crap. My bad - thanks for catching that. Off to fix it...
Leo
10-Nov-2011

sue
November 8, 2011 3:44 PM

help - all the time, IE8 pops up and wants to install - its already on and being used - how do I stop it popping up?

DaGeek247
November 8, 2011 4:39 PM

Quite frankly, Internet Explorer is NOT the best browser out there. If I had this problem, i would have done my best to disable IE, after getting a different browser. It may be good for less-tech savvy users who just want things to "Just Work", but it has problems with even that.

The best browser for speed and ease of use is chromium, or Google chrome. Firefox is the runner up, but only because its less user friendly. If you depend on one browser to access the internet, (IE or not), then you are asking for trouble.

Carol
November 9, 2011 6:57 AM

I was glad to see this issue addressed as I have had the same problem with IE9; unfortunately, the solution from Leo doesn't work because the "use software rendering instead..." is checked AND grayed out so I can't uncheck it. I loved Firefox until the new version rendered my Google Toolbar unuseable (and I do use it) so I'm left with IE9. Don't like Chrome and Opera much either.

Glenn P.
November 10, 2011 5:02 AM

This is for Doug, who asked:

"Shouldn't that be 'make sure box is checked' concerning turning 'off' hardware acceleration ??"
Doug, examine the graphic of that Internet Options  dialog again -- carefully, this time.

Under Accelerated graphics  is the line Use software rendering instead of GPU rendering. Right?

Well, to stop using  this, you have to uncheck  that option.

I know, it can be really  confusing... but do you understand it better now?

Doug
November 10, 2011 7:02 PM

Glenn... I did look at it carefully. And I tried (just to make sure before I sent the message to Leo) it checked and unchecked. I stand by my remark, and I noticed that Leo has changed it now. Yes, it can be confusing, evidently...

Ken
November 12, 2011 10:57 PM

Google Chrome is good and fast, except if you want to print something. Then it is not very good. It does not have any way to set print parameters. Whenever I have something to print I copy the link and past it into IE9, then set the print parameters as I need and print.
I do not know why Google does not improve Chrome printing?

Glenn P.
November 13, 2011 11:35 AM

To Doug (and to Leo as well!):

You're BOTH right! Aaarrrggghhh! I misread -- not a common occurrence. Yes, it can get confusing. I freely admit that! And I got it wrong! Ugh!     :(

If I may be permitted a (slightly relevant) digression upon my favorite topic, parliamentary procedure, this is precisely  why parliamentary motions are not  allowed to be worded negatively: because they can cause terrible confusion when voted on. For example -- "I move that we do not attend next month's protest rally." -- "All in favor, say 'aye'." Is a "yes" vote FOR going to the rally or AGAINST it...? It's exactly the sort of binary confusion that can arise when propositions are negatively worded. Instead, the wording should be (for example) "to boycott" the rally, which is an affirmative wording.

The actual problem with the Internet Options  dialog above isn't any actual  negative wording, but rather an implied  negative wording, which is inherent in the words "instead of GPU rendering".

As long as you're thinking in terms of "Starting software rendering", everthing is fine; but think in terms of "Stopping GPU rendering", and things quickly start to get weird. To "stop GPU rendering" is a negative action, which is why checking the box is so darned confusing.

It might, I think, have helped to emphasize the separateness of these actions by setting them off -- by, for example, putting the second one in parenthesis:

               "Use software rendering (instead of GPU rendering)"

That, I think, might  have made things slightly clearer...

I thought about it some the other day and decided that I'd have used a radio button control - Use Software/Use GPU - and selecting one deselects the other.
Leo
13-Nov-2011
Glenn P.
November 14, 2011 7:14 AM

A Radio Button! Yeah, that'd do it. But then, one seldom sees one of those  things in Internet Options; there, the paradigm seems to be "checkboxes all the way..."     :(

Yeah, though it's interesting - there is a radio button in the Windows Explorer Advanced Options list, in amongst a lot of checkboxes. Very similar. That's what made me think of it.

Leo
14-Nov-2011
Glenn P.
November 15, 2011 1:05 AM

Too bad -- as you yourself have oft pointed out! -- that Windows  Explorer isn't the same as Internet  Explorer!

Scott
November 15, 2011 11:31 AM

@Ken,

Try ctrl-shift-p in Chrome. That should bring up the familiar box.

Doug
November 15, 2011 3:45 PM

To Glenn P.
The thing of it is, the check box thing did not confuse me at all. I spotted right away that it was a simple mistake. Nothing complicated at all. I really see no need in changing anything.... If it isn't broken, don't mess with it.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.