Helping people with computers... one answer at a time.

Making the NUMLOCK to default to ON in Windows 2000 involves a simple fix in an obscure place.

I have an HP PC running Win2000 Pro. The num lock state is off when it boots up. I'd like to change it so that num lock is on by default. Where would I change the setting?

This qualifies as one of Windows more obscure settings. It's not in Control Panel, and it's not in the registry ... it's in the Environment.

Here's how and where:

  • Right click on My Computer

  • Select Properties

  • Click on the Advanced tab.

  • Click on Environment Variables

  • In the System Variables section, click on New...

  • The variable to be added is called NUMLOCK, and the value is ON

"OK" your way back out of those dialogs, and the next time you reboot your keyboard should default to having Num Lock ON.

Article C2254 - January 5, 2005 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

6 Comments
Bear
January 7, 2005 10:22 PM

Or the standard way is to set it to on from the System Bios

Leo
January 7, 2005 10:54 PM

Unfortunately that setting doesn't always carry through. And not all BIOS's have it.

Steve
August 29, 2005 7:01 AM

To enable NUM LOCK before a user logs on, use the steps below.

1. Run Registry Editor (Regedt32.exe).
2. Navigate to HKEY_USERS\.Default\Control Panel\Keyboard.
3. Change the value for InitialKeyboardIndicators from 0 to 2.

Ancelin
October 20, 2005 5:04 PM

Hi Leo,
I tried the following and didn't work.....

Right click on My Computer
Select Properties
Click on the Advanced tab.
Click on Environment Variables
In the System Variables section, click on New...
The variable to be added is called NUMLOCK, and the value is ON

I used the suggetion posted by Steve on August 29 2005 and it worked.
I also changed HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyboardIndicators from 0 to 2 inorderd to keep the NumLock stay ON.

Thanks for the Help
Ancelin

Phil Tkachuk
March 16, 2007 3:53 PM

There are actually TWO distinct places for Windows to remember the state of the keyboard indicators. One is before logon, the other is after logon.
According to Microsoft to change the default settings requires using the Registry Editor. This is only true if you want to change the default settings for a NEW user at First logon. See: http://support.microsoft.com/kb/q154529/ It does not change the settings for existing users already using the machine. It would have to be changed in the All Users section of the registry, but I have not investigated if this is possible.

First, you need to have Admin rights to the computer you are using…it won't work otherwise...
To get Windows to remember your preferred keyboard settings do the following: (applies to Windows 9.x, NT4, 2000, XP and I suspect Vista as well, (but as I don't have Vista yet I haven't verified this))

After you have logged in, set your Num-lock the way you like it - do a Alt-Ctrl-Del sequence and select Logout. The trick is the Alt-Ctrl-Del sequence - logging out of Windows using Start-Shutdown-Logout doesn’t cause Windows to remember the keyboard settings, Alt-Ctrl-Del & Logout does (or Shutdown or Restart).

To get Windows to remember the Keyboard settings for the Logon Screen (before Sign-on), with the Sign-on screen showing on the desktop, set the NumLock the way you want it, and use the option for Shutdown or Restart. As it takes a Alt-Ctrl-Del sequence to get to the logon screen, the Shutdown or Restart will cause Windows to remember you want the NumLock on or off at the Logon Screen.

I stumbled across this after several months of fruitless searching - Microsoft is wrong, this is just another undocumented feature - they think they know better and override the Bios settings…along with other undocumented features and default settings that frustrate many users.

Frank Quesada
May 1, 2008 10:06 AM

Just tried this on an XP machine and it worked like a charm.

Thanks!

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.