Helping people with computers... one answer at a time.

IE9 will notify you if it thinks you can speed up browsing because add-ons are taking too long to load. We can change the definition of "too long."

I am running Windows 7 Pro, 32 bit. Every time I open IE-9, a pop-up appears, asking me if I want to speed up browsing by disabling add-ons. How do I get rid of this?

Unfortunately, you can't.

But we can definitely make it significantly less likely to happen.

The problem is that this isn't just a simple informative notification. It's actually telling you that some of the add-ons currently loading in IE are taking too long to load.

The "Speed up browsing" notification

The "Speed up browsing by disabling add-ons" message isn't just a simple "hey, did you know?" kind of message that IE would display once and then never again.

It's actually trying to tell you something about your current configuration.

'Speed up browsing by disabling add-ons' message

Internet Explorer actually keeps track of the amount of time each add-on takes to load when it starts up. If one or more add-ons take too long, the message is displayed.

There's no way to turn that off.

However...

We can change the definition of "too long."

Configuring the "Speed up browsing" message

The next time that the message appears, click the Choose add-ons button.

Internet Explorer Choose Add-ons dialog from the 'Speed up browsing' message

As you can see, it'll present a list of add-ons that were loaded when IE started.

Included is the amount of time that each add-on took to load. In my example above, you can see that while the SnagIt add-on loaded almost instantly, the LastPass Toolbar took just over two and a quarter seconds.

Of course, you can disable add-ons, which is what this whole process is designed to encourage.

However if you don't want to lose the functionality provided by the add-ons that you have, you might not want to do that. You might be willing to have an add-on take a couple of seconds to get started.

Instead of disabling add-ons, locate the time the control near the bottom of the dialog:

'Speed up browsing' delay threshold

"Tell me when the delay caused by add-ons exceeds:" is the source of our troubles. The "Speed up browsing" notification is Internet Explorer telling you that the amount of time taken by add-ons to get started exceeded this amount of time.

Change the default value of "0.20 seconds" by clicking it and selecting something larger ... much larger.

Let's face it, 1/5th of a second isn't a lot of time; it's easily exceeded by add-ons that need to communicate with a service on the internet, like LastPass does.

I set mine to 10 seconds, the maximum allowed.

If an add-ons actually takes more than 10 second to load, I probably want to know about it. Otherwise, the "Speed up browsing" notification never appears.

It's not really disabled, but ... close enough.

Article C5068 - February 4, 2012 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

10 Comments
Douglas A. Brace
February 4, 2012 6:35 PM

After a very quick Google search with "internet explorer 9 disable speed up browsing notification" as the search words, I found a way to completely disable it if you have Windows 7 Professional, Enterprise, or Ultimate.

http://www.onlinecomputertips.com/windows/ie9_addon_message.html

It requires access to "Local Group Policy Editor" or "gpedit.msc."

Once in "Local Group Policy Editor," on the left side navigation go to...

"Local Computer Policy" --> "Computer Configuration" --> "Administrative Templates" --> "Windows Components" --> "Internet Explorer"

... search for "Disable add-on performance notifications," then double-click on it, and set it to "Enable."

Apply all the change and you are good to go. You may have to restart or log off for the change to occur.

C Rowe
February 7, 2012 10:58 AM

That's really helpful - I've been having those blasted notifications come up all the time too. Thanks Leo

Phil
February 7, 2012 11:10 AM

Actually, I got it to stop at the first notice by clicking on the drop-down arrow on the "Ask me later" button and there was a selection disabling the notification. I apologize that I can't be more specific but since it is no longer coming up, well... ;^)

Michel
February 7, 2012 11:20 AM

Just in time! I was tired to see this message and I never take care of it.

I like your answers: not too complicated or too long to read, and you also explain "why".

This is a sign of quality!

Thank you.

Saetana
February 7, 2012 9:17 PM

Thanks for that Leo, I usually click Ask me later, which gets rid of it for a while but, like a bad penny, it always turns up again. I shall take your advice next time it appears as the only add-ons I run are essential ones (non-essentials are disabled except for the rare occasion I need them). To check which add-ons are installed and whether they are enabled or disabled (in Internet Explorer 9) click on the cog icon at the top right corner of your browser window and then click on Manage Add-ons to see them broken down into categories. This does not however let you know how long they take to load.

mabel
February 8, 2012 12:19 AM

MANY THANKS Leo... I too have had this problem and just 'disabled' it to get rid of it but now I will go further! I appreciate your brief and to the point answers - keep it up! Mabel.

Kim
February 8, 2012 3:03 AM

Thanks Leo, I use IE occasionally and that message was driving me nuts...

Kim

Don
February 8, 2012 6:10 AM

Wow! I have to echol the prior comments about something that bugs you, but you just tend to ignore it after awhile. Thanks.

Glen
February 9, 2012 7:55 AM

I don't use IE much, but this is a great tip!
Thanks.

Judy
February 10, 2012 12:41 PM

Outstanding. Thanks for the answer to something that almost everyone wants to know. One of the attendees at my computer club meeting last Wednesday asked the question and I didn't have an answer for him. Now I do, as well as a suggeston that all of my members subscribe to Ask Leo!

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.