Helping people with computers... one answer at a time.

The IE8 Welcome screen allows you to set up a few initial IE settings and then it goes away. Apparently you MUST setup, or it'll keep coming back.

I recently downloaded IE8, and it keeps displaying the "Welcome to IE8" instructions. How can I stop it doing this?

It's annoying, and I believe it's gone in IE9 (I could be wrong, or that could change since at this writing IE9 is still in Beta).

It took me a moment to figure it out as well.

In a bit of draconian thinking ... you will submit.

Forever Welcome

Here's the dialog you're seeing each time you start up:

Welcome to Internet Explorer 8 dialog

Though I suppose if you're having this problem you're all to well aware of what that thing looks like.

"Ask me later" just postpones the issue. It will, indeed, ask you again later - presumably the next time you start IE8. That's kinda the problem we're tying to solve.

Closing the window using the 'x' in the upper right seems to be about the same as "Ask me later" - this was my approach since I didn't want it to "Ask me later", and I also didn't want to hit "Next". No luck - the dialog came back.

"Next" is your only option to make it go away permanently - you must comply.

Setup Internet Explorer 8

Here's what you'll go through, and my suggested answers to what you'll be asked.

Setup Internet Explorer 8 - Suggested Sites

Unless this sounds interesting to you, suggested sites is just a distraction - I turn it off.

Setup Internet Explorer 8 - Express or Custom?

Take a close look at what the express option does to for you. If that's what you want then by all means, go ahead and take Express. Me? I have different choices, so I choose custom.

Setup Internet Explorer 8 - Default Search Provider

Microsoft naturally wants to promote Bing as their search engine, but if you have other ideas (as I do) choose the option to select another search provider later. (Note that if you fail to then your default provider will stay as is - in all likelihood, Bing.)

Setup Internet Explorer 8 - Search Provider Updates

I'm not even sure why this is an option. There's nothing wrong with taking the updates to the list of possible search providers, even if you never plan to change providers.

Setup Internet Explorer 8 - Choose Your Accelerators

Accelerators are keystrokes that allow you to do something quickly - blog, map, email, whatever - from a web page. I never use 'em, so I choose to turn them off. If you do use them, then either choose the default all-Microsoft set of tools, or select the option to choose differently after setup.

Setup Internet Explorer 8 - Compatibility View Updates

Internet Explorer is notorious for not following proper HTML standards when displaying web pages. IE8 changed the default to be ... closer. Not perfect, but closer. Or at least different. The upshot, though, is that some websites don't display properly with the new more correct display rules. Compatibility view changes the behaviour to be "the old way". One way that compatibility view is controlled is by a list of known websites that IE8 can periodically download and update. Why not? I'd enable this.

And there is it! The Finish button!

Click it, and....

Not Quite Finished

You're not finished.

If you look carefully there's a new tab opened in IE8 since we elected to select our own search provider:

Add Search Providers to IE8

Naturally I click on the one I want (Google), and am then presented with a confirmation of the download required:

Make Google the default Search Provider in IE8

Make sure that "Make this my default search provider" is checked. By default it isn't, meaning you'd still be left with Bing for that task.

After doing so, the icon and text in IE8's search box changes as expected:

IE8 - Google as the search provider

Now. Finally.

You're done.

You should not see that "Welcome to IE8" dialog again, unless you explicitly reset your IE back to default settings.

But by doing that, well ... you're quite literally asking for it.

Article C4671 - December 4, 2010 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

13 Comments
Russ
December 7, 2010 8:29 AM

This was perfect timing as a web sit I need to view keeps telling me it is best viewed in IE8... Since I have not completed the download and install of IE8, this will be of benefit! Wa-hoo! These are the kind of articles I love.

Dick Thomas
December 7, 2010 8:42 AM

I've got a MUCH easier solution, Leo: Disable IE and use Firefox - been using it since ver 1.x!
It does tick me off that some software insists on calling IE vs my default, but I can work around that.

James Richter
December 7, 2010 9:08 AM

You can't change the home web page in settings to fix this problem? Seems a lot simplier.

The home page is only part of the problem. That IE8 introduction is a popup wizard that must be completed.
Leo
07-Dec-2010

Nick
December 7, 2010 9:34 AM

Here here to Dick Thomas - IMO Firefox beats IE hands down!

However, I have set up my IE to default to the "InPrivate" mode which helps towards preventing it "spying" on the software I've been using, and also set the Privacy settings to stop collecting the info. Plus I have checked the "Empty Temporary Internet Files folders when browser is closed" box in the Advanced tab.

Paranoid? Possibly - but that wouldn't mean "they're not after me" would it!

Dave Markley
December 8, 2010 6:27 AM

Being a PC repair tech, I am constantly running into this problem, as well as "some Adobe thing keeps popping up wanting updated", and other equally annoying questions. My question is 'Why wouldn't you want to update to IE8?'. Internet Explorer 7 was to browsers what Vista was to operating systems. (In my opinion, garbage) Microsoft had so many problems with IE 7 that it actually made a program which would stop Windows Update from automatically installing IE7! IE8 is a vast improvement, not to mention it is much more pleasing to the eye than previous versions and was the first version of IE to use 'tabbed' browsing. It's simple to just click 'next' and install it, so why not? Just follow the simple prompts, keeping your settings as they were, and you are done, no more 'pop up'. If you use IE regularly, I'm sure you will be happier with IE8.

Also, keep in mind that 'InPrivate' and similar settings in other browsers are only a small
measure toward privacy. Anything you do online is still tracked (unintentionally or not) by your ISP, etc. There really is no such thing as 'private' browsing.

Rich
December 8, 2010 7:07 AM

Easiest way: use Firefox or Chrome.
Ditch Gates' garbage. Done, end of story.

Glenn P.
December 9, 2010 1:05 AM

My poor Mom (who is elderly and computer illiterate) was having this problem; her problem actually proved to be deeper -- a registry setting wasn't "sticking"; seems there was a corrupted (or at any rate mis-set) permission issue. Once I ferreted out and corrected that (and cleared -- or, was it "set"? -- the relevant registry flag) the problem went away.

In other words, Leo, in certain isolated cases the problem might be deeper than having to jump through Micro$oft's hoops -- a genuine, bona fide  glitch might be involved. Might want to add that to your page as a troubleshooting option to be investigated if the prompt doesn't go away after all hoops have been jumped.

Michael Delheimer
December 9, 2010 12:03 PM

I am not thrilled with IE8, I keep it but use Firefox as my main browser. Much faster and really no issues.

P. Dhir
December 12, 2010 2:53 PM

According to Mozilla website, if you have Windows 7 (64 bit), you can't use Firefox. That program is till under preparation. Does anybody have an idea as to when it will be ready. Thanks.

I run 64-bit Windows 7 and Firefox works just great. It has for months. My guess is they're talking about a 64-bit specific version, which is not required - you can run the existing 32-bit version just fine. I do.
Leo
13-Dec-2010

jeenu
February 3, 2011 5:18 AM

I think the simpler solution is as follows

1. Launch the Group Policy Editor
Run gpedit.msc

2. Expand the following branch:

Computer Configuration | Administrative Templates | Windows Components | Internet Explorer
3. Double-click Prevent performance of First Run Customize Settings

4. Set it to Enabled, and select Go directly to home page.

5. Click Apply, close the dialog and exit the Group Policy Editor.

dafne
March 18, 2011 10:33 AM

If I have "live" (MSN product) as my email, should I still click "Turn off accelerators"? I want to turn it off but I am afraid I will not be able to use my "live" email. Thanks.

G. Walsh
June 6, 2011 7:13 AM

This did not work for me. I did everything.
I set Google as the default, Bing and MSN Live as 2, 3 and 4, etc. I also have ZoneAlarm and I understand that there is a conflict between ZA and IE8.

WilyCat
June 24, 2011 11:43 AM

I followed your directions. WOW! Worked great. Thank you, thank you.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.