Helping people with computers... one answer at a time.

I want to be able to send a photo as an attachment, but not have it automatically visible when the recipient opens the email. I sent a message to myself with a photo as an attachment and when I opened it, the photo was shown as an attachment, but it was also opened at the below message text.

It seems like overkill to me. If I send six photos as attachments, then the recipient will get six attachments and six opened photos below the message.

How do I stop this behavior.

Well, the short answer is: you don't. You're trying to control a feature that may or many not even be present in your recipients mail program.

But there are some games we can play.

Many mail programs have this feature, Outlook Express being a prime example. Assuming that images aren't blocked by OE for security, it will automatically display attachments below the message body when you view a message. Note that these aren't additional copies of the photos, they're just the attachments automatically displayed for you. Outlook Express is trying to be helpful, and save you the step of opening each attachment to view it.

Contrast that to Outlook which does not have this feature. I get requests for it regularly, so I know the it's popular.

I know of no way that you, as the sender of the email, can control this feature directly. If you send a picture as an attachment, it may be automatically displayed if the feature exist and the settings are right in the recipients mail program.

"I know of no way that you, as the sender of the email, can control this feature directly."

Now, if you really, positively, want to make sure that the images aren't automatically displayed, then don't send them as images. Use a "zip" utility to bundle them into a ".zip" file. Normally we think of zipping a file to compress it, but since most images such as ".jpg" files are already compressed, the file probably won't get much smaller, if at all. However the result will be a zip file, not an image, which you would then send to your recipient as an attachment. Their mailer won't automatically display it.

The down side is that your recipient will have to un-zip the file before he or she can view the images.

As kind of wacky an alternative you could simply rename the files before you attach them. For example rename "picture.jpg" to "picture.leo", and the recipient's mailer won't know what to do with it. The type of file is indicated by the extension. A ".jpg" file is an image, and the mailer acts accordingly. A ".leo" file? Who knows? Certainly not the mailer, so it shouldn't display the image that it is.

Again the down side is that your recipient will need to rename the files back, for example renaming "picture.leo" to "picture.jpg", before they can view them.

Article C2578 - March 3, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

12 Comments
Cliff
March 7, 2006 8:09 PM

> The down side is that your recipient will have to un-zip the file before he or she can view the images.

The real down side is that you never know if Mickeysoph is going to change Outlook Express so that even the contents of ZIP files get displayed, the same way that the contents of ZIP files now get displayed in XP's Search results (unless you are savvy to some rather slick and obscure wizardry).

Take care!

Cliff the CyberCynic

elle
March 16, 2007 4:23 PM

not tried this but have been told this works
regedit
HKEY_CURRENT_USER\Identities\{GUID}\Software\Microsoft\Outlook Express\5.0
where {GUID} is a unique alpha-numerical string corresponding to your identity.
Set the DWORD value for "Automatically Inline Images" to 0
create it if it is not there

Wendell Gunn
May 4, 2007 1:35 PM

Based on my limited experience, it appears that the picture shows in the body of the message when it is OPENED in Outlook Express, regardless of the source, Outlook or Outlook Express. (This is what I am trying unsuccessfully to stop.) This does not happen when the mail is opened in Outlook.

IAN BAILEY
July 9, 2008 3:28 AM

When i am trying to send photos as an attatchment to an email it keeps saying error as the photos are the wrong size how do i cure this?

Joe
September 9, 2008 8:10 PM

The tip from elle (regedit) worked perfectly

Pip
September 19, 2008 10:11 PM

How do I keep attachment out of message body?

Pip
September 19, 2008 10:30 PM

Outlook: How to prevent attachments from showing up in typing area of message body?

mrm
April 18, 2010 9:04 AM

To prevent seeing picture attachments in outlook express messages you receive you can tick the box in the: tools - options - read tab to "read all messages in plain text" - the pictures will not then open until you click on the attachment icon for each picture --will not stop display in the receivers email, but you can at least tell them how to stop it happending in Outlook Express

Bill Geraats, Unionville, ON, Canada
January 12, 2011 7:42 PM

Here is a solution that works with 'Outlook Express', but I have no experience with 'Outlook' or 'Web Clients'
After you have selected your pictures for entry on the 'Attach' line, click on 'Format' in the top command line. A Format panel shows up, and at the bottom of that panel, you'll see the option: "Send pictures with message".

Make sure that this option is NOT selected by a check mark. If it is, then de-select this option, and your pictures will show below the text area. They will then only be carried as JPG pictures in your Attach line for the recipient to open them.
This is not necessarily a permanent setting, and must be checked for every E-mail you send with JPG pictures attached.
Best of luck.

josil
February 6, 2011 10:55 PM

Bill G fm Ontario provides the best solution for yet another Microsoft pain. If you send a bunch of pics with the pics showing in the msg, there are email clients out there (e.g., yahoo) who reject it outright or aggressively treat it as spam or even think it's a virus. But apart from changing every extension and then asking the recipient to do the same, Bill gives the least painful solution. I wish MS would stop helping me!

Allan B
December 17, 2012 1:09 AM

I am looking for the opposite solution, I have a picture which i wish to be opened automatically when i send a email, its a christmas card, but when i send it to outlook it keeps it as a seperate file, so in essence i am sendign a blank mail with an attachement. Is there anyway to sort this out.

Thanks,

Mark J
December 17, 2012 10:34 AM

@Allan B
This article might help with that:
Why don't pictures show up in the emails I send or receive?

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.