Helping people with computers... one answer at a time.

There are times when the disk checking utility needs to run before you boot into Windows. Sometimes it seems to get stuck and does so every time.

I have a two year old laptop running Windows XP. I had run "Defrag" and also clicked on the check drive for errors option, which was then scheduled at next restart.

Now this scan program runs every time I start up. How can I shut this off?

Good news: we can turn it off.

Bad news: it means editing the registry.

The "I'm not so sure" news: you shouldn't have to. It should have turned itself off, and I'm concerned that this might be trying to tell you something.

Checking your disk for errors requires that the checking utility have exclusive access to the hard disk. That means that even Windows can't be accessing the drive for any reason. If the disk drive you're checking is the drive on which Windows lives, the error check is then "scheduled" to happen automatically the next time you boot, before Windows loads. It looks much like this while it's running:

Chkdsk running at system boot time

"It's possible that there's an issue preventing the scanner from un-scheduling itself."

It should happen once. When the utility completes successfully, it should remove that request to run again on boot up, and then reboot. In other words, the next time you boot, which would be upon completion of the scan, it shouldn't check again.

Before I tell you how to turn it off, I want you to watch it one more time, this time paying particular attention to any error messages that it may produce before it completes. (A digital camera snapshot of the screen, as I've done above, is a great way to preserve the error massages before they disappear as the boot continues.) It's possible that there's an issue preventing the scanner from un-scheduling itself.

In order to disable the scan we'll be making changes in the Windows registry. Step one should be: back it up. This Microsoft Support article Description of the Microsoft Windows registry includes pointers to the recommended ways of doing so.

The short version, for those who are ready to dive into the registry: we're going to change the value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute to autocheck autochk *.

Step by step that means:

  • Start the registry editor by clicking Start, then Run, typing in regedit and pressing OK. The result will be similar to this:

    Registry Editor at top level

  • Click on the boxed plus sign [+] in front of HKEY_LOCAL_MACHINE. That will expand and look something like this:

    Registry Editor with HKEY_LOCAL_MACHINE expanded

    Don't worry if your instance of Regedit already had some of these expanded; it remembers the last setting. Just follow along as if it hadn't been, expanding the nodes that we need if they're not already expanded.

  • Expand (by clicking the boxed plus sign in front of) SYSTEM

  • Expand CurrentControlSet

  • Expand Control

  • Now click on Session Manager, which is listed underneath Control and you should see something like this:

    Registry Editor open on HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

  • In the right-hand pane, double click on BootExecute. This contains the instruction that we want to remove. You should get an edit dialog much like this:

    Registry Editor editting the BootExecute setting

    The command "autocheck autochk /p \??\C:" is what we want to change.

  • Change replace the "/p \??\C:" with an asterisk (*). The resulting command, "autocheck autochk *" in the dialog looks like this:

    Registry Editor editting the BootExecute setting complete

  • Press OK to dismiss the edit dialog.

  • Close Registry Editor

Now, on your next boot the disk checker should not run.

I say "should" because there are still things that may cause it to run anyway:

You didn't shut down your machine cleanly. Perhaps your machine crashed or suddenly rebooted. Or perhaps you were in a hurry and turned off the power before Windows said it was safe to do so. In both cases Windows may not have finished updating information on the hard disk on shutdown, so it must check the disk on start up to make sure that everything is ok.

The disk may be failing. It's sometimes the case that a disk drive, as it starts to fail, will do so in a way that causes Windows to notice and run the disk checking utility on start up. It's not common, but it can happen.

Article C2990 - April 9, 2007 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

34 Comments
Dan Ullman
April 10, 2007 9:09 AM

I have never had to do this in XP but there is an old 98 trick you might try. Start up in windows safe mode and let the scan disk run. If something flaky is running after the system boots that is causing windows not to change the "autocheck" entry it should not run.

Ravi Agrawal
April 14, 2007 7:35 AM

Leo, don't you think there's something called "setting the Dirty Bit" in Windows XP that does the work of rechecking it everytime.


http://www.uninets.net/~blaisdel/whistler12.htm#DirtyBit

See the above link.

Ravi.

Alv
April 27, 2007 6:47 AM

I have similar problem, and i know the cause. One of my hdds is hooked through bad ide cable (actually it sits in low-quality removable hdd rack). And now my XP keeps checking that hdd on every reboot (and doesn't find any errors).

Interesting fact: before there was other hdd connected to that cable and then no long check was performed on boot. System just occasionally then wrote error messages in system log saying "controller error/parity error" (something like that).

Possible cause in my case is that newer hdd supports higher Ultra DMA mode (5?) than my old hdd supported (2?).

My XP's
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager BootExecute
contains autocheck autochk * (XP default).

I'm still annoyed and don't know a solution.

Morten
May 29, 2007 10:32 AM

Thanks Dan Ullman. It also works on XP.

Tim
December 27, 2007 10:03 PM

Thanks Leo. It worked great. I was getting a BSOD with the missing autocheck system message. I had copied the autocheck.exe from my XP Pro CD to my System32 directory which didn't do anything, I thought it might have gotten corrupted, but booting OK to XP desktop. Added the BootExecute which for some reason was missing from session manager. Possible either CCleaner or RegSupeme cleaned up a little to much of a leftover software program that I in/uninstalled recently. Hard to keep track since I'm dual booting with Vista. Never fret as I backup every couple weeks with Acronis True Image. Got to love Acronis. I love messing around in the registry. Thanks again Leo. Great job on your site. Keep it up and you'll be eating lunch with Thurrott at the next MS convention.

Jim
April 6, 2008 9:24 AM

Leo! You da MAN! The registry edit fixed this, after I tried all the other suggestions. I've bookmarked your site for the future. Thanks.

Watthon
June 17, 2008 7:30 PM

I use Windows 2000 and need CHKDSK run every time the system boots up. Referring your instruction, I type the following lines in BootExecute

0000 61 00 75 00 74 00 6F 00 a.u.t.o.
0008 63 00 68 00 65 00 63 00 c.h.e.c.
0010 6B 00 20 00 61 00 75 00 k. .a.u.
0018 74 00 6F 00 63 00 68 00 t.o.c.h.
0020 6B 00 20 00 2F 00 70 00 k. ./.p.
0028 20 00 5C 00 3F 00 3F 00 .\.?.?.
0030 5C 00 43 00 3A 00 00 00 \.C.:...

It works one time but after it the value in BootExexute automatically goes back to

0000 00 00 ..

Any idea to keep CHKDSK running at every boot up as it is necessary for my application.

Thanks.

Watthon
June 17, 2008 7:36 PM

It works fine with Windows XP PCs.

David Bieda
September 26, 2008 11:53 AM

I carried out the above as disc check started running every time I re-booted. As far as I can see this is a space between '.... autochk *' and the asterisk. However if I leave a space the other wording pops up again when I re-check the registry so I deleted the space.

This has stopped autocheck from running (thank you!) but when I reboot a blue screen appears saying skipping disk check as disabled. Should that happen?

I assume I can still run it manually?

By the way I'm not very technically minded.

David Bieda

David Bieda
September 26, 2008 7:29 PM

The exact wording which now apeears on my screen on re=start is:
'Autocheck programme not found - skipping AUTOCHECK'
Which means my machine is still trying to start autocheck each time it starts.

db

robert nagler
December 3, 2008 6:00 AM

Ran CHKSDK with the (disk):/f option on e partition affected, that cleared the command to run it at startup. It worked I don't know why.

Brian
January 22, 2009 12:32 PM

I need a fix for my c drive. I get a message that comes from the toolbar at the bottom. It says msn.exe-corrupt file. The file directory c: is corrupt and unreadable. Please run the chkdsk utility. I did that and finally found your solution to shut the chkdsk off, I hope it works. My question is how do I now fix that error message. My computer will no longer play video when I am online and I need that for school.

Beata
March 8, 2009 7:16 AM

I had this autocheck autochk * when I opened register and one of diskkept checking every time

louise
April 27, 2009 8:07 PM

i had chkdsk checking every time on boot i came here and did all the steps and got to the edit reg and the bootexecute autocheck already had an * so what do i do not to get it to stop????

Keith Ward
July 18, 2009 1:26 AM

autocheck autochk /r \??\C:
autocheck autochk /r \??\E:
autocheck autochk *

autocheck autochk /k:D *
THE ABOVE IS MY BOOTEXEC. ANY SUGGESTIONS AS TO WHAT TO CHANGE SINCE I HAVE NO COMMAND STRINGS WITH THE /P OPTION? THANK YOU IN ADVANCE

IN METTA

Lee Nelson Guptill
November 2, 2009 7:51 AM

Anybody know why when I boot up everytime I get the message, "Checking file system on C: the type of file system is NTFS - the volume is dirty. Chdsk is verifying" and then it goes through stage 1 of 3, stage 2 of 3, and then stage 3 of three checks. It takes several minutes of booting up because of this.

Lee Nelson Guptill
November 3, 2009 8:59 AM

Hi Leo, I carefully read your answer to the question, "How do I keep CHKDSK from running on every start-up?" but none of the answers exactly applied to me. This is what my error says: "Checking file system on C: the type of file system is NTFS - the volume is dirty. Chdsk is verifying" and then it goes through stage 1 of 3, stage 2 of 3, and then stage 3 of three checks." Naturally, it takes longer than average to boot up.

Just wanted you to know that I seriously tried and am not being lazy 'cuz I know you are a busy man.

Harry
November 12, 2009 1:09 AM

Leo, you are a 'God Send'......I have been struggling for weeks with this issue and have googled many a site to find the solution and then I found this answer and it worked. It simply worked. Thanks for your clear and consise answer, I was able to have my computer (once again) start without going through the CHKDSK check every time I started it up.....thanks. For a (relative)newbie it was so simple and easy to follow.....thanks a million.
Thanks again for all your help

Harry (Northern Ireland)

Alexandra
November 25, 2009 11:46 AM

Hi,
My computer gets to this light blue screen AND runs the CHKDSK but once the check is 100% done it never leaves the blue screen and allows me to move forward in the startup so I don't get a chance to turn it off. What should I do?

Kareem ( Iraq )
March 8, 2010 4:04 AM

Dear Leo,I read your explanations and applied them but still I have the same problem which is(at every start up the computer scanning drive F only).
Waiting your help
Thanks alot

B.dhanasekaran
April 27, 2010 10:33 AM

Hi Leo,
I just tried putting one inverted comma and a star and the problem got solved. Thanks a lot

Anonymous
May 27, 2010 11:11 PM

Hi Leo,
I just change a star and the problem got solved. Thanks a lot

Dhanuja Kaluarachchi
July 4, 2010 1:46 AM

Once my computer shut down improperly and now my computer has slowed down and CHKDSK runs every time I boot. I tried "msconfig" but CHKDSK wasn't there. Then I tried it your way but "BootExecute" file already contains the instruction "autocheck autochk *". I still haven't figured out a way to solve this. Please help me.

Thank you

Vishal
July 27, 2010 7:54 AM

Hi Leo, Is there any software that saves current settings at every step when I m working on my PC. if u can suggest me any this type of software that saves settings each time & chkdsk will not come at every boot.
if u an ans. plzzz mail me.
i m waiting...

suman
November 18, 2010 8:41 PM

Is this CHKDSK error due to Power issue?

It can be, but there are many, many other possible causes as well.
Leo
19-Nov-2010

Sandi Brockway
May 17, 2011 11:10 PM

My computer never gets into XP program, only keeps running CHKDSK when i restart it. shows no errors, but will not allow normal start of XP. sometimes wants to use some alternative boot, then says it finished chckign disk and it is clean and ok. then stall stall. one time it chose Normal Windows startup, but nothing happened. i would love to get into xp to regedit if i could.

Manny
September 2, 2011 2:59 PM

I am using Windows XP and AVG. I shut down my computer properly however, every restart will trigger a chkdsk operation.
I found that I have a corrupted avg receipt in pdf format which I cannot open nor delete. I think this is the cause of the problem. How can I delete it?
Thanks!

Nymathin
April 21, 2012 7:52 PM

yeah, my laptop runs chkdsk every start up and when I went to edit the registery, the command line was already there with the *. Guess I'll just have to live with it.

Thomas Tinker
June 8, 2012 2:36 AM

My XP machine has this problem. BootExecute in my registry was already set to autocheck autochk *. Only F: drive has this problem. Chkdsk doesn't run for C, D, or E. Reading the above, my best guess is the cause may be that I didn't shut down my machine cleanly once recently. The PC was locked up, so I had no choice. That being the case, what would be my next step?

Emil
September 10, 2012 11:58 AM

My "BootExecute" file is missing. Now what can I do?

dhishan
April 3, 2013 6:49 AM

works like charm!! great job

Augastine Mathew
April 10, 2013 1:30 AM

Thanks. That was really helpful.

David Usher
April 14, 2013 6:33 PM

Windows 7 Autochk *still shows upon screen even after running chkdsk "f"!!!

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.