Helping people with computers... one answer at a time.

Using a DOS window under Windows ME there's a handy "paste" clipboard appearing with some other icons in the DOS window title bar. Is there any way to get this in Windows XP? I haven't been able to find any mention of it but may be overlooking something obvious.

You came to the right place. I live in the Windows XP command shell. My (DOS) roots must be showing.

Anyway, the icons may be gone, but the functionality is most certainly still there.

I don't believe that there's a way to actually get the icon back, though it wouldn't surprise me if there were a third party add-on that could add something like it.

But Copy, Paste and a few other old friends are all still there on the system menu. Click on the upper left icon on the command shell window, referred to as the system menu, and along with Move, Size, and so on, you'll see a sub menu called Edit. Click on that, and you'll find Copy, Paste and other clipboard related commands. Here's a screen shot of what I mean:

CMD Shell System Menu

If you're so inclined, there are good things buried in the Properties item as well that will let you control the look, feel and some of the behavior of the Command Shell.

Article C2313 - March 25, 2005 « »

Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

March 25, 2005 9:03 PM

Probably the quickest way to get to this menu is to hold down the ALT key, and hit the spacebar. So, for paste, it's ALT+Space, E, P (E for edit menu, P for paste command). If you do it enough, it becomes second nature. :) Especially in a command prompt, the mouse isn't always the quickest method.

March 25, 2005 10:34 PM

I ping for a living & I prefer to set my cmd's Properties to Enable Quick Edit which pastes with a simple right mouse click in the window.

March 29, 2005 8:52 PM

Could you go over that Enable Quick Edit?

I've tried it in a quick edit enabled command prompt, and in a Norton Commander for DOS box, but nothing gets pasted on a right click.

The alt-space-edit-paste routine works as usual.

I must be missing something blindingly obvious!

Robert Leeper
December 18, 2005 7:12 PM

This works fine if you're in a command shell window, but what if you're running the dos program full-screen? Is there then a way to copy and paste between the dos program and XP aps? Maybe like winoldap's int 2F under win 9x?

December 18, 2005 7:23 PM

I believe if you type ALT+Space you'll get the system menu, which will allow you to select the entire screen and copy it. (It may take you out of the full screen window.)

February 5, 2006 2:16 PM

Just in case it's useful to anyone: I've found a neat program called Tamedos which among other things gives you the option to use ctrl-c and ctrl-v to cut and paste in a Dos window under XP, as well as smoothing out various other aspects. 30 days evaluation. Registration is $20 -- worth it to me.

Nadir Mrabet
June 17, 2008 8:15 AM

Many thanks. I had to paste a 4-line long command into the shell!
Is there a way to use the keyboard instead?

June 18, 2008 1:22 PM

Hash: SHA1

Just use the keyboard shortcuts for the system menu:


Does the paste.


Version: GnuPG v1.4.7 (MingW32)


ketab bhardwaj
September 12, 2008 7:00 AM

how can i enable my cut,copy and paste command?

Michael Trahan
July 25, 2010 2:39 AM

Thanks a Billion! I am very experienced, but self-taught; and I was stuck with a "file"/non-file thing on my XP x64 Desktop for a few months. Finally I thought to search the error message (duh!, but guess I was lazy at first and my desktop was messier then anyway).

Well, I am posting this for thanks and two other reasons - for all reading with
this kind of issue:

1 - for me the file ended with a space; and not a period; and thought I would spread the word this still worked!

2 - Also, I read above some had problems with copy and paste. I too had to
re-learn how to do this, but you should be able to do it simply with the Windows prompts (well, at least mine, see version above). I use the portable one from, and also discovered it to be tricky. It seemed to keep "forgetting" or something, what I had copied into the clipboard (which was the entire command written in a text editor to include everything (of course)). I had to carefully left click the very top left of the prompt window to bring up the context menu which included Edit->Paste. Maybe mine was acting up for some other reason, but I think this may help others; keep trying.

So happy that "file" is gone!

Michael Trahan
July 25, 2010 2:46 AM

Sorry, I posted this to the wrong site accidentally. I used this info in conjunction with the info here:

Sorry for the possible confusion...

Steve Arundell
September 8, 2010 6:19 AM

re. CMD window cut and paste.
Try under CMD window menu "Properties" --> "Options" Tab and and enable "Quick Edit Mode".
This gives you Paste on mouse Right-Button and Copy is by mouse drag and Return.

November 6, 2012 9:38 PM

The resizing gimmic is fantastic. I cottoned on to it just like that. Thanks Leo.

January 6, 2013 11:29 AM

how to copy one file & past it to
another plase in cmd ?

You don't "copy/paste" in the command prompt. Look at the help for the "COPY" command, that's the command used to copy files.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to to ask your question.