Helping people with computers... one answer at a time.

When I log on to Hotmail it goes straight to my in box without my having to type in my password. How do I change that so I have to type in my password to stop other people from being able to access my in box.

Making sure that Hotmail doesn't automatically log you in is critical if it's possible that someone else might walk up and use your computer while you're not looking.

The great news is that it's trivial.

Step 1? Sign Out.

When you're looking at your Hotmail, if you look at the top of the window, you'll see a list of several links, including the .net Sign Out button:

Hotmail signout button

Click on the Sign Out button. It'll log you out, and take you to the MSN home page.

Now, return to Hotmail page, and you'll be required to sign back in:

Hotmail signout button

Don't sign in ... just yet.

Make sure to click Always ask for my e-mail address and password. Now, sign in (in order to make this setting 'stick').

Now sign out again, and you should be good to go.

Article C2613 - April 5, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

28 Comments
orlando duarte
April 18, 2006 8:40 AM

thank you

Lucy Perry
May 8, 2006 9:07 AM

At my mums work place there are three computers and when i come back in from school i go on one and when i log on to my file of the computer everything works as usal but my msn account allways logs on by its self and i cant change this, or can i??????????
and it is on my mum's friends computer and she could talk to any of my friends and i cant stop it.

st.clair
May 10, 2006 3:08 PM

i used the file and sign out from my e mail account and when i press sign in ti just sign me in this is dangrrous

jenni
June 15, 2006 4:52 AM

We have msn messenger version 7.5. I watched your video... this version doesn't have the options you refer to. No general tab to start with! How do I stop automatic sign in?..especially whenever i open Outlook express. My daughter has used it on my login.. now I can't get rid of it! She wants to use it on her login though.. so she doesn't want it uninstalled.. can we selectively get it off my login?

Lynda
June 27, 2006 12:51 PM

Okay, so I have this problem plus one more: I don't have a sign out button! None. COuld it be because I use msn as my internet provider?

Eric
August 27, 2006 3:32 PM

When I click on the Microsoft messenger Icon in the tool bar, it automatically signs me in. I wants it to ask for my password so that mot just anyone can click on it and and open my contact list and retrieve all my peronal information?

robin
March 19, 2007 11:41 AM

can i sign on as i what to go no i to see what it is lije

Rob
December 3, 2007 7:32 PM

The solution described in this posting is obvious IF one had those options. However, my problem, as it was of others in this posting, is that I "do not have a "SIGN OUT" button to click." I do not have the upper buttons that are shown to the left of the SIGN OUT button in your example. The only buttons I have, are: TODAY - MAIL - CALENDAR - COMPOSE - OPTIONS - HELP. The options & help buttons were of no help at all; other than to bring me here. That is it. If I could get BACK to the sign in box, of course I know to select "Always ask for my e-mail address and password" - so my question is, "How do I sign out when I don't have a SIGN OUT button? I am leaving my PC on for 2 hrs in hopes it will automatically log me out. If that works then I can fix the problem as you mention in the post. If there is a faster or better way, please advise as soon as possible. Thank you

Rob
December 4, 2007 6:04 AM

UPDATE - I had my Hotmail set to automatically log me out after two hours, but even after leaving it on all night, it never did log out. So, I still need to know how to get out of this thing when there is no "SIGN OUT" button to click.
Thank you

Joe
July 3, 2008 8:08 AM

It's annoying that every time I logout from Hotmail it takes me to the MSN page. Is there a way to change this setting?

Mystery AAA
September 12, 2008 4:07 AM

This is how you do it ....

Click Start, then Control Panel and select User Accounts

Select an account name and:

XP Home users -choose Manage Passwords

XP Pro users: Click the advanced tab and choose Manage Passwords

Select your account name you and click Remove.

Select NET*\(Passport) and then click Remove (this is the one I removed)

It worked for me!!!

Niles
February 3, 2009 8:38 AM

The newest Hotmail (2008/2009) has been automatically singing me in, even though I never store my passwords, AND I explicitly sign out after every session.

Their support led me to "Manage Passwords" in XP and very sneakily it was stored there! Very bad, as I never authorized this. But please read on:

I cleared it out, and... it is still signing me in automatically -- even after 24+ hours after signing out. This is a MAJOR breach of privacy! What if this was a public computer, or even a friend's?

P.S. I'm using IE8, so I'm not sure if the security hole is in IE, or Hotmail, but either way it is very concerning to say the least.

Sue Powell
February 5, 2009 12:48 PM

I am also being logged in automatically. I have removed my info from "manage passwords" but to no avail. The problem is it is stopping my husband from logging onto his hotmail.
Help!

D
March 10, 2009 2:24 AM

Thank you, Mystery AAA. The original article did not solve this issue for me but your suggestion did.

James
March 24, 2009 10:26 PM

I just upgraded to IE8. It won't sign me in automatically when I open my first browser window. But since I have Hotmail as my homepage, If I open a second window, IE automatically signs me on that one. I have no passwords stored, and can't figure out how to keep IE from auto sign in across multiple windows even if I select "always ask for email and password."

danielle lacher
July 25, 2009 6:16 PM

The solution described in this posting is obvious IF one had those options. However, my problem, as it was of others in this posting, is that I "do not have a "SIGN OUT" button to click." I do not have the upper buttons that are shown to the left of the SIGN OUT button in your example. The only buttons I have, are: TODAY - MAIL - CALENDAR - COMPOSE - OPTIONS - HELP. The options & help buttons were of no help at all; other than to bring me here. That is it. If I could get BACK to the sign in box, of course I know to select "Always ask for my e-mail address and password" - so my question is, "How do I sign out when I don't have a SIGN OUT button? I am leaving my PC on for 2 hrs in hopes it will automatically log me out. If that works then I can fix the problem as you mention in the post. If there is a faster or better way, please advise as soon as possible. Thank you

The appearance of the signout button has changed since this article was written.

Windows Live Hotmail signout button


Leo
26-Jul-2009

Mr K
January 2, 2010 2:42 AM

I resolved the 'sign-in' and 'sign-out' problem (after a wasted morning) by clicking the MSN button on my (logged-in) Hotmail page. This brought up the option to 'sign out'. I then signed back in with my guests name OK.

BILLY PEEK
March 28, 2010 8:35 AM

just tell it not to remember you

Sarah
July 27, 2010 1:50 AM

I'm signing out while in my inbox, but every time I got back to the hotmail login in, it automatically signs me in again and I don't have the option for it to "not remember me".

Plep Johnson
July 27, 2010 9:48 PM

This auto sign-in feature is way too intrusive... but I found a band-aid fix. The best solution that I found was that in the top right corner you should have your name and a green circle indicating that you are online. If you click your name you have to option to appear offline, and that will be default every time you log into hotmail.

Shelly
August 6, 2010 8:16 AM

It seems if you click on your name on the top right hand corner a scroll down menu appears and you can log out.

S
January 20, 2011 7:36 PM

I am so tired of the invasiveness of MS. I use a hotmail account and nothing listed here allows me to actually "logout." When I want to post a comment, I want to have to sign in to have the gd illusion I'm not being tracked. How do I do this!!!

Jim
February 4, 2011 8:52 PM

this fix did not work for me.

djzena
February 19, 2011 1:19 PM

nothing suggested works for me; cannot prevent automatic sign-in. really a problem. what to do?

Anne
March 16, 2011 2:49 AM

First, click on the "sign out" at the top right of the Hotmail page. Then when you try to go back to your email, the sign in page will appear again, with your email and password already there, but instead of clicking "sign in", simply choose the option to "sign in as a different user". Then, type in your own email and password, being sure to NOT check "remember my password". Thereafter, it doesn't remember your password and you have to type it in each time. This worked for me.

Max
March 31, 2011 8:09 AM

I don't know why Leo and other posters have posted solutions that involve signing out, clicking a hotmail link and then altering the settings.......

The *whole* point of this problem is that, AFTER you sign out, clicking ANY hotmail link takes you directly to your INBOX - therefor there is no possibility of altering setting, permissions or anything else....

Especially hard to believe given the double warning from Leo himself in the commenting protocol below.... No wonder MSN treats us as sheep...

Anyway - the control panel solution posted previously looks like it may work on a pc - I have a Mac.

What DID work on a Mac was to Reset Safari.

This does mean losing all your browsing history, cookies, saved passwords, autofills, etc - but for solving such a major issue that was a small price to pay, for me.

Go to Safari - Reset Safari - be sure to check the box that says 'remove saved names and passwords' - click 'Reset'.

This took me back to square one with hotmail - finally............!! :-/

Yeshin
June 14, 2011 4:08 PM

I tried to go through these steps. Unfortunately, there is no option of
"Always ask for my e-mail address and password".

Fran
January 2, 2013 4:44 PM

This fix doesn't work in IE 10.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.