Helping people with computers... one answer at a time.

Auto-play can be a convenient feature but if it's not what you want, it can be difficult to turn off and keep off. The TweakUI utility can fix that.

How do I *really* disable auto-play in Windows XP?

The auto-play feature in Windows was significantly beefed up when Windows XP was introduced. For CD and DVD drives specifically, Windows will first attempt to determine what type of media you've inserted and then perform an appropriate action. If it doesn't know what action is appropriate, it asks along with providing the option to remember that action for next time.

Seems fair enough, except that when I encountered it for the first time it kept forgetting the settings and would always ask. From my perspective that's worse that not having auto-play at all. And then I couldn't turn it off.

If that sounds familiar, then you know my frustration.

Enter one of my favorite Windows add-ons: TweakUI, one of what Microsoft calls "Power Toys for Windows XP". It's more than a toy. It allows you to adjust (or 'tweak') several settings that aren't exposed directly by the standard Windows tools.

Once you've installed TweakUI you'll find a lot of options in it. For our current problem, in TweakUI expand My Computer, and then AutoPlay. Click on Drives and uncheck the drive letter that you no longer want to auto-play. Click on Apply and that's it. No more "what would you like me to do" dialogs.

TweakUI has a number of other settings, I encourage you to install it and browse around in it. It's something I install on every computer I run. (The PowerToys page has a number of nifty tools as well. Have a look while you're there).

Article C1884 - January 21, 2004 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

47 Comments
Carol
May 7, 2004 9:34 PM

I downloaded the tweakUI program, and I was wondering how do I move it into the control panel section of my computer, since to my knowledge I'm not able to just do the typical "drag and drop" method.

Leo
May 7, 2004 9:45 PM

As I understand it TweakUI for XP can no longer be put into control panel. Previous versions were in control panel by default. Not sure why the change.

phyllis
July 9, 2004 5:31 PM

my sister burned a cd now i keep seeing autoplay being canceled out im freezing up and im unable to stop the cd burner from my pc from opening up its doing it for the last hour every 10 seconds

David Morgan
February 3, 2005 11:19 PM

Dear Leo,
> Seems fair enough - except that when I encountered it for the first time, it kept forgetting the settings, and would always ask. From my perspecitive that's worse that not having auto-play at all. And then I couldn't turn it off. If that sounds familiar, then you know my frustration.

Yes I do Leo. thanks for the heads up on how to REALLY disable XP autoplay on specific drives. I have a second HDD with several partitions and hate XP asking what to do with each partition when I insert it into my laptop. I have been a long time user of TweakUI but never cottoned on to that feature.
Thanks again,

Dave Morgan (Australia)

PS I found your solution using Google.

And for those wanting to add TweakUI to their Control Panel you can find a great little utility here

http://www.dougknox.com/xp/scripts_desc/xp_addtweak.htm or download it from here http://www.dougknox.com/xp/utils/xp_addtweakui.zip

jim
March 7, 2005 6:19 PM

Ok I installed tweakUI.
now, how do i use the darn thing? or even find it!
thanks
jim

Leo
March 7, 2005 6:27 PM

Heh ... yeah, it's a little non-obvious.

Look for a new item on your All Programs menu called "PowerToys" or some such. Underneat there you should find TweakUI for Windows XP.

sas
March 14, 2005 2:46 AM

Another useful tip is to make sure you run tweakui with admin permissions, otherwise it won't give you all the autoplay options.

Sandy Lemberg
April 3, 2005 9:22 PM

Well, I downloaded TweakUI and tried to install it. I got an installation wizard which gave me no options on where to install it. The wizard said it was installing it and then disappeared without a trace. (Not a very wise wizard) So I don't know whether this thing is in my system and if so, where.

Your instructions do not say where it should be either.

Any advice?

Leo
April 4, 2005 7:34 PM

Either in your control panel (non XP), or look for a new item on your All Programs menu called "PowerToys" or some such. Underneath there you should find TweakUI for Windows XP

Terry
April 8, 2005 8:27 AM

I want to turn it autoplay off - permanently - for all users - for all drives. Reason?

I have a laptop: I have to use external drives - Firewire and USB. I have more disk drives than I have enclosures to hook them up to - so my external HDD situation can be highly dynamic. And each HDD change seems to screw up the autoplay options I've already set.

And as I'm a relatively functional adult, I am well and truly capable of invoking for myself the programs I deem are needed at any given instance. But Autoplay thinks it knows better than I. Even though it farts around, then asks me what to do anyway.

[This is highly frustrating, and an insult to my intelligence. If I want my intelligence insulted, I will watch the Fox News channel.]

If you have a solution for Windows XP (SP1 or 2), please let me know.

If your best solution is to harass MS about it: that's fine, I'll do it. After all, MS is the exception that proves the rule: Do not shoot the MESSENGER. (It's the first thing I kill when re-installing XP)

Cheers and many thanks for the help you give to the dazed and confused. I want a one-step process to kill autoplay for every possible attached drive, and if the answer obviously exists in the posts I am commenting on, then yes I deserve to be condescendingly referenced as stupid, a bonehead, and worthy of a political career.

Thanks for reading this far,

terry

terry
April 8, 2005 8:40 AM

PS: I should have used emoticons to indicate self-deprecating humour.

{ :-) >

No offences intended!

Terry

Leo
April 8, 2005 8:54 AM

Use TweakUI as decribed in the article. You'll need to for each drive -- and possibly for each user, I'm not sure.

Chris
June 29, 2005 1:28 PM

I would love to get rid of this annoyance but the microsoft web site says 'PowerToys will only work with US-English regional settings'. Any suggestions for those that don't want to use US-English regional settings (the rest of the world ;-> ) or have I misunderstood what it means?

Thanks
Chris

Leo
June 30, 2005 9:50 AM

In your situation, I'd be really tempted to try it anyway. I can't think of any huge reason it would be US only, other than they haven't bothered to translate the text with it.

Adrian
August 15, 2005 1:37 PM

To Disable autoplay, completely, on all drives, in Windows XP Pro

1) Click Start, Run and enter GPEDIT.MSC

2) Go to Computer Configuration, Administrative Templates, System.

3) Locate the entry for Turn autoplay off and modify it as you desire.

zag
March 21, 2006 11:41 PM

Any suggestion to get it done on XP Home.

Andre
March 26, 2006 12:28 PM

I'll ask the same question above. Any suggestion to get it done on XP Home.
I've got a notebook and i dont wanna install windows xp pro just to disable auto play.....
what do you say to help me...

Leo
March 26, 2006 12:47 PM

Use TweakUI

zag
March 27, 2006 1:01 AM

TweakUI certainly can do but would be great to know about any Admin key options or registry keys.

Mark
March 31, 2006 4:19 PM

1. Click Start, click Run, type regedit in the Open box, and then press ENTER.
2. Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
3. To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
4. Restart your computer.
NOTE: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.


(From the microsoft site)

doug
May 26, 2006 10:34 AM

For the newest version of TweakUI (2.10.0.0),
find autoplay this way:

On the left outline, click My Computer.
Under that, select AutoPlay.

You could uncheck individual drives, but
look at the Types setting first. Unchecking
just one box in Types may do the trick.

IMHO the Handlers item is useless.
Most of the entries cannot be deleted
and most of the details (file args and
wording) can't be changed either. I have
one entry that always appears on autoplay,
but the args are wrong, so it doesn't work.
TweakUI is no help for that one.

Mike Turner
March 23, 2007 8:27 PM

Another application I have that I like is "The Ultimate Troubleshooter" from Answers That Work (www.answersthatwork.com). It has a section for tweaking as well ... one of which is turning off CD auto-play.

TechnoLaziness
March 15, 2008 3:41 PM

Best option is to press one of the shift key while inserting thumb drive.

Laura
March 24, 2008 6:12 PM

I'd like to thank you for saving my sanity by posting this information. The Auto-play window was running over and over on my daughter's computer and I could not turn it off. Each time it popped up, we were unable to type or use any other application whatsoever. I suspected spyware also.

I got on my laptop, googled "remove auto-play", found your site, downloaded TweakU and in the process I found that several media drives had been installed on her computer. I disabled autoplay on all of them, thanks to the TweakU program and also began running the anti-malware, anti-virues.. etc atc.

Before I found your site I was about to throw the computer in the pool. I've since bookmarked this site and I'd like to Thank You Very Very Much!!

Bart
May 29, 2008 7:15 AM

I used TWEAK UI to switch of autoplay for CD/DVD and for removable devices. Under my computer - autoplay - types you can uncheck these two types of devices. It works fine. Thanks you very much.

Jim Ekleberry
June 18, 2008 9:19 AM

It is safest to disable CD autoplay in XP using either local group policy or, for an enterprise, an Active Directory group policy. The local group policy editor method:

Click Start
Click Run
Enter GPEDIT.MSC
Group Policy mmc will popup. On left panel:
Double-click Computer Configuration to open submenu
Double-click Administrative Templates to open submenu
Double-click System to open submenu
Double-click Turn autoplay off option which will be near the bottom of the list in the right panel.

The default is the Not configured . Set it to Enabled.

Jim Ekleberry
June 18, 2008 9:21 AM

In the steps above, if you wish to disable autoplay for all drives (e.g. usb drives/keys, etc), when on the last step select All Drives instead of CD-Rom drives.

JPaget
July 16, 2008 6:27 AM

Thankyou Jim Ekleberry! This was the type of answer I was looking for! Oftentimes, these settings are completely configurable without the need for external software! (Not that TweekUI is a bad program however) just that I am proud of you for giving truly professional advice! Indeed many programs exist to help you do things that windows already does (when you know how), and I'm in favour of all those who take the time to educate this to millions of people who would have otherwise paid for software they didn't need! So Bravo to you! (To Leo also, as generally his site is pretty good as a whole!) May the knowledge live on within those willing to share it!

BT
October 3, 2008 3:38 AM

Mr. Ekleberry... Thanks. I have to mirror the comment of JPaget. Using the tools provided (even if not well exposed) by MS would always be my preferred method as well. I never thought about it being a GP attribute. Too simple for once. Thanks!

nimd4
October 7, 2008 7:18 AM

Quoted from windowsnetworking.com:

"It is safest to disable CD autoplay in XP using either local group policy or, for an enterprise, an Active Directory group policy. The local group policy editor method:

* Click Start
* Click Run
* Enter GPEDIT.MSC
Group Policy mmc will popup. On left panel:
* Double-click Computer Configuration to open submenu
* Double-click Administrative Templates to open submenu
* Double-click System to open submenu
* Double-click Turn autoplay off option which will be near the bottom of the list in the right panel.

The default is the Not configured. Set it to Enabled."

nimd4
October 7, 2008 7:23 AM

ps.

In addition to my comment posted above; The funny thing is: when the Group Policy option is set, it becomes practically impossible to access the Registry key any more! :-F

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom

Kvwielink
November 9, 2008 6:57 PM

Not sure if I am the only one with this added problem, but when I tried to change the group policy as described above, I couldn't find the System option. To solve this, right click on administrative templates, select add/remove templates, and select system.adm. The option to disable autoplay is now available.

derick03
January 20, 2009 3:43 PM

Great advice!!! Thank you so much. I have to agree with Haz, I think that the Group Policy method does not work with Home Edition as gpedit.msc does not even exist on my OS drive. However, TweakUI is a great tool for any XP machine if you know how to use it, or only use it for things like this that give you clear direction.

Ras Manyobvo Machipanda
January 21, 2009 8:23 AM

Open Notepad and copy/paste the following into a text file:

REGEDIT4
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
@="@SYS:DoesNotExist"

Save the file as something.reg. (You have to be sure to change the "Save File as Type" to "All Files" before saving, or Windows will try to save it as a .txt even if you typed in .reg.

Locate the file you just saved and double-click the file to run it. You will receive a prompt asking if you want to add the data to the registry. Click yes to allow the modification.

The above method nulls any request for autorun.inf and works on XP Home or Pro, as well as Windows Vista.

M3TAL_L0RD
April 14, 2009 10:35 AM

This is how you can easily disable AutoPlay

Open Notepad and copy/paste the following into a text file:

REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:000000B1

Save the file as something.reg. (You have to be sure to change the "Save File as Type" to "All Files" before saving, or Windows will try to save it as a .txt even if you typed in .reg.

Locate the file you just saved and double-click the file to run it. You will receive a prompt asking if you want to add the data to the registry. Click yes to allow the modification.

and to re-enable it, use this:

REGEDIT4
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

George
August 26, 2009 2:43 PM

For those who have XP Home (no gpedit.msc) and don't want to hassle with the registry, I found a nice tool that turns off autoplay in the easiest way that I have ever seen (it's also reversible). Just Google for "Auto Play Squelch" and you will find it.

Gregory Robinson
August 29, 2009 2:11 PM

SP3 makes it even harder to use the regedit app. And pretty much makes it necessary to use third party utilities or TweakUI. Why does MS continue to make it difficult for users to secure the OS?

GRob
August 29, 2009 2:40 PM

Oh and by the way, M3TAL_L0RD's posting does not work with Windows XP Pro SP3 even under admin credentials and after a reboot. Nice try though.

GRob
August 29, 2009 3:15 PM

M3TAL_L0RD's posting will work swapping HKEY_CURENT_USER with HKEY_LOCAL_MACHINEthe and the addition of the following registry key:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]"HonorAutoRunSetting"=dword:00000000

GRob
August 29, 2009 3:17 PM

Sorry, that should be HKEY_LOCAL_MACHINE with no "the" at the end of HKEY_LOCAL_MACHINE.

aktrout
October 24, 2009 8:23 AM

I loaded and tried TweakUI. It did nothing. I am using windows XP. Why?

Globinch
July 20, 2010 10:18 PM

Read some alternate ways to Enable and Disable Autoplay Feature Windows..
http://www.globinch.com/2010/07/05/enable-disable-autoplay-feature-windows/

Dennis Anthony
March 15, 2011 8:49 AM

I have unchecked my two memory sticks (E & F drives) in TweakUI but now my computer does not recognise them so how can I access them?

Dennis Anthony
March 15, 2011 8:56 AM

Sorry my mistake - I unchecked the computer drive not the drive in Autoplay. However, unchecked in autoplay still opens my stick on clicking 'Open'.

Robert
September 15, 2011 3:23 AM

My favourite tool for this is Autoplay Disabler Pro from http://www.autoplaydisabler.us
I had bad experience with editing registry, since I am not so good with computers! This tool is simple and works safe and for Xp and for windows 7, for Vista I didn't try...

Richard Kahn
November 4, 2011 6:46 AM

G-d bless TweakUI. I have been cursing the autoplay "feature" ever since it haunted me for the second time and beyond. Why on earth wouldn't Microsoft want to give people the ability to turn this off? It is not like it encourages people to use non-Microsoft software or otherwise hurts their business. Actually just the opposite.

Richard Kahn
November 4, 2011 6:53 AM

Hopefully this link will show up. Here is what I see in the TweakUI utility. Notice how I unchecked boxes A-G which covers most of what I do daily. When I would hook up my smartphone to synchronize, it would show up as E and G for internal memory and SD card, respectively:

Click here to see JPG

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.