Helping people with computers... one answer at a time.

Most people don't realize that Firefox has the option to open multiple home pages at once. It's possible some install programs use this.

Every time I launch Firefox, in addition to opening my home page it also displays a second tab entitled "Help for Skype - user Guides" How can I permanently delete this tab?

This seems to be catching several people by surprise lately.

Firefox has a feature for this and I'm not sure if some software installs are now starting to take advantage of it or what.

The good news, though, is that it's very, very easy to correct.

(Re)Setting Your Home Page

Go home.

Seriously, open your browser and press the Home button, or whatever is convenient to take you to your home page.

Close all tabs that aren't your home page. You should be left with only one tab open, and that tab would contain your desired home page.

Now, Click on the Tools menu, Options menu item, General tab to get to this:

Firefox General Options dialog

Click on Use Current Page to reset your home page, and then click on OK to close the dialog.

Next time you start Firefox you should start with only a single page.

But ... What Happened?

So, what is it that we fixed?

The "feature" that I alluded to above is simply this: Firefox can be instructed to open more than one tab as your home page.

Open up two tabs - I'll open up both msn.com and microsoft.com - and go back to that General tab in the Options dialog, note a very subtle difference:

Firefox General Options dialog - showing Use Current PageS

Note that the "User Current Page" button is now the "Use Current Pages" button. Click it and you'll see the Home page field change:

Firefox General Options dialog - showing multiple home pages

The Home Page field now lists both URLs, separated by a pipe character "|". When you open your browser, both pages will open up, in separate tabs.

Personally I find this "feature" less than useful, since clicking on the Home button later will take the current page to the first listed URL, and open up a new tab for the second URL even if it's already in an open tab.

The fix we applied above simply restores this setting to your single desired home page.

How'd it get that way? I can only guess.

That guess is that some setup program - perhaps Skype's in your case - noted that you were running Firefox, and in addition to adding it's Firefox extension, also modified your home page setting to include the additional page.

But that's just a guess. Since that "Page" versus "Pages" on the Options dialog is so easy to miss it's also possible that the second tab was open when you set your home page, and at the time you didn't realize that you'd actually set it to both.

Article C4404 - August 18, 2010 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

8 Comments
John
August 24, 2010 9:02 AM

Leo, the above procedure only helps in having a tab with a + sign but you can never make the firefox tab disappear...It just doesn't happen....

DanU
August 24, 2010 9:22 AM

John- (assuming windows)
Tools --> Options --> Tabs. Uncheck "Always show Tab Bar."

I like the fact that you can have more then one home page. Every morning when I get to work and start up the browser I start up pandora, a USACE site, web mail and a navigation forum. With the exception of pandora, Firefox presents me with what I have to check out before my day begins.

Sigma
August 31, 2010 4:11 PM

Léo, how can I take off the skype page when I start my Firefox, i mean, not as u explained, the page appears before the Firefox standard page, and then disappear replaced by the Firefoz main page, how can I avoid this? That Skype page laggs my browser...

Never seen a Skype page as you describe. I'd disable/uninstall any Skype addon in Firefox, and perhaps even uninstall Skype if that didn't resolve it. Look for options to turn off when you reinstall Skype to stop it from interfering with your browser.
Leo
02-Sep-2010

Eli Coten
September 15, 2010 1:17 AM

Maybe by Skype Page you just mean the Skype program window is automatically popping up before your Firefox starts. That's probably because it's set to auto-start so if you look inside the Skype Options - I don't know where they are because I don't use Skype (try the Tools menu then Options) and look somewhere there is probably a tick box that asks you whether you want Skype to Start automatically. There may be another one that allows you to set it to start minimised allowing you to have it running but not popping up.

Hope this helps. NB If this is the issue then it doesn't have so much to do with the actual article and is rather a completely separate question.

Jill
September 25, 2010 11:54 PM

If you have set only one home page in tools/options but Firefox opens two then here's the fix! Right click on your Firefox icon then click open & it will open one tab, not two.
Or you can "single click" the Firefox icon instead of "double clicking" and it will open with only one tab.

imaginashawn
March 17, 2012 12:46 PM

Does not work. Still have two tabs after update. Win XP.

imaginashawn
March 17, 2012 1:24 PM

Leo's article didn't help?
It could be that your prefs.js file for Firefox is corrupt. This can prevent you from saving any preferences.
Fix: You can either uninstall and re-install Firefox or you can attempt to replace the prefs.js file by following the instructions provided in Firefox support.

Vinod Choodappa
November 18, 2012 9:31 PM

Hi Mr Leo

I am getting an double tab when i am using the java script, So how do i solve this problem.Please help me out in resolving this Issue ?
I will be waiting for your valuable reply.

Thanking You
Vinod Choodappa

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.