Helping people with computers... one answer at a time.

QuickTime Player, a popular player for various formats, has a nasty habit of inserting itself into your browser, and being difficult to remove.

Why does it seem that quick time takes over playback of MP3s in Internet explorer? This phenomenon appeared after I installed iTunes. instead of my default media player, quick time seems to want to play my MP3s instead of my default. The only way the default works is if I right-click and download first.

This is one of the Most Annoying Things Ever.

Can you tell I've experienced this?

Let's look at what's happening, and what to do.

"Most annoying 'feature' ever."

Here's the scenario: you find a link to an MP3 file on a web page, and click it. The web page disappears, is temporarily replaced with the QuickTime logo:

QuickTime Logo

And then a small audio player, centered on the page:

QuickTime Audio Player

which then begins to play the audio. You have to hit Back to return to the page you were viewing, but of course that stops the audio.

Most annoying "feature" ever.

And it's not at all obvious how to get it to stop.

Turns out, it's fairly easy.

The "trick", if you want to call it that, is even if you don't actually plan to use Windows Media Player long term, set it to become the default player, then disassociate QuickTime from everything, and then go ahead and pick another media player as the default. But make sure to let Windows Media Player do the heavy lifting first.

First, exit Internet Explorer.

Run Windows Media Player, type ALT+T to get the "Tools" menu, then click on Options, and then on the File Types tab.

Windows Media Player, mp3 filetypes option

Make sure that MP3 audio file is checked. Click OK.

Now, it's also a good idea to remove QuickTime's misguided associations as well.

Fire up QuickTime Player, click on the Edit menu, Preferences item, and then the Quicktime Preferences sub-item. Click on the File Types tab:

QuickTime file type preferences

I uncheck Audio, MPEG and MP3. While I'm here I also uncheck Notify me if other applications modify these associations, so as to keep QuickTime from bugging me in the future.

Next, still in QuickTime preferences, click on the Browser tab, and then the Mime Settings... button.

QuickTime Mime Settings

Same thing here: uncheck Audio, MPEG and MP3, as well as Notify me if other applications modify these associations.

Click OK as appropriate and exit QuickTime Player.

At this point, MP3 files should play automatically in Windows Media Player, outside of your browser.

If you'd like to choose a different player you can:

  • Use that player's options to re-establish its association with MP3 files.

  • Re-install that player, which often offers to reset file associations.

  • Run the Set Program Access And Defaults tool in Windows XP, Default Programs in Window Vista and Windows 7, to set a different default media player.

Now, the bad news.

It is possible that the next time you take a QuickTime update (or an iTunes update, which often includes a QuickTime update) you might need to repeat this process. It may have gotten better, but QuickTime has a nasty reputation for taking over.

I know that Microsoft gets a lot of flak for forcing things on you because "they know better", but in my opinion Apple's no better when it comes to QuickTime. Perhaps over time they'll improve, but the fact that this has been happening for years doesn't speak well to the situation.

Article C3872 - September 18, 2009 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

27 Comments
heikwith
September 19, 2009 1:21 AM

In Window Vista and Windows 7 there is no File Types tab.
Please advise about these systems.

Mike
September 19, 2009 10:03 AM

In Vista go to Control Panel > Programs > Default Programs > Associate a file type or protocol with a program. In there look for .mp3, click on it, then click on the Change program... button in the top right corner and set the correct program.
I don't know for Windows 7, perhaps something similar.

The reason that this is such a big issue for people is that those logical, simple steps you've just provided simply don't work in all cases. QuickTime is insidious.
Leo
20-Sep-2009

Bill P. Godfrey
September 21, 2009 5:38 AM

Gah! I installed Quicktime for use only within Sony Vegas to decode MOV and MP4 files. Any time Quicktime code runs outside of Vegas is unwanted. (I don't even want to be able to click on MOV files and have the player run.)

Very annoying, totally agree with you there.

AG Wright
September 22, 2009 9:04 AM

I actually despise QT and use a program called Quicktime Alternative that uses the Media Player Classic program to play QT files. It works well with Mozilla, which seems determined to use QT for it's default media player.
Oh also Media Player Classic will play Real Player files, another program that I would rather do without.

AG

duane
September 22, 2009 11:51 AM

Is there something wrong with the Quicktime player? If it plays the selection, what's the difference?

I find it extremely annoying that it takes over the page I was looking at, and that it consistently and repeatedly overrides my preferences.
Leo
23-Sep-2009

Andrew
September 22, 2009 1:57 PM

That is because apple makes vile, invasive, and innefective software.

Mark
September 22, 2009 7:44 PM

Another vote for QuickTime Alternative. I haven't had official QuickTime installed since Windows 98.

Dave duChene
September 24, 2009 3:40 PM

An easier way is to uninstall QT.
Ant computer that I work on has QT removed (with the permission of the owner. Other software, such as GOM or VLC will do a better job without getting "in your face".

Mark
September 25, 2009 9:08 PM

Quick Time Alternative and Media Player Classic rule!
Will free you forever from Apple QT & MS's Media Player disaster.

Sandy Smith
October 1, 2009 9:25 PM

You know what else they do that SUCKS. Every time you update iTunes/Quicktime (and why are they together - I don't even WANT Quicktime yet it is always part of the iTunes update) they put both programs back on your startup. So every time you update you have to hit "msconfig" and take them off startup. I think there should be a class action lawsuit against them for this.

TG2
October 3, 2009 8:19 AM

here's the next logical question.. what if you bring up the preferences, and it won't let you change them!? (Vista)

Phostenix
January 7, 2010 12:46 PM

Removing the mp3, MPEG video & MPEG audio associations in the Browser>MIME Settings from the QT control panel did the trick for me on a Win XP machine - without restarting IE8. Thanks!

Me
February 27, 2010 3:45 AM

For Windows 7:
Click Start, Default Programs
Click on Set program access and computer defaults
Go to the Custom Section
Scroll to Choose a Default Media Player
Click on Windows Media Player (or whatever program you wish)
"Ok" your way out.

Beth Anne
June 21, 2010 12:40 PM

I have windows 7, and I followed the instructions. No worries there. But now, NOTHING is playing rather than Quicktime or Media Player. Help! I use Opera, if that makes any difference.

Paul
September 28, 2010 2:01 PM

I find Quicktime to be more than a nuisance. I edit audio files all day long and QT's installation also interferes with music downloads via Mozilla. With QT installed, the music downloads default to the QT player instead of the Mozilla downloads box where we normally open & save the file. I see that QT Preferences in Win 7 has no tab for editing file types. This is the worst media player I have ever used...and I've used them all. I can't have QT along with our audio editing software, so iTunes won't work. QT just commandeers the PC. Will QT Alternative fix this problem? I'll try it and see.

carlalva01
October 25, 2010 1:45 AM

you CAN use Aunsoft video converter for mac to remove audio file ,that is all

http://www.aunsoft.com/video-converter-mac/

t.j.
November 17, 2010 10:19 PM

running win xp pro sp3 ,using firefox browser
final step i had to do, after doing all the fixes suggested above, go into firefox tools/options/applications,look at each and every application,and see which apps still had quick time associated with it,
if you click on any that still have quicktime you get a list of options including defaults, reset all until the dreaded quicktimes are eliminated, and your browser is yours again , thanks.

Rick
November 21, 2010 2:35 PM

However this DOES NOT work in Windows 7 and the latest quicktime and WMP... This is all handled by Default Programs > Associations. and QT locks in its associations.

TOM
February 2, 2011 11:32 AM

As a PC illiterate I have to ask you, Do I exit internet explorer before I go into Media Player or when I open up QT? I performed all the steps you suggested and attempted to try again and as you can guess I failed. Please help.

Jim Mooney
February 19, 2011 7:05 PM

Here's a quick fix on that rotten hog-everything quicktime player. Download the latest real player, which won't hog if youset it that way on installation. But when the scummy quicktime microplayer appears, you can right click to download the mp3. Apple's Instrusions solved despite Fuhrer Jobs

abdullah
March 22, 2011 3:48 PM

Exactly what I needed to know, tremendous thanks go to you for this article :)

Andy
May 8, 2011 7:03 PM

I have AOL, recently I have been flooded with spam mail. It goes into my spam folder, but how do I treated so that they don't know that I am aware of it. I heard that these people know somehow how you treat the spam. Like if I open it, it send them a message that I look at it. Until Huffington post took it over, I was alright but now, 20 to 30 at days. Can you shed some light on it.

Just leave it in your spam box. They do NOT know anything about what you do unless you open the spam message with images turned on, or you click on a link in the spam. As long as you avoid those two actions they don't even know that you got it.
Leo
09-May-2011

coder1413514512456
May 18, 2011 7:57 AM

For Windows 7 it is different, and there have been several comments to this, one of which is close but I found not to be completely accurate. What I found works for Windows 7 running IE9 (or IE10 preview) while keeping QuickTime is the following:

1. Start > Default Programs > "Set program access and computer defaults" > Custom > Choose a default media player don't select QuickTime but DISABLE access to the program > Select Windows Media Player > OK

2. "Set program access and computer defaults" > Custom > Choose a default media player don't select QuickTime but re-ENABLE access to the program > OK


I found that if I didn't disable QuickTime, the selection just wouldn't take. (Then I re-enable QuickTime but don't choose it so it can be used yet doesn't force itself as the priority. This is if the user wants QuickTime to remain capable.) Also, you do not have to restart IE 9 or IE 10 for this to work.


Cheers,

coder


a nobody
August 10, 2011 12:58 AM

If you want to get rid of quicktime annoyance, just open whatever browser your using. Example: If i opened firefox, i went to Tools, then add-ons, then i scrolled down, found quicktime, disabled it.(you can always enable it for whatever purpose you need it for l8er on) Boom, now you can download songs and whatnot again :3 Hope i helped xD

works4me
October 27, 2011 1:17 PM

Thanks to anobody....that quicktime TRASH was driving me crazy! Quicktime is almost worse than the AoHell software!

"If you want to get rid of quicktime annoyance, just open whatever browser your using. Example: If i opened firefox, i went to Tools, then add-ons, then i scrolled down, found quicktime, disabled it.(you can always enable it for whatever purpose you need it for l8er on) Boom, now you can download songs and whatnot again :3 Hope i helped xD"

Lassar
August 30, 2012 11:19 AM

This post is obsolete.

The is no files types in media player options, or QuickTime preferences .

In vista, you go to control panel, default programs.

You can set your audio preferences here.

But it does not help.

QuickTime still hijacks the mp3 mime in IE.

A possibility is to uninstall QuickTime and install QuickTime Alternative codec.

Don't know if this will fix the problem, but it's worth a try.

Hearth M. Rising
January 6, 2013 8:06 PM

Article is outdated for Windows 8 and Media 12. I tried everything, including making Media default player and disabling Quicktime addons. Nothing worked. Finally I uninstalled Quicktime completely. Now it's gone and Media is back.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.