Helping people with computers... one answer at a time.

IE (Internet Explorer) is frequently configured to make a "clicking" sound when you move from page to page. Here's how to turn IE's click sound off, or change it.

Every time I change to another page in IE6 SP2, whether by using the back and forward buttons, clicking on a link, or typing a URL, there's a sound that plays. It sounds like a muffled explosion and it's annoying as hell. I checked all the assigned sounds in the control panel and there's no entry for IE at all, so there are none assigned to it through there. Where else can I look? I'd like to get rid of it, but even substituting a simple beep would be a big improvement.

Actually you were looking in the right place - Control Panel, Sounds - it's just that it's totally not obvious which item you want to change.

So everyone else can get there, we'll:

  • Open Control Panel

  • Open Sounds and Audio Devices

  • Click on the Sounds tab

  • In the Program events: list, scroll down to the section for Windows Explorer

"...imagine Homer Simpson saying "D'oh!" each time you navigate."

So "magic item #1" is that Internet Explorer takes some of its settings from Windows Explorer.

  • Scroll down to the Start Navigation setting within Windows Explorer

And "magic item #2" is that the setting that controls the sound you want is called "Start Navigation"

Here's where we are at this point:

Sound Control Panel Dialog

You can now select different sounds for that setting, using the Sounds: dropdown beneath the list. One of those settings is "(none)" to turn is off completely. Alternately, you can use the Browse button to assign just about any ".wav" file to be played - imagine Homer Simpson saying "D'oh!" each time you navigate.

OK, maybe not.

Article C2763 - August 21, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

19 Comments
bob
November 16, 2006 1:36 PM

i have done this and have to do it every time i turn my computer back on as the sound reappears! have i got a virus or something?

Mad
November 25, 2006 11:36 PM

me too i turn it off just like this and i still get that little click, at this point when i go into sounds to turn it off, it's already off. I'm confused.

pramod
January 26, 2007 8:44 PM

thank you Leo, it worked for me. Guys, if not working for you, try to block popup sound too!

Shane
November 1, 2007 4:07 PM

Thanks again Leo!
(darn stupid noise)

Russell
November 4, 2007 4:49 AM

I'm having the same trouble as the first two posters - I follow the instructions but when I go back into the Sounds applet, after clicking Apply and OK, it has reverted back to how it was, i.e. Windows doesn't seem to save it, or something else is over-riding it. Any suggestions on how I can fix this? Thanks, Russell.

John
December 3, 2007 10:15 AM

Great! This noise is really annoying when listening to online radios!! THAAAANK YOOOU!

QA
April 13, 2008 4:10 AM

Thank you! Hopefully this puts an end to it. Such things drove me to FireFox long ago, but occasionally I do find myself in IE and now it will at least be bearable. Notice how there are no pleasant sounds in the entire list of Windows sounds?

A
April 23, 2008 12:07 AM

Thanks for the info Leo! Why on earth would we want these annoying sounds in the first place? We can already SEE WHEN WE HAVE CLICKED ON SOMETHING!

jj
June 20, 2008 5:27 AM

Thanks. Worked first time. Dont we just love computers.

andyolinyk
November 26, 2008 2:08 AM

well.i was running into the same "my sound is already off and i was still hearing the clicking noise" wall and so i went to opera prefs and i took the check off the enable program sounds and it seems to be working and ...AAAAH!!!!! [removed]!!! ....NEVER MIND

rod merritt
March 12, 2009 5:22 PM

Thanks! That has been irritating me for a long time, especially since that is supposed to be the sound Google Taskbar makes when it blocks a popup. I kept thinking... is something being blocked now?

mark
March 25, 2009 8:25 PM

i've wanted to turn that sound off for years...my god my live has improved SO MUCH!! it was expecially annoying in hotmail...now if i could only figure out how to turn the noise off in outlook...d'oh!

Liana
May 5, 2009 8:03 AM

I turned off everything what everyone sayd,but... i steel have a "click" sound !!!!!Heeeelppp

Jenny
November 6, 2009 3:32 AM

I'm a little confused here, because the remedy given here is not effective, and yet the administrator just seems to have dropped off. If I remember this site, and I may not.. I will provide the correct remedy when I have it. Thank you.

dean
March 18, 2010 8:17 PM

great help
having said that...
how do u turn it back on ???

Jonathan Amorosi
April 8, 2010 8:52 AM

Yes this does work, but I am using Vista (unfortunately for me) and the process is just a little bit different but once you know the sound to change is "start navigation" then you can locate it.

Jarek
May 12, 2010 12:43 AM

i found ibSilent, it turns off sound of flash adverts.

Charles
August 17, 2011 5:26 AM

I find windows sounds infuriating – especially when I am recording something and want to navigate the computer.

I have tried turning them off, but Windows XP – ‘works the way you want it to’ – doesn’t believe that I really want sound off and turns them back on again!

My foolproof way is to go to Windows/media folder (you may have to unhide the contents) where you will find all those annoying sounds that have been bothering you. Delete the lot! If you are a bit wimpy, then create a new folder in ‘media’ and move all the sound files into it. In either case – the result is blessed silence and Windows cannot reinstate the damn things.

JN
October 15, 2011 5:37 PM

Second time i've had to use this - I made the mistake of not having windows update off since i got the computer and it reverted the sound choice!

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.