Helping people with computers... one answer at a time.

Internet Explorer will sometimes not display pictures. Bypassing security settings occasionally helps but there are also other settings to check.

I am finding it very annoying that pictures in Internet Explorer 7 are not getting through because of some security settings. When opening a website with technical info and the illustrations are not displayed, they are useless. Is there a way to disable these settings in IE 7 and damned the consequences?

Well, to begin with pictures shouldn't be getting blocked based on security settings. You can turn pictures off entirely, of course, but that's a speed-up intended for slow connections.

Let's double check that setting, consider a couple of other issues that might be causing this problem, and then also see about what it means in IE7's security settings to, uh ... ignore ... the consequences.

The ability to display pictures should be turned on by default, but IE7 still includes the option to turn it off. This is a browser-wide setting, so it'll effect every website you visit.

In IE7 click on Tools, Internet Options and then click on the Advanced tab. In the Settings list, scroll down until in the Multimedia section you see Show Pictures:

Show Pictures option in IE7

Simply make sure that's checked, or not, as you see fit.

"Another possibility is that your security software is somehow interfering with your web page displays."

Sometimes files in IE's cache can interfere with new files and pictures. The quickest approach to eliminate this as a problem is to clear the cache.

Click on Tools, Internet Options and then in the General tab, in the Browsing history section click on the Delete... button:

IE7 Delete Browsing History dialog

In the Temporary Internet Files section click on the Delete Files... button and then click on Yes in response to the confirmation request.

Another possibility is that your security software is somehow interfering with your web page displays. Unfortunately there's no way for me to confirm that this is the case, because different security packages all operate differently and have different levels of what I'll just call "intrusion" into your browsing experience.

If you're running a software firewall or some other kind of internet security suite, I would take a few moments to review whether or not that package is involved in protecting you from what your browser might display, and in turn, how to go about turning that off.

Since you mention these are technical sites, I'm wondering if these aren't plain old images at all, but rather some kind of interactive, Javascript or other technology based image displaying utilities. If you can scroll around the images, zoom, pan, and whatever else, it's likely that this is the case.

This is also a case where "damn the consequences" might be an appropriate solution.

Within reason, of course.

In short, we're going to add the site you're having trouble with to Internet Explorer's list of "Trusted Sites". That should remove most of the restrictions that IE might be placing on that site's content.

Once again in Tools, Internet Options, this time click the Security tab, and then click on the Trusted Sites zone icon:

IE7 Security Tab

To add a site to the list of trusted sites, click on the Sites button:

IE7 Trusted Sites list

Enter the URL of the site that you're having issues with (you can see I've typed in "http://ask-leo.com" here as an example). You also may need to un-check "Require server verification (https:) for all sites in this zone" if the URL does not begin with https.

Click on Add, and then click on Close. This will bring you back to the Security Tab displayed above. You may want to drop the security level of this zone from Medium to Low:

IE7 Security - Low Setting

Since only sites you trust will be placed into this zone, it's reasonable to drop the restrictions placed on them. As it states "Appropriate for sites that you absolutely trust".

And if you don't absolutely trust? Well, that's the "damn the consequences" part of it all.

Article C3399 - May 29, 2008 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

9 Comments
C Muncy
May 30, 2008 3:01 PM

The user should also make sure that he has downloaded the latest Java updates. One of my co-workers complained of being unable to view Google maps and various other web content. Problem was solved after downloading latest Java updates.

RITA OBERMAN
November 17, 2008 2:28 PM

Sometimes interactive buttons are not displayed. I am trying to purchase something and I can't find the "submit" buttions. Live Chat does not work.

Don
December 18, 2008 9:10 PM

So simple to just check a box labeled "show pictures"...Thanks Leo. This is a great site.

manjit
January 23, 2009 1:50 AM

similar kind of problem i face. The pictures on the IE 7 browser are not clear it is hazzy. I have windows vista home premium on my toshiba u400 laptop. Plsd to know any solutions?
thanks and best wishes.

Clyde
May 24, 2009 7:57 PM

I am having the same problem on my computer but the images will show on other computers, using IE and FireFox, including mind. I have deleted the Cache, all MS updates are current. One image is a normal jpg and the other is flash and neithter will show, yet other .jpg's on the same page does display. Thank you for looking at this

jyotika
February 3, 2010 1:23 AM

images are not cear during the use of internet.how i can solve to this problem?

Srinivas
March 26, 2010 6:03 AM

Still .jpg images are not displaying in IE6.
plz any help..

for eg: http://www.magnabuildersdirectory.com/trader/thumb/2147483647.jpg

Krishna
April 17, 2010 1:38 PM

Try this :-

IE7:
Go to Internet Options
Go to Security
Click on the Internet icon
Click on the Custom level button
Scroll down and near the bottom, look for "Display Mixed Content"
Change it to Enable

Its works like charm.

S. Beal
April 3, 2013 1:57 PM

I had a similar problem. Some web pages would not show and clicking on the picture on properties reported the picture as a Blank.Gif. I went into Manage-Add-ons in IE 9 & 10 and went to Tracking Protection and disabled all protection, closed IE and restarted. Problem went away and pictures were visible. Went back into Manage add-ons and into Tracking Protection and re-read all listings and re-enabled one at a time looking for the problem listing. I now use a personal listing based on what I want blocked. Hope this helps someone, I have been trying to find a solution to this for the past 6 months.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.