Helping people with computers... one answer at a time.

Computers can be configured to shut down after periods of inactivity. But if it happens without having configured it, reasons aren't as clear.

When my desktop PC is idle for a time, it shuts off. At first, I thought it was a thermal issue, but the unit doesn't shut off when it's being used, even for extended periods. That led me to think it was a power-management glitch. I figured that disabling system standby and/or hibernation would work around the problem, but when I checked the settings, they were already turned off.

Any ideas?

I don't have anything very specific, but there are a few things I'll throw out as places to look and perhaps some items that hadn't been thought of yet.

The first thing that comes to mind is your screen saver. Particularly if "after a time" is a relatively consistent amount of time. Normally a screen saver wouldn't turn the computer off, but a screen saver is software after all, and could have a bug that's manifesting on your machine.

This certainly sounds and feels like it could be a standby or hibernation issue - though if either you'd be able to tell right away when you turn the computer back on. If it resumes immediately it went into standby, and if it says "resuming from hibernation" that's pretty clear. Even if hibernation and standby are turned off, for a long time I ran into a problem where they would automagically turn themselves back on.

"Power management is, at its root, a BIOS initiated and managed thing."

Another place to look is the ACPI (Advanced Configuration and Power Interface) power settings in the BIOS. Power management is, at its root, a BIOS initiated and managed thing. Perhaps turning that functionality off in the BIOS, or at least twiddling with the settings there might affect the issue.

There are services that kick in after inactivity. The indexing service is one (you can turn it off), and in Vista I believe there's a bunch of defragging stuff that happens in the background after some idle time. In either of these or similar cases it's possible that the service is causing a problem that would result in the machine shutting down.

In fact, because of the possibility of services kicking in at idle time, it actually still could be a thermal issue. The services might be driving the machine harder than you do when you use it normally, and thus the machine might be experiencing higher temperatures. If it's something you can watch, try running process explorer and see if some application is using up all CPU prior to the machine shutting down.

It certainly wouldn't hurt to run a RAM diagnostic anyway.

You might have a look in the event log for anything suspicious. Error messages or messages of other activity that happen around the time of the shutdown might throw some interesting light on the situation.

Article C3281 - February 3, 2008 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

10 Comments
Big Bill
February 9, 2008 7:04 AM

I am not a fan of indexing, which I turned off on my old system, as the sound of my drive working when I'm not irritates me. Imagine my chagrin to discover you are not allowed to turn off indexing in Vista (contrary to the impression Leo gives in the article, above.)

Terry Hollett
February 9, 2008 7:59 AM

To turn of indexing in Vista:

Open up Services through control panel, or by typing services.msc into the start menu search box. Find "Windows Search" in the list of services and double-click on it to open it.

Change the Startup type of the service to Disabled, and then click the Stop button to stop the service.

www.geocities.com/terryhollett2003/

Jon Smith
May 16, 2008 2:09 AM

At night, I usually put my desktop (XP) into hibernate mode. In the morning, while I wait for it to power back up again, I get bored of waiting so go and make myself some tea. When I come back, it's powered itself down again. It seems that if there's a period of inactivity from the point of coming out of hibernation, then it will power down. Once I've moved the mouse or pressed a key in the morning, it will never auto-power-down. I've tried the suggestions above, but to no avail.

yang jian jun
June 5, 2008 7:50 PM

my lenovo think center A61 desktop pc power supply auto shutdown after power on few 5-10mins.

John
February 23, 2009 4:09 PM

I have some new HP Computers running Vista at 2 sties. 1 site has no problems. On the other site the people say that when working on the computer on a terminal server if they leave for a extend period of time the computer will kick them off of the terminal server and log off.

David Spector
November 30, 2009 5:07 AM

To Jon Smith: Microsoft, knowing what we need more than we ever could, put in a permanent feature that hibernates your computer five minutes after you bring it out of hibernation, unless you press a key or move the mouse. They reasoned that, since an XP computer can (by default) be brought out of hibernation over the net (how many people even know this?), that this might happen by mistake. In such a case, this five minute feature would actually be useful.

I know of no way to disable this wonderful feature.

Shaun
February 22, 2010 2:25 PM

i just experianced this exact issue with my computer. Replacing the PSU solved all problems now for 2 weeks.

Stephanie
May 18, 2010 8:55 AM

I defraged my computer by hitting the defrag for the first time on my own in 6 yrs! Yes i am totally illiterate when it comes to computers! Anyway it began to act irratically after this and would go into hybernation constantly. I went in and changed the time for hybernation to 45 min and now, if I am not hitting any keys and am just reading something, it goes to the welcome screen after only 2 minutes. I lost how to get back in to change the minutes.nThe computer wakes up as soon as I hit on my name, but it is getting annoying losing the site I am logged on every 2 minutes. I have a 6 yr old compaq presario # 3000 windows XP. Any suggestions would be so very appreciated!!!!
Thanks!!
Stephanie

betty drew
January 6, 2011 8:42 AM

i know there is a place to put in length of time before computer shuts down because of no activity. where do i find where i can set the length of time before computer shuts down because of lack of activity. i have my yahoo home page and walk away for ten minutes and i have to put my password in again to get back to my yahoo home. please help.

betty drew
January 6, 2011 8:44 AM

i know there is a place to put in length of time before computer shuts down because of no activity. where do i find where i can set the length of time before computer shuts down because of lack of activity. i have my yahoo home page and walk away for ten minutes and i have to put my password in again to get back to my yahoo home. please help.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.