Helping people with computers... one answer at a time.

PPS files seem to cause many people problems. We'll look at how to go about configuring your system to view PPS files.

I followed your instructions to create a file association for PPS files, but I still get an error when I try to open PPS files attached to email. What am I doing wrong?

It's hard to say, but I will say that for some reason, PPS files cause a lot of people consternation.

Let's review what you should do, and what to do if that doesn't work.

First off let me remind you that you must have either PowerPoint or PowerPoint Viewer installed. PowerPoint comes with Microsoft Office, and the PowerPoint Viewer is a free download from Microsoft (here). The difference is, of course, that PowerPoint will let you create PowerPoint presentations, while the viewer will only allow you to view them.

Now, as I stated in my previous article This file does not have a program associated with it - what does this mean and what do I do?, the most common solution is to simply install the program that understand PPS files. If you don't have Microsoft Office, that means downloading and installing the free PowerPoint Viewer. Setting it up should create all the appropriate associations for you to be able to view PPS files.

If you have Microsoft Office, you can perform a repair install, making sure that PowerPoint is, in fact, installed.

Unfortunately for some folks all that doesn't appear to work. Very well, we'll do things the hard way ... meaning we'll do it by hand.

I'm going to assume you have successfully installed the free PowerPoint Viewer.

Fire up Windows Explorer (right click on My Computer and click on Explore is one quick way). Click on the Tools menu and then the Folder Options item. In the resulting dialog, click on the File Types tab, and you should see something like this:

Folder Options, File Types tab

Scroll down to the PPS entry, or where the PPS entry should be alphabetically. If you don't find a PPS entry, click the New button and enter PPS into the resulting dialog to create one.

Click on the entry for PPS, and then click on the Advanced button. The result will look something like this:

Edit File Type dialog

For the moment we'll ignore the entry that says "Print", and focus on the other - "Show". What seems to be unique about PowerPoint Viewer is that it doesn't use the word "Open", but rather "Show" as the action to perform. My theory is that that's the cause of much of the confusion.

If "Show" doesn't exist in the list, click on New..., enter:

&Show

into the Action box, and then:

"C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe" "%1"
"What seems to be unique about PowerPoint Viewer is that it doesn't use the word 'Open', but rather 'Show' as the action to perform."

Into the Application used to perform action: field. Go ahead and check DDE as well, entering "pptview" (without the quotes) into the Application field, and "System" into the Topic field.

Press OK.

If you did have a "Show" option, or you just created one, you can check it by clicking on "Show", and then clicking on Edit.... The result should look something like this:

Edit Action dialog

Note that even though it's not entirely displayed, if you click in the field Application used to perform action:, and scroll to the right, you'll see it contains the entire string:

"C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe" "%1"

Press OK, and you should be back at the "Edit File Type" dialog pictured earlier.

Important: click on the "Show" action, and then click on the Set Default button. The "Show" item should turn bold, as seen in the image above. This tells programs which action is the "default" thing to do with a PPS file under certain conditions.

OK and Close your way back out, and you should now have a proper association.

Note: as I said this assumes the free PowerPoint Viewer, which you'll have had to download and install, and it assumes you installed it to its default location. If you're using PowerPoint itself, you'll need to locate "powerpnt.exe" on your hard disk and enter its path instead of "pptview".

If you'd like to create the "Print" action, the steps are the same, except that the Application used to perform action: is:

"C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe" /p "%1"

Thanks to one of my readers for pointing out the potential role of "Show" in people's confusion on this issue.

Update: Ramesh's Site includes an article Unable to open .PPS attachments directly from Outlook Express? which includes not only instructions similar to the above, but a utility that you can run to install the fix for you.

Article C2785 - September 11, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

58 Comments
John Hileman
September 12, 2006 2:58 PM

An alternative to the free Microsoft viewer would be to install the wonderful, free OpenOffice. OpenOffice also includes word processing, spreadsheet and database. Available from http://www.openoffice.org

Dik Heikoop
September 15, 2006 5:19 AM

Still going wrong here with free Powerpoint Viewer
Everything now is as you said, except that I had to put the next path also between Quotes:
C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe
Without quotes I could not save my edit (2x)
My "Show" (in dutch called "Weergeven") item was already turned bold.
Can my problem something has to do with my DUTCH Windows XP home ?
My Powerpoint Viewer is also a dutch one.
Also same problems with PPT files.

Dee Jay
September 15, 2006 9:26 AM

I was reading abt the pps problem, no file association.... I know you cant play the pps from an email.......at least I cant.. I drag it out to desktop and then click on it to watch them. I keep them in a folder called pps and can watch them anytime I want to..but I cant open them in email. Must drag them out first. I do have a pp viewer installed. Hope this has helped a bit. Im not expert, but this is what I have found.

Randy
September 15, 2006 3:49 PM

If the person's e-mail program is Eudora, there's not much he can do: I've got Eudora, and it absolutely refuses to open Powerpoint files that are e-mailed to me. If I go to the "attach" directory where the file is stored and click it there, it opens no problem. But not from within Eudora. I have no idea why that is, and it's possible other e-mail programs display the same behavior. Either way, it's a PITA.

Barb
October 24, 2006 3:50 PM

I still can't open a pps file, even after downloading the free powerpoint viewer and following your instructions for manual reconfiguration. (there was no "show" or "print" wording.)I have bleeping Office pro edition 2003!!

Marty
November 15, 2006 9:39 PM

When I try to open a .pps file from Outlook Express, I get an error message that it is not a valid Win 32 application.

Gerry Jarratt
November 18, 2006 6:46 PM

I can't open pps files from outlook express, but can open them if I drag them to desktop. How can I fix this?

amol sharma
November 20, 2006 8:46 AM

I tried your all steps. After that it is asking for "documents" and "and" files. What do I do?

Janice
December 7, 2006 10:06 AM

Thank You for the direction..fixed the problem..the browser option worked better for me..got the direct link from my program files..Thanks

Dianna
December 18, 2006 10:05 AM

"I tried your all steps. After that it is asking for "documents" and "and" files. What do I do?"

Posted by: amol sharma at November 20, 2006 08:46 AM

YES, Now that is my problem!!! Now I can't even look at my pps file on the desktop!!! I could look at it if I saved it to desktop, but now, after doing what was told here, it won't work at all!!!! Exactly as mentioned above is happening. It says it can't find "documents" and "and" files?????

Mike Stevens
December 19, 2006 2:32 PM

I did everything you suggested. Still cannot directly play .pps files.

Mike Stevens
December 19, 2006 2:47 PM

OK, I've fixed it partly from what you said. I selected "New" in the "Edit File Type" box, and typed "Open", entered the C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe /p "%1", OK, OK and it worked. Thanks for your help.

Harry Cooper
December 24, 2006 3:52 AM

I received a Christmas greeting in the form of a pps. file that I could'nt open. After reading your page and re- installing MS Office (inc. Power Point) I was able to see what had been sent to me...... and it was lovely. Many thanks and Seasons greetings to you.

Harry Sarajian
January 20, 2007 9:44 AM

I still can't view a .pps attachment in Outlook Express. I have downloaded PowerPoint Viewer and implemented your instructions. If I save the attached .pps file in a separate folder on my C: drive, I can view it via Windows Explorer using the PowerPoint Viewer. However, Outlook Express still produces the same, original message..."This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel." My computer runs Windows XP-Professional and has SP2 installed. Any suggestions? Thanks.

Rob Nieman
January 28, 2007 11:11 AM

this way to do it doesn't work for me either. after i'm all done creating everything, something deletes it. When i go back to see if it's still there under the file types tab, it's completely gone like it never existed. VERY frustrating.

Edd
February 7, 2007 10:55 AM

I still can't view a .pps attachment in Outlook Express. I have downloaded PowerPoint Viewer and followed your instructions. If I save the attached .pps file in a separate folder on my C: drive, I can view it using the PowerPoint Viewer. However, Outlook Express still produces the same, original message..."This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel." My computer runs Windows XP and has SP2 installed. Any suggestions? Thanks.

Eric Y.
February 7, 2007 5:00 PM

I could strangle Bill Gates for the aggrevation of trying to get a simple program like Powerpoint viewer to work. I tried everything in your article and the comment posts. Nothing worked until I found a back door to open the .PPS extension. Here's how. 1) Save the Outlook Express message in your documents. 2)Right-click on the file. You should get the menu for "Open With" There should (not in my case) be an menu box with "Microsoft Office PowerPoint Viewer" (Wasn't there) Then you can open the freaking file. In my case I had to go on search and rescue to get Powerpoint to even be an option in the menu box. Gee, can Micro$oft extract even more of my hard earned salary for a "free" program that requires a PHd to use? Never and I mean N-E-V-E-R have I gone through such an ordeal as to open, I mean attempt to open a .pps file extension from Outlook Express. Even with my technical and somewhat geeky skills, the attempts were not worth the effort. If I could hit a Micro$oft "representative" with a 2x4 until he or she was unconscious, I would. Telephone "support". I'd rather have a chimpanzee come over and attempt to fix the problem. As Mo from the 3 Stooges use to say...Why I oughta...

Little Girl
March 9, 2007 11:14 AM

they just want you to get annoyed and buy Powerpoint. I prefer blocking e-mail from ppl who send .pps's solution.

Millie Johnson
March 14, 2007 5:25 PM

I've followed your instructions; however, at the end I get this message "the specified program could not be found. Make sure file name & path are correct. Where do I go from here? Thanks for your help up to this point.
Millie

Leo Notenboom
March 14, 2007 6:40 PM

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Try putting the program in quotes. Like so:

"C:\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe"

Leo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (MingW32)

iD8DBQFF+KPaCMEe9B/8oqERAsIlAJ94a/CjM5gTaLzsC2ZZfM5pbqbMswCdESfI
jsVMbRGz+wISpbrrTiprzV8=
=9/g4
-----END PGP SIGNATURE-----

Greg
March 16, 2007 6:26 AM

A program from this website fixed the problem for me.
http://windowsxp.mvps.org/ppsopen.htm

paul ferraro
March 17, 2007 6:33 AM

pps files still don't work after following your instructions please reply

Kevin Tilley
March 22, 2007 1:53 AM

The program name is ppviewer.exe not pptview.exe

Kerrieanne
March 23, 2007 3:59 AM

I still could not open pps file in Outlook Express,I tryed everthing you suggested. After all that I could veiw the file once I saved it in my documents.

Rick Lowman
March 27, 2007 1:13 AM

I too tried to do the manual fix outlined above, without success. Then I went to the link in the "related sites" and opened Ramesh's Site on the link "Unable to open .pps attachments directly from Outlook Express". Once in, there is a small utility download that provides a fix at a click of the mouse (don't be afraid of the 'unknown publisher' designation). Quick and easy!

Wade Harford
April 9, 2007 9:21 AM

I copied my Power Point Viewer File from Office and installed it in My Documents. I then recreated my association in Folder Options and directed it to My Documents and my pps files are opening great now. Try it.

John Hatch
April 12, 2007 2:54 AM

Note :- there is an easier way of setting file associations. Right click the file and select 'open with...'. Select the program you wish to associate the file extension with and then tick the box that says 'Always use this program to open this type of file'. Association made!!

Janice
April 29, 2007 4:35 AM

Thank you! Have been attempting to fix .pps since 10/2006 with no luck. Followed your instructions, then went on to Ramesh's site and downloaded the Fix utility for Outlook Express.
It worked! Thanks for your help, Leo.

John Davis
May 23, 2007 2:57 PM

Have been fighting with this pps bug for over an hour - After trying your fix - (I think I managed to screw up the "exe %1" somehow) I went to Ramesh's Site and downloaded his fix. Worked like magic!

Thank you ever so much - Will be back for more "Magic" in the future.

Signed - "sigh of relief in PA"

Bijan Fard
May 27, 2007 2:10 PM

I send a PPS file as an attachment, but the sound files won't play . . . what should I do, I am confused, they play when power point is open, then when I send it to other e-mails, they are rather lost, hidden or disabled for playback, is there something I can do?

Checko
July 5, 2007 9:07 AM

Thank you very much !!!!! this helped me more than our Knowlix DB ...

I had one happy customer , thanx !!!

luther Bolen
October 15, 2007 7:16 PM

I failed until I installed the Ramesh utility, and
now I can open .pps files with no problem---thanks
a bunch, guys----
aaaluther

C. Daniel
April 6, 2008 6:29 PM

That fix program was a life saver!!!!

Adel H
July 15, 2008 3:50 PM

It seems your fix to the problem is to make "show" the default, but the Ramesh repair makes "open" the default. Would this confuse people ( besides me )?

John Bates
July 28, 2008 1:14 AM

Got to 'edit file type' and 'editing action for type', had the right string in 'Application used to perform action', but got 'specified program could not be found,make sure the file name and path are correct'Have downloaded PP viewer several times.

blair girtley
August 24, 2008 12:13 PM

i just wondering that problem with downloading is nto working i dont know how to figure out come from where? i cant find so problem with installed and like run and twice run but verfity is not working but too long like 3 hours something wrong with that like pc something inside from the desktop i dont know i am not sure anything bout it so let me know please please help me i was so fruasted myself get mad so i give up so give me how direction do u care help me ok thanks i appericated

Alex Cerny
December 21, 2008 8:41 PM

I could not get "Show" to be default. My solution was to create in window "Edit File Type" new entry "Open",then click Edit to open window "Editing action for type" and in that window type into "Application used to perform action" the whole string suggested for Show ie. "Disc\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe" "%1" Make sure that the path to your PowerPoint Viewer leads to correct disc. After that set default and "show" will appear bold. Close everything.Took me a while to convince myself that "show" default in my case did not work.

D. McDonald
January 10, 2009 12:59 PM

On Opening folder options, there was no file type tab. Only General, view and search tabs. Tried to look for file types but found nothing. Can you help.New computer with vista system. Thanks

Tony
January 14, 2009 1:18 PM

Tryiny to edit show It comes up S&how I try to change to &Show and it tells me I don't have the programe at that location.. But it is there.. "C\Program Files\Microsoft Office\PowerPoint Viewer\pptview.exe" "%1"
What am I doing wrong

Tony
January 14, 2009 1:28 PM

Sorry-- Let me update my problem.. Along with not being able to EDIT the s&how, the reason I even got to this point is that I can not read pps in my "mail"
I am using MS Outlook Express.
I can go to pptview.exe and run the program, but it asks what file to read and I don't have any files other than express mail and I don't know how or where to find them..

Lawn
January 14, 2009 3:27 PM

Please see my earlier message trying to view pps email attachment. I've installed PowerPoint Viewer 2007.I performed all tasks above but same message comes up, "This file does not have a program assiciated with it..."

Christine Wakeham
February 17, 2009 8:48 AM

I have this problem on Vista. What is the process required on Vista please.

Ray
April 14, 2009 8:33 AM

I also cannot get this to work. When I pull up folder options via control panel PPS is listed in the file type. When I click on show I get S&how in the Action box and everything else is the same as your suggestion. Changed to &Show and no help.

Cathy
April 22, 2009 5:57 PM

Downloaded viewer. PPS file was listed, as was the whole sequence as you said it should be. Show was the default, everything was how you said it should look. But when I tried to click OK to close I got "The specified program could not be found. Make sure the file name and path are correct." Of course they are correct, they were already there!! Help!

Bob Martin
August 4, 2009 4:44 PM

Downloaded pps viewer, opened .exe file to install.Then when I try to view a pps file I get a message asking for my name, organizatio, and product key..I don't have one because I don't have Office, so I can't start the pps.

Don Rogers
August 20, 2009 12:48 PM

I fixed the .pps file extension and added open. I
now get powerpoint to open but get errors sayiing
it cannot fine the attached "Australia vissen koraal.pps" file. 1st I get power point viewer cannot find the file "documents", then I get
power point viewer cannot find the file "and",
then I get power point viewer cannot find the
file "local", then I get power point viewer cannot find the file "temporary", then I get
power point viewer cannot find the file "Internet", then I get power point viewer cannot find the file "Australia", then I get power point viewer cannot find the file "vissen", then I get power point viewer cannot find the file "koraal.pps", then after I click OK on the last one the power point viewer closes without opening anything. Can anyone help me???

JUAN MANUEL
September 9, 2009 9:08 PM

THAT WAS THE BEST ANSWER TO BE AVAILABLE TO OPEN
POWER POINT (PPS) FILES FROM THE WEB THANKS

Albert
September 28, 2009 7:01 AM

I had some trouble with getting the instructions right i guess, but I went to Ramesh's site, downloaded and ran the utility for an instant fix.
Thanks.

Larry
November 2, 2009 6:12 AM

I had the same problem and I also had the S&how entry as the default. To fix the error, I followed the instructions as published in this article to create a new entry but I used &Open in the Action field. Now it is working fine.

Patsy
December 15, 2009 1:35 PM

I have a Vista and tried everything, so I send a PPS file to my documents and can open it from there.

Edward
December 25, 2009 9:05 AM

Most of the article above deals with XP. I have been able to associate the extensions with the correct files and even go into the register and remove show and put open to make them work, however with Windows Vista I did all the things required to open PPS but it still did not open. I found that it was missing from the file associatin page under the extensions alphabetical list. PPT and other extensions were there but PPS was not. How do I put it back on the page so I can associate the Power Point Viewer with it?

Momus
January 20, 2010 11:10 AM

Larry > create a new entry but I used &Open in the Action field

THANKS!!! Creating the "Open" action fixed the problem with Outlook Express not opening .pps files.

I much prefer your help, to the "fix" exe file offered everywhere else.
It's better to understand the problem and the fix, then to use blindly a fix hidden in an .exe file.

BTW, Microsoft while clearly aware of the bug didn't bother to fix it for over five years! They've saved a few minutes of their own time at the expense of thousands of hours of user's wasted time and frustration. Why am I not surprised?

R Posey
February 1, 2010 4:27 PM

On my Windows Vista, there is no file type tab in Folder Options. What now?

Terry Ball
March 11, 2010 3:07 PM

I use windows live, have install the pps viewer and I still can't open pps files without saving them and then viewing them using the viewer.

J Marker
March 18, 2010 8:05 AM

Great web site and my problem is solved. You are right, PPS files are a pain. Your site was given to me by a tech at systemax. Thanks

Barbara Henschel
June 25, 2010 10:18 PM

I have the same problem with Windows 7. I cannot open pps files as an attachment in Windows Live Mail. Have to save them, then use the MS Power Point program to open them. The fix you describe does not apply to Windows 7 because there is no "Advanced" button to use.

Hector Gasquet
January 21, 2011 7:53 AM

The devil is in the details. Tell your friend (linked given in this page) that he helped me solve the problem with the attached pps files, but in my case the exe file (Office 2007) was in Office14 (instead of 12) and I had to Browse instaed of writing the path. For some reason didn't like my writing.

Sorry I used your page, but the Feedback tab in your friend's page is not working.

Thanks for the link.

s.singh
April 13, 2011 11:00 PM

I use windows XP, have install the pps viewer and I still can't open pps files.
What can i do.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.