Helping people with computers... one answer at a time.

If what you type isn't what you get, one possibility is that your keyboard is configured for the Dvorak layout. We'll look at how to check and fix it.

I just installed XP SP2. Occasionally now, my keyboard layout changes without warning and I don't know how to get it back to the normal "qwerty" layout. For example:
q='
w=,
e=.
r=p
t=y
y=f
l=n
I haven't been able to figure out what triggers this. Sometimes it corrects when I change programs; otherwise I reboot. I've checked the language and regional settings; they're okay.

The list of character changes was particularly helpful. It's what happens if a keyboard gets put into Dvorak layout.

But why did it happen? That's a little unclear.

Dvorak is an alternate keyboard layout that's more ergonomic and efficient than the traditional "qwerty" layout we're all familiar with. Where qwerty was designed specifically to slow down typists that were too fast for old mechanical typewriters. Dvorak is designed to be fast and efficient. You can read more about the Dvorak keyboard, its origins, and resources here at The Dvorak Keyboard - A Brief Primer.

It's unlikely that Windows would spontaneously load up the Dvorak driver - the first time takes a reasonably complex procedure.

Once the driver is loaded, you can set it to switch back and forth via an icon in the notification area of the taskbar a specific keyboard sequence. But you'd probably know it, as it has to be set up for either or both.

You can check in Control Panel, Regional and Language Options, Languages, and then the Details button.

Article C2221 - November 11, 2004 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

16 Comments
Benjamin Lindelof
November 12, 2004 5:03 AM

I think I can answer this one. Spyware/Adware creators are on the run.

However, they are probably bored. I mention this because usually if I am browsing around I'll get messages asking to install plugins.

Yesterday it said there was a Microsoft Corporation plugin that was going to install. There was NO way to cancel it.

At this point, I could have clicked anything and the program just installs -- in your case -- a keyboard driver and made it active.

The only way I could avoid it was by opening Task Manager (I use Ctrl-Alt-Del for fun), then I clicked IEXPLORE.EXE and clicked End Task. The horrifying installation dialog box disappeared.

Just thought it might apply to this situation!

pappoonet
November 20, 2004 1:37 AM

Hi!
By default, the short keyboard way to toggle between keyboard is "left alt+ Shift". Perhaps you did that sequence... you can change this behavior with the specific tool in the taskbar. Just try to delete the short way!

Michael Farro
March 26, 2006 11:19 AM

You haven't listed a fix to this. I'm having this exact problem. Generally, it only affects one or two programs and the others will work fine. The problem I have is in MSN Messenger. I'll be using it quite happily and suddenly it will randomly switch to Dvorak. Is there a remedy? This guy is right, restarting the program or restarting the machine solves it but it is quite the annoyance.

Mike Farrow

Nikolas Andersen
May 4, 2006 5:33 AM

I have specifically installed a Danish keyboard layout, so I can change layouts using control+shift to write , and .

The trouble I have is that it sometimes spontaneously switches (without control-shift) if I change programs or sometimes within the same program if I pause when typing. I can switch back again, but it is annoying, especially if it happens when you select a password field!

If anybody knows how to disable this "feature", I'd be very grateful.

kyle
November 4, 2006 6:34 PM

I've had the same problem for a while. A few months back i was messing with the diffrent keyboard languages, and the thing is, is that there is hotkeys to change them. For instance when im playing a game, i hit alt + shift somtimes, and then all of a suddent my keys are changed. If you go to the control panel, then to regional and language options. Hit the languages tab, and then hit details and your there. Make sure that US is bolded, and not devorak or left handed devorak. If you want just remove those because you wont have to worry about those. Hope that this helped. :)

kyle
November 4, 2006 6:36 PM

also, if you want to see the hotkeys for it, while your in the details, if you hit the key settings, it will show you that you can switch the languages buy pressing left shit + alt.

Cliff
November 25, 2006 6:48 AM

Tfne is right: When I installed Dvorak, my system had only the standard US keyboard listed. Dvorak wasn't even on the list until I put it there from the installation CD. If I decide that Dvorak is not for me, then I will delete the listing -- a habit since Win31.

Rhys
September 3, 2007 5:49 AM

I have been trying to add a second keyboard for a user who has one hand that doesn't work as well. When I change applications it always seems to go back to US standard. I am thinking about having a second user created for her so that only one keyboard is installed for each user.

Mike Cooper
December 27, 2007 8:56 AM

I don't remember when, but at some point last year I had installed the Dvorak keyboard option (I guess I was just curious) and had forgotten about it. Flash-forward to this year and I'm typing in Lotus Notes and go to cut+paste something and start to type again - and the keys have gone all funny.

I called my helpdesk and they said my keyboard was going bad, which I knew wasn't the case because it was only happening in Lotus Notes (twice in two weeks!) and exiting and coming back in resolved the problem.

So to appease the helpdesk, I switched keyboards with someone else to see if I could eliminate the problem, and two weeks later, it's happening again, only this time it happened in Microsoft Word. And to cap it off, I found the key combination that was turning it off/on. For me, it was left ctrl+shift.

Searching for "control + shift" and "dvorak" brought me here and the posted information helped me find the issue. I removed the dvorak option from my settings and I no longer have the issue.

Ramesh
July 31, 2008 1:15 AM

i dont get my normal keyboard on my laptop.i have to use Fn key to Get normal Keys on my laptop?
help me

Shine
August 30, 2008 4:07 AM

Solution XP: Remove Dvorak
Ctrl Panel -> Regional and Language Settings -> Languages(tab)-> Details (Button) -> Select Dvorak from installed services and click Remove (Button)-> Click OK

Bill
November 13, 2008 7:43 AM

Shine's solution doesn't actually take effect until you reboot.
Windows sure can be annoying.

Jim
November 17, 2008 10:41 PM

Try holding 'alt' and pressing 'shift' three times.
alt+shift+shift+shift

Chris
November 26, 2009 11:31 PM

I am looking for a way to adjust the behaviour of SINGLE INDIVIDUAL keys.

I live in Australia now and therefore I would like to have a normal US keyboard layout which is common here. But I came from a German speaking country and I write lots of emails in that language. So I thought I just use the "US-International" layout setting in Windows so I can type all the necessary umlauts. These umlauts are generated when I use the right-hand side ALT key (called ALT-GR then) in combination with one of the characters I would like to have an umlaut of.

This works like a charm, but has also some really annoying drawbacks: The keys for the quotation marks (" and ') do not work as in the US layout anymore, they do not generate these characters immediately anymore but rather wait for me to type another character and if it is one which could be a umlaut in German, it makes this character to be a umlaut. An example: I type " and a, and the output is an .

Because I can easily generate an by typing ALT-GR together with q, I don't like this behaviour at all because it is inconsistent and slows down my typing (I would have to type " and SPACE everytime I want to have just the quotation mark).

Is there a way I can change this darned behaviour of just the quotation mark key? I think I heard somewhere that you're even able (through some key-mapping tables) to change the placement of any key to anywhere else, but I didn't find anything on this subject on the net.

Please help!

I use AutoHotKey to remap keys. You can do almost anything with it.
Leo
27-Nov-2009

Vivian
December 4, 2012 11:51 AM

I have the opposite problem. I like to have my keyboard set to Dvorak, and every now and then it will mysteriously switch to Qwerty. Advanced Key Settings says I have no hotkey for switching between Dvorak and Qwerty. I think there must be a secret Windows hotkey--one of its bugs/features.

Vivian
December 4, 2012 12:02 PM

Found it! Ctrl-Shift will switch between all the keyboard languages you have installed. I guess it gets pressed by accident sometimes.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.