Helping people with computers... one answer at a time.

I have a problem that neither Hotmail nor an otherwise helpful technician can solve. I have within my home a network: Compaq desktop with a D-link extreme G card, attached via a modem to an ADSL line, a separate router and a new Tosh laptop with a wi-fi card. Everything works as it should, except that i cannot access Hotmail from the laptop: any other URL can be accessed immediately. I have had various "help" suggestions from Hotmail, including re-installation of IE 6. Nothing works and my computer adviser has given up. If I plug the ADSL line into the laptop direct, I can access Hotmail normally, yet not when I do so remotely through the router and desktop. Do you have any suggestions?

I have two guesses - one involves your router, and the other involves an obscure network setting.

I've not tested this, but I wonder if HotMail is sensitive to what's called "double NATing" and wonder if that's what you have happening.

Double NATing happens if you are behind two routers, each attempting to perform "Network Address Translation". I have seen several cases where a broadband modem attempts to perform NAT, and thus in some ways it's "acting like" a router. If you put a NAT router in front of that modem, then you are, effectively, behind two routers.

When you plug your laptop into the ADSL line directly, does your IP address begin with 192. or perhaps 10.? If so, then it appears your ADSL modem is performing NAT. Addresses that begin with 192 or 10 never appear on the internet, but are assigned by routers when sharing a single internet connection between several computers. If your modem is assigning you an address in that range, then it's pretty likely that it's acting a little bit like a router. At least in a way that we care about.

If that happens, you might consider turning DHCP off in your router and seeing if a) all computers connected still connect to the internet properly, and b) whether or not this resolves your problem.

My other guess has little to do with the router, but apparently has resolved HotMail access issues for others. While I think of this as more of a long shot, it's possible that how you connect to the network could impact this.

There is an obscure network setting called "MTU" that deals with how packets are sent on the network. Several people have reported that reducing the MTU setting has restored access to some sites that they couldn't access before. This article: I can't access some websites ... why? covers the setting, and how to go about adjusting it.

As I said, it's a long shot, but it is something that could be affected by your network topology.

Article C2648 - May 8, 2006 « »

Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

Dan Ullman
May 9, 2006 1:21 PM

Err, sounds like one of the routers is blocking cookies to me

September 28, 2006 8:19 PM

I recently got time warner cable, with it came email with adelphia,. The way I got msn email was when I got Verizon DSL the msn email came with it. Now I no longer have msn email and cannot access it, to retrieve very important mail of mine that is still there . Please help

October 19, 2006 6:57 AM

You need to forward tcp/udp 443 using NAT

January 1, 2007 11:59 AM

You can't get to your free hotmail account from the laptop, you have to sign up and pay for the hotmail to get it on the laptop.

January 20, 2007 2:50 PM

Hi Leo,

Love your site, it's a godsend.

I've been trying, with the previous posts, to figure out what may be wrong. I have been unable to access hotmail either since setting up a LAN.

I run xp pro, and have a d-link wireless DI624M router hooked up to a d-link 302-g modem via ethernet cable.
The main computer is in port 1 of the router, and a laptop runs off the wireless.
Both function ok except for hotmail, gmail style addresses.
I have changed the mtu on the main computer to 1492.
I have looked into double nating. The NAT is disabled on the modem, so I presume that wouldn't be a problem.
Do you think port-forwarding may be the problem?
Would I need to assign a static IP for the main computer?

Any help you could give would be great. (ps, i'm not proficient in networking)

Thanks, Ben.

Eric Torrez
January 27, 2007 3:28 AM

Leo you are the BOMB!!!
This worked for me too, I have a comment to add. I couldn't figure out the right number to put, I tried 1500 and 1492 but neither one worked. One of my other computers could access hotmail and myspace just fine, so what I did is run the little program on that PC and noticed that the number there was 1300, so I used the same number on the one that wasn't working and all of the sudden Boom it worked. Once again thanks for taking the time to write this article.

February 3, 2007 10:53 AM

why can I not get into my hotmail, MSN comes up, but it won't let me get into my hotmail. However, it will let me do the horscopes, but other things, but not hotmail???

thomas baillie
February 27, 2007 1:58 PM

i have just bought a belkin wireless router and although i can connect to the internet i cant get onto sites like bebo myspace and cant get on my msn i have tried everything you have suggested to othere people but still no luck can you plz help thanks

Tom Young
March 20, 2007 7:25 AM

I have a D-Link DI-524 router. I never could get to hotmail through it. Finally, I wild ass guessed, and set the MTU setting in the router to 1200. It worked. I can get into hotmail, upload & download pictures, etc.

Paulo Pantoja
March 25, 2007 4:44 AM

when a tried to acess my hot mail [email address removed] I get ERROR 81000395
What's this mean?

May 9, 2007 11:33 AM

i can get bebo up on my homepage but cant sign in its been like this for a week now any ideas????

September 4, 2007 12:25 PM

Oh my god .. the MTU setting worked for me too !! I too have a D-Link DI-524 router which could not get to hotmail. I changed the default MTU setting of the router from 1500 to 1200 and now hotmail works !! I'll try slowly increasing the MTU setting to see how far up I can take it.

Thanks Leo & Tom Young !!

September 4, 2007 12:46 PM

BTW .. MTU setting of 1492 also works on my D-Link DI-524 router !

Joan M. Cowley
October 26, 2007 10:10 AM

I used my hotmail password yesterday prior to noon. When I needed to get bac k to read my email, it would not accept my password. I had not changed it. Consequently I signed up for the new version email [Email Address Removed] and now that wont accept my password. What gives? This is the second weekend that this happening.

October 30, 2007 11:32 AM

Thank you Leo! My roomate and i have been trying to figure out the router for almost two weeks! the MTU worked for us too! Thanks for your help :) We'll check in on your site for any future PC needs ...

November 25, 2007 2:44 PM

hello I'm frist time user new to all this so hoping some out there can help me.I bought A new linksys broadband told me I could use this as a spliter to get on line and play xbox live 360 at the same time follow all cd insteructions and did everything my desktop ask me to do It comes up as my desktop telling me I have limted or nonconectivity. can some plese hepl me out,I would appreciate for any hints or hepl

December 9, 2008 12:59 PM

when i try to get onto bebo it says sorry, you cannot use this site! is there any reason why?

January 3, 2009 7:17 AM

I cant get into my hotmail account and some other web sights.I can access it from my laptop just fine but not my desktop why is this.Iv read all the other comments.

April 8, 2009 2:29 AM

I got this error from changeing to different isp
before that it was okay, but once i changed to another isp, i cant login

November 28, 2009 9:00 AM

I had this problem ever since moving from Virgin to Orange broadband. I have a D-Link DI-524 router and all computers that had XP could not access hotmail, but the laptop that had vista for some reason. I called Orange who had no clue what they were doing after they had done their usually routine of checks. T
At one point i was changing the windows clock to 5mins forward...?!?! Anyway, i came across this site and within 5mins problem was solved! I changed the MTU to 1200, restarted and could then access hotmail and the orange email. Btw i had to change the MTU on all of the computers that had XP.

May 1, 2011 5:56 PM

I had this problem whenever I was in my Ubuntu system, but not while in Windows. I couldn't access yahoo mail, hotmail and moodle. Youtube always stopped working if I logged in.
Adjusting the MTU setting solved all those problems, thank you very much.

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to to ask your question.