Helping people with computers... one answer at a time.

My IE address bar will not respond when you type in, say, "www.yahoo.com". you have to put http:// in front of the address. This just started happening tonight, 4/15/2006. What's up?

To put it bluntly ... Microsoft messed up.

I've gotten a flurry of reports of this behavior ... all starting on 4/15. Right after Windows automated update.

Microsoft acknowledges that there's an issue, and I believe that this is the issue causing your behaviour. It affects more than just IE - but also places some of the blame on some third party software.

Note: this article is out of date, and no longer applies. It's preserved for historical purposes only.

First, here's the Knowledgebase article that applies: Problems in Windows Explorer or the Windows shell after you install security update MS06-015.

I first learned of the problem as a Microsoft Office issue, where people are unable to open files in "My Documents". The Knowledgebase article actually includes several symptoms:

  • Unable to access special folders like "My Documents" or "My Pictures".

  • Microsoft Office applications may stop responding when you attempt to save or open Office files in the "My Documents" folder.

  • Office files in the "My Documents" folder are not able to open in Microsoft Office.

  • Opening a file through an application's File / Open menu causes the program to stop responding .

  • Typing an address into Internet Explorer's address bar has no effect.

  • Right-clicking on a file and selecting Send To has no effect.

  • Clicking on the plus (+) sign beside a folder in Windows Explorer has no effect.

  • Some third-party applications stop responding when opening or saving data in the "My Documents" folder.

Not everyone is seeing the problem. One of two additional factors apparently need to be present: Hewlett-Packard's "Share-to-Web" software, or Sunbelt Kerio Personal Firewall. While I do run HP software and use an HP printer, I'm not seeing an issue. However apparently many users are seeing it.

The Knowledgebase article does include a workaround - but it involves a registry addition. A fairly obscure registry setting at that.

NOTE: the following is provided without warrantee, and should be used at your own risk. As always, be wary of anything you download from the internet, even from me. Backup first, backup often.

That disclaimer out of the way, I'd also recommend that if you can, just live with the behavior. I'd guess that the next round of updates will fix it.

But, if you need the fix now, here is a ".reg" file that will install that registry setting for you: 918165.reg. Right click it, save it to disk. Then, in windows explorer, double click on the downloaded file allow it to execute, and the setting as described in the Microsoft article will be added to your registry. (Why Microsoft doesn't provide this is beyond me.)

The registry setting apparently only deals with the HP software issue. Folks using Kerio firewall are instructed in the Knowledgebase article to make a configuration change to it.

For those who'd care, the contents of the .reg file is:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Cached]
"{A4DF5659-0801-4A60-9607-1C48695EFDA9} {000214E6-0000-0000-C000-000000000046} 0x401"=dword:00000001

(There may be some line wrapping, but it's 4 lines, total.)

I know a lot of people will start to worry about automatic updates breaking their system in the future. Obviously it can happen. However my opinion is that the benefit still far outweighs the risk. I'm leaving it on.

Article C2625 - April 18, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

15 Comments
Tom
April 21, 2006 1:00 PM

Hi,
I have the same problem with IE now requiring "http:" in the address bar? I go around this by only typing lets say "yahoo" and then by holding the control key and hitting enter, by doing this it will add the "http://www." in the begening and the ".com" at the end to what ever you type in. I'll keep doing this till microsoft has an update to fix this...Actually i really got used to this...saves so much time..... no more www. and the .com....wohoo00... good luck

TJ
April 22, 2006 12:53 PM

You are awesome!!
I was having this problem and downloaded the registry editor provided and all is well. I have bookmarked your site for future reference.

THANK YOU VERY MUCH!!!
=) TJ

Chris Inverso
April 22, 2006 10:42 PM

Leo,

Thank you. Your registry entry fixed my address bar problem. Muchas Gracias!

Mary
April 23, 2006 5:44 PM

It was driving me crazy that I couldn't go to a website by typing the address onto the address bar! I downloaded the registry 'thingee' and it works great, now!!! Thank you so much!

Sterling
April 24, 2006 1:16 PM

Great article. This bug also affected Visual Studio 2003. Thankfully, applying the fix resolved both the IE problem and the Visual Studio problem.

More info on the Visual Studio bug

Sterling
April 24, 2006 1:17 PM

More info on the Visual Studio bug at:

http://sterlingporter.net/blog/?p=11

Oz
April 24, 2006 10:43 PM

You da man. Thank you.

Art V
April 25, 2006 6:18 AM

Checked my Add/Remove programs and found the HP software Share-to-web. Removed it using the ADD/Remove, rebooted the PC and now the IE Address line works as previous. PS-Loved the Control/Enter keystroke to complete the IE Address - might just continue to use it!! Thanks..

ann
April 26, 2006 6:12 AM

Apart from being to access the address bar I am not able to use my scanner. it will not scan photos into my C drive yet it will scan to print. Could this microsoft download have affected this and if I download registry could this solve the problem? my scanner works on someone else's computer. thank you

bananamanUK
April 26, 2006 9:48 AM

This man is KING! I seriously thought I was losing it, everytime I tried addding pictures or attachments in Office/Outlook the software froze. I done loads of web searches and found nothing, so started uninstalling and reinstalling everything but it still didn't work. I seriously thought I'd have to reinstall XP. Then, when all was nearly lost I realised another problem was the "http://" searched on that, found this and am happy again. Enjoy a tall latte on me!

kaylee
April 30, 2006 9:27 AM

how do you get stuff off your address bar when to go to see what differnet address's are?? I went to history and delete stuff and still they didn't go away

manojkumar
April 30, 2006 12:57 PM

Not good at all poorly organised

Anand
June 7, 2006 3:21 AM

well, the .reg execution doesnt yet resolve the problem on my system. Infact the problem arose after i changed my router from LinkSYS to Netgear. Also the browser doesnt respond imediately....i need to click on GO 3-4 times. The same was not there while using linksys router. Any advice!

Juan Miranda
June 21, 2006 4:13 PM

You are the man thanks a lot. It was driving crazy I thought I had a virus or worm, but it wasn't . shame on Microsoft.

Thanks a lot again

Gary
December 2, 2007 12:52 PM

I now have to enter www. in front of all URL's, and must enter http:// if the URL doesn't have a www. such as "http://name.phanare.com. I have tried your fix and also reinstalled IE7. I can find no evidence of HP Software to Web on my computer. I have installed the suggested MS fix and also your .reg fix. I do not have any other known problems except this URL thing. Any other ideas?

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.