Helping people with computers... one answer at a time.

Internet Explorer can automatically dial a connection if you use dial-up to connect to the internet. Having it automatically dial a connection can get in the way, though. Here's how to turn that off.

I have a laptop with Win2k Pro installed and totally patched re critical updates and AV software and firewall. At home I have a 56k dial-up connection which I use very often. Today, for the first time ever, I installed a Sandisk combo 128mb Compact Flash card and Wi-Fi card - 802.11b grade. I went to a local free cybercafe and ran through the process of setting up the Wi-Fi and connecting. All went well.

The last instruction from Sandisk was open IE and start to browse. Well, every time I opened IE, it wanted to connect via the 56k dial-up connection. The only way I could get the Wi-Fi to work was to delete the 56k connection from the settings area on the laptop. As soon as I deleted that connection, the Wi-Fi worked very well. So the basic question is: Is there an inherent conflict here?

Not a conflict as much as a configuration issue.

Internet Explorer is trying to be helpful. And, while that works in many cases, being helpful can also get in the way.

But it's easy to fix.

In an effort to make dialing up easier, Internet Explorer (and Outlook Express, by the way) will automatically do it for you if it sees there's no dial-up connection when it starts. Fire up Internet Explorer, and "all the right things" just happen, and you're connected and surfing in a single step.

That made a lot sense when dial-up was the most common mechanism to connect to the internet. These days with always-on and other types of connections, it can get in the way.

As you're experiencing.

To turn it off, fire up Internet Explorer (cancelling any attempts to dial on the way):

  • Click on the Tools menu

  • Click on the Internet Options menu item

  • Click on the Connections tab

You should now see something very similar to this:

Internet Explorer Connections Configuration

In the center of that dialog box you'll see the option that allows you to control when IE (and Outlook Express) should dial a connection for you.

Personally, I recommend Never dial a connection. This puts you in control of when the dial-up connection is to be made.

If you've been relying on IE or OE to dial the phone for you, to dial the phone now you can right click on your dialup connection in the Network Connections section of Control Panel:

Dial-up connection right click

And click on the Connect menu item. To disconnect, that right click on that again, and you'll see that there is a Disconnect item.

If you do this often, you can create a shortcut to that network connection on your desktop or start menu simply by dragging and dropping it on to either. Right click on that shortcut, and you'll see the Connect item.

Article C2707 - June 29, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

14 Comments
Ivan Tadej
July 4, 2006 9:01 AM

Well, and as an addition to setting the system like Leo described (for that particular dial-up connection/account), for security reasons, I also highly recommend everyone to set the computer's dial-up adapter to "Show terminal window" before dialing (as mentioned, beside seleting/checking: "Never dial a connection"); for information on how to do this (and much more), please check out the "Security and dial-up" page at CastleCops Wiki: http://wiki.castlecops.com/Security_and_dial-up (btw. I've created it) or the "config.html" page on my very own home-site: http://users.volja.net/tayiper/other/config.html ...


--

best regards,
Ivan Tadej, Slovenija, EU
http://www.tadej-ivan.be/

Roger
August 14, 2006 7:37 AM

Turns out that the "Choose a network connection" pop-up can appear when the browser tries to access a non-existing domain. Configuring Internet Explorer to "Never dial a connection" will prevent this pop-up, also when browsing the Internet with Mozilla Firefox:

http://rogerkarlsson.com/blogs/winhelp/disable-network-connection-popup/

diane
September 4, 2006 8:50 PM

Hi, something wierd is going on, or I just don't understand whats happening or why..I have had broadband for 2 years now..I went to Network connections the other day & saw under dial-up, I had 2..Dial up Connection & dial up Connection 2.Both had disconnected firewall..& said SoftK56data fax on both..Under Lan or High Speed Internet it says 1394 Connection & firewall connected & 1394 Net adapter..Next to that was another that said:Local Area Connection network cable unplugged,Broadcom440x 1/100 intergrated controller.It had a red X through it..Then under that had another that said: Wireless Network Connection, Connected firewalled 802.11g Network adapter..I then took 2 months reading & searching for answers as to why & when I turn on the laptop it says dial up & dial up2 place name & password.I placed Never dial a connection, but it didn't work..Keeps comming back. Called Aol & Gateway,They said to do a full system restore that I have a virus & worms..I saw spywareBlaster icon on my laptop, so I clicked it & all these crazy things were there..On Internet explorer it had lots of Dialers...And on the restricted sites it had porn & alot of sites from CoolwebSearch..It named them all..Now, I know this is only a machine & it only knows what we put in..But I don't know how they got there(although, I do know someone placed them on there when searching)And the ones on Internet Explorer are all in active X..I then went to use my desktop the other day & wasn't able to use my printer/scanner..It said it was disconnected..So I looked on faxes & printers..The one downstairs works the other is off..I saw all this stuff about the set up Wizard & it seems like its already been set up,,I saw a few 1800 #'s & it sounded like a fax sound, but gateway said no, it was connecting to another computer..I have on the desktop Local disc C & Recovery D, DVD-RW Drive E Then have F also..I would love to know how you hook all this up & why i saw some screen that said comp 1, comp 2, comp 3 & comp 4..Its both on the desktop & laptop..I value your opinion & Gateway told me someone must of placed a cd in & copied all the stuff from one comp to the other..The laptop is 6 months old, the desktop 2 years old..I saw soooo many files & folders & some they used Stuffit & they are zipped & I can't open them..Last night I shut down the desktop & a screen came up from Microsoft & said something like- The computer is locked please put in your name & password..All I know is that its not good to have all that porn & dialers on there & I don't know how to fix it.Also,how does one disable a printer & why? And what does the fax machine have to do with all this..Can you help me, i'm desperate Please Help! I also saw all sorts of folders labled uninstall...And programs used like windows media & realone & i clean..I can't use that because someone already set it for running when comp is off for cache & cookies..Its a shame this happened but i need to understand how this was all done..I also saw agere systems 'ac97modem? All i know is they went to alot of trouble to use different languages & zipped folders & all sorts of stuff..That just appeared on my laptop recently..I was concerned when i saw all the dialers because they told me never to plug a phoneline in or i will get a large phone bill.So, then how did they connect to other computers? Was it free through the internet? Please try to help me understand what is happening...Thank You sooooo Much for any help you can give me..

Sincerely,
Diane, a concerned Mom

marie
October 6, 2006 3:52 AM

when on my computer for a certain amount of time a dialing tone comes on and the in goes engaged and then repeats it self over and over. Even if i am watching a flim this happens, is there a way of stopping this?

Elsa Jamison
December 20, 2006 12:17 PM

I have both of my computers attached my HPNA adapters to the modem. Both have been set to NEVER dial a connection. STILL AOL keeps trying to dial a connection. I turned off the Microsoft Firewall in the desktop, but AOL is blocking this computer because it also has a WiFi.

kim
February 16, 2007 1:02 PM

its strange i have AOL dial up and when i start up my computer its loads for about a min AOL kicks in and tries to connect all by its self i cancel it and i dials again what's happening how can i fix it i did a virus scan just to see if it was that and no virus found please help what can i do this is getting really annoying cant even play a game offline. thanks so much

rhonda johnson
May 25, 2007 6:04 PM

dear leo:
can u tell me where to find the phone number(s) i need to get my comp. to connect to mozilla firefox(foxfire?).
i can't seem to find one at google!
please help asap!
thanx a bunch,
r. m. johnson
p.s. love this site, very helpful!

Mason
December 24, 2007 9:54 AM

When i turn my computer on it loads a lot of differnt stuff like MSN, Iturnes, I.M. and a lot more. How do i change it so that stuff doesnt load up right away?

Margaret Gray
January 11, 2008 4:39 AM

Leo, what do you do if you've done everything you've suggested, and that pesky dial up box keeps appearing, and you keep on clicking 'Don't dial a connection'? What's worrying is that it doesn't happen when I'm surfing the net in a vague way. It always happens when I'm paying for something via paypal, or through a company's check out. Result? Major panic from me, and much clicking of the pesky box to get rid of it, then reclicking the 'Never dial up a connection,' only for the same thing to happen over and over again!
Margaret

jackie nutwell
August 5, 2008 11:35 AM

Why does aol keep interfering and loads up when I am talking with a tech regarding my broadband service. It happened 50 or more times in 53 minutes. What makes this happen and how can I disable it?

Christi
October 5, 2008 3:34 PM

My father gave me a Dell with Windows XP home Edition 2002 on it and when i went to download Yahoo Messenger it will not allow me to log on and tells me to look on internet connections and i have placed it on "no network detections" but at the bottom it says Dial-Up and i am using a cable modem and will not give me a option to change it...Need to know where i go and how i go about fixing it to connect to messenger..thank you

Kathy
April 1, 2009 9:07 AM

We have internet through our cable provider, yet when I click on a pic on my desktop and ask to email it, my computer tries to dial up. I have went to tools, internet opt, connection and have marked never dial up, yet it does. Help

polly
October 12, 2009 12:34 AM

Hi Leo

Me too: "never dial a connection" is checked, but the drop-down menu still appears on boot-up - at least,so far, it doesn't try to dial up!! I have a LAN/Hi-speed connection.

Scott
January 27, 2010 8:14 PM

I found the solution to this problem, at least for my computer. Go to Outlook Express, click on Tools on the menubar, click on Accounts...

Click on the Mail tab at the top, select the mail account you are using, click Properties.

Now select the Connection tab at the top and deselect "Always connect to this account using..."

Now it will use whatever your default connection to the internet is.

Best of luck,
Scott

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.