Helping people with computers... one answer at a time.

Tabs are mysteriously appearing in a Firefox browser. This could be a miss-set homepage, or perhaps pop-ups.

I'm using the latest Mozilla Firefox on Windows XP Home Edition. Continually, although not always, the following link appears out of nowhere in the tab section when I open the browser (he gives me the URL). I went to this site once and never opened it again. I don't need this site, but it's there as a tab. It has something to do with University of Massachusetts.

In this excerpt from "Answercast #14, I look at several reasons why a second tab may be popping up in your browser window and how to get rid of it.

Browser tab appearing

There are two possible things that come to mind on this particular instance. I believe it's possible that you have more than one page set as your homepage.

Most people don't realize this, but most of the tabbed browsers these days actually allow you to specify multiple pages, separated by semi-colons, as the homepage. Those are the pages that come up automatically when you open your browser or possibly when you click on the Home button.

Set your browser's homepage

The thing to do is go into your browser's options and verify that the homepage or start page is set to the URL that you expect.

I actually have an article on the site about making sure you're setting the homepage to the page you want it to be. So I would direct you there.

Website pop-ups

The other thing that comes to mind is: if this is happening when you visit some other site (this second tab appears), the other site you are visiting may have some kind of advertising network that's throwing a pop-up into a tab.

I've seen this on some sites that I visit regularly. They throw an advertisement into a pop-up window that Firefox's (and a couple of other browser's) pop-up blockers can't actually block.

  • Sometimes, it will show up as an additional window
  • Sometimes, it will show up as an additional tab.

So I would pay attention to exactly when this page is showing up. If it's showing immediately on opening your browser, I would make sure that the homepage setting you have configured is what you think it is.

Article C5281 - May 3, 2012 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

2 Comments
David
May 4, 2012 2:01 PM

You probably already know this, but Firefox has an option to save all of your tabs when you exit. Instead of giving you a current page, it will take you to the same page(s) you were at when you exited.

Billy Bob
May 4, 2012 6:01 PM

Mutiple homepages separated by semi-colons? I just tried that and it doesn't work. I believe they should be separated by the "|" (shift-backslash). I think it's called a pipe.

You may be right - it's not a feature I use and I believe different browsers that offer the feature use different separation characters.
Leo
05-May-2012

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.