Helping people with computers... one answer at a time.

Applications, and Windows itself, need to know the proper program to use when sending mail - we'll look at where that is, and how to [re]set it.

Laptop running XP and Office 2003. For no apparent reason, when in Word and click FILE/SEND TO I get an error message saying I need to connect to MS Exchange Server, Until 10 days ago, this command seamlessly opened up a window in Thunderbird (the only email client on the machine)and attached the file. Any ideas on what happened?

No real ideas on what happened, but I do have some ideas on what needs fixing.

To begin with, I'm guessing that you do, indeed, have at least one more email client than just Thunderbird on your machine.

Since you mention that you have Office, then it's likely that you also have Outlook, the email program that is part of Office. Since you're getting asked about Exchange, that tends to support that assumption, since Outlook is one of only a handful of email programs that even know about Exchange.

"Since you mention that you have Office, then it's likely that you also have Outlook ..."

Nope, the problem here is that somehow your default email program got reset. Often this might be due to an update to Office - perhaps downloading the latest patches, or performing a repair install.

Or something else unrelated. It happens.

And if this is the problem, it's fairly easy to fix.

In Windows XP, hit the Start button and then click on Set Program Access and Defaults:

Set Program Access and Defaults on Start Menu

(If not on your start menu, you'll also find it in Control Panel, Add/Remove Programs, in the left hand column.)

Typically you'll use a "Custom" configuration, and then select your default e-mail program:

Set Default Mail Program dialog

The dialog should include your currently installed email programs. My desktop, for example, includes the options shown above plus both Microsoft Office Outlook and Mozilla Thunderbird.

Windows Vista has a similar, but more clearly named "Default Programs" interface:

Set Default Program dialog in Vista

Once the program has been re-associated with its default functions, it should start to behave as you expect. (You may need to restart all the programs involved such as Word and Thunderbird. In the worst case you might need to reboot to have the changes take effect, but I'd hope not.)

Article C3816 - July 22, 2009 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

2 Comments
Mark Jacobs
July 23, 2009 1:34 AM

Microsoft is infamous for changing your defaults after updates. Every once in a while ma browser default gets reset to iexplore, MediaPlayer gets put on my quick launch menu. It's there feeble attempt to get you to use their programs. Microsoft is more afraid of free software than of MacOS and other commercial software. Steve Balmer once commented that it's better for M$ if people pirate WIndows than use Linux. It's like a drug pusher starting out offering free drugs.

ArtD
July 28, 2009 9:46 AM

But how can I set gmail as my email client?

This article includes an approach: How do I change the "mailto:" or default mail program?
Leo
29-Jul-2009

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.