Helping people with computers... one answer at a time.

Email is timestamped by the program that creates it. Normally Window's time, date and time zone are used. Web services, however, need a little more.

How do I fix the time on my email? The time on my computer is correct, but when I send emails, the time's an hour ahead! What's wrong?

You nailed the one thing that many people forget: the time on their computers.

However, depending on your mail service, you may need to make sure something else is set correctly as well. The "one hour off" is actually a clue that your time zone is set incorrectly.

And, of course, where that gets adjusted depends on what program or service you're using.

Let's look at a couple of common situations...

First, as you point out, your computers time and date must be correct. That's easy to adjust: just double click on the clock in your task bar and you'll get the Date and Time Properties dialog where you can adjust the date and the time:

Date and Time dialog

Notice the "Time Zone" tab? Click on that and make sure your time zone is correctly selected:

Time Zone Properties

Finally, go ahead and click on the tab labeled Internet Time:

Internet Time Server Settings

Most of the time the default settings are correct, but make sure that Automatically synchronize... is checked to allow Windows to synchronize your clock with an appropriate time server. If your clock "drifts", as some do, this will help keep it accurate.

The preceding steps should correct any time errors in an email client you run on your machine. Programs like Outlook, Outlook Express, Thunderbird, and others all use Windows to determine the time, date, and time zone.

If you're using a web service such as Hotmail, though, you're not quite done.

"Programs like Outlook, Outlook Express, Thunderbird and so on all use Windows to determine the time, date and time zone."

Hotmail, GMail, Yahoo!, and other web-based services usually ask you for your time zone when you sign up. If you ignore that, get it wrong, or move to a different time zone, you'll need to change the setting in order for the time stamps of your emails to be correct.

For example, once you've logged into Hotmail, click on the Options button in the upper right:

Hotmail Options Button

Then click on Personal on the left, for Personal Options, and then click on My Profile, which is described: "Change your name, location, and other personal information."

As I write this, Microsoft is transitioning to "Windows Live" for account management, so the resulting page will be a Windows Live branded page:

Windows Live Header

If you scroll down that page, you'll find a setting beneath your location where you can specify your time zone:

Windows Live time zone setting

Press Save, and it's updated.

Services other than Hotmail have similar settings in profile, user account, or personal information settings. Regardless of which service you use, the time zone must be set properly for your email to be timestamped correctly.

Article C2871 - December 14, 2006 « »

Share this article with your friends:

Share this article on Facebook Tweet this article Email a link to this article
Leo Leo A. Notenboom has been playing with computers since he was required to take a programming class in 1976. An 18 year career as a programmer at Microsoft soon followed. After "retiring" in 2001, Leo started Ask Leo! in 2003 as a place for answers to common computer and technical questions. More about Leo.

Not what you needed?

139 Comments
Cliff
December 22, 2006 2:42 AM

Several years ago, I was using my Web host for eMail. Since I'm in Oregon and he was in Texas, my eMail time was forever off by two hours. He said there was no fix. But what did he know? he used a Mac, right?
Going to Yay-hoo and then to GMail solved the problem for me, post haste.

irene
February 20, 2007 4:49 PM

I think i must have a bug, when i try to update it says an error occurred and date does not match. When i went into date time the region was set to Canada
but i live in Sydney Australia. I've corrected that but it still refuses to synchronise? I am a full day out!! regards Irene

Carol
March 3, 2007 7:11 AM

When trying to synchronize my internet time I get this message:

An error occurred while synchronizing with time.windows.com

Next synchronization 3/10/27 at 8:06AM

How do I get it to synchronize?

Karen
March 13, 2007 12:06 PM

I am having the time-stamp problem and my time is set correctly in my computer. I have GMail. We just went to DayLight Savings time and I am wondering if that is the issue since we did that 3 weeks earlier than in the past and the system doesn't seem to get it.

leanne
March 14, 2007 6:01 PM

the clock on the computer is correct, but emails sent are the wrong day and wrong time.

bernard
March 31, 2007 3:52 AM

i'm having a problem trying to synchronize my time with:

time.nist.gov
time.windows.com

i'd always get this error message:

"An error occured while Windows was synchronizing with time.windows.com."

my internet connection is on a modem and running at 31.2kbps

Leo Notenboom
March 31, 2007 8:49 PM

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Most often it's because your firewall is blocking the ports needed for time
syncronization.

Leo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (MingW32)

iD8DBQFGDyuBCMEe9B/8oqERAsiBAJ9xR0AjQxIZfGgM1lFQOV8sGtD99gCcC80S
pjjKQ+JpQDGZaNe3tM726PA=
=5KHm
-----END PGP SIGNATURE-----

eric
April 13, 2007 9:22 AM

I don't have Internet option on tab.

Trisha Conrad
April 18, 2007 10:16 AM

I had the error message too when synchroizing mine, HOWEVER.... LOOK at the screen on this page where it tells you where to synch to.. THE ADDRESS AUTOMATICALLY IN WINDOWS is WRONG. the correct address is the above one ie: time-a.nist.gov is correct where mine didnt have the -a. in it. CHECK THAT, mine synchrozied after that.

Nicholas Olah
April 19, 2007 7:13 PM

Thank you for explaining the time zone - check box to automatically adjust to time zonne changes. Last night I did on line diagnostics with two technicians and neither knew and just had me run around in circles.

DUBRA wATTS
May 1, 2007 12:27 AM

the clock on the computer is correct, but emails sent are the wrong day and wrong time.

Tim
June 14, 2007 11:52 AM

Using Thunderbird, the Time Zone and Computer's Time is CORRECT. All emails sent show up 1-hour ahead when recieved by other people, and emails recieved on this computer from other people are 1-hour behind.
Example:
I send e-mail at 1:00pm to someguy@site.com.
He gets it, and it says "2:00pm".
When he sends an email to me, say at 1:30, it shows up at 12:30pm in Thunderbird.
All other email from someguy to other people are right, and all other emails he gets are right...

Maureen
September 10, 2007 4:01 PM

Thank you! Problem solved! Comment for Mac users: I couldn't get the Registered Information option to appear up on the Classic Version of Windows Live (which is all Safari can handle right now), so I had to switch to Firefox and use the Full Version to make the change.

J.T.
September 28, 2007 9:52 AM

why do all the yahoo e-mails always have time stamps of XX:09?

Brad
September 30, 2007 6:39 PM

My e-mails on my home PC seem to be being received time-stamped an hour earlier that they really are (i.i. they say received at 3:20 and sent at 4:20). And somehow my Outlook changed the times on every event in my calendar (making them an hour earlier than they really are). The clock in the lower right shows the correct time.

I have tried installing the following to no avail:
Outlook Fix
http://support.microsoft.com/kb/931667/en-us

Windows Fix
http://support.microsoft.com/kb/933360

Do you know how to fix this? Thanks!

Rachel
October 2, 2007 1:19 AM

Thank you, who would of thought time on hotmail came under personal information???

sandi
November 2, 2007 5:47 AM

thank you!!! that was driving me crazy and i just couldnt figure out how to fix it. of course now i feel stupid b/c it was so easy.

Abby
November 9, 2007 3:29 PM

Totally awsome, helped me in 5 seconds, was a pain in the ass before, because i didn't know where to find the option. Thanks!!

Rick
November 25, 2007 2:41 AM

Thanks Leo!!!

Kelly
January 12, 2008 7:25 AM

thanks for the info..but I've already done all that and it's been like that..but my emails are always 2 hours off...
any other advice..my email is yahoo and good luck getting in touch with them..

Jean
February 13, 2008 9:21 AM

Thank you for pointing me in the right direction - I just want to add one point.

Problem
I am at GMT-7 and my hotmail emails were at GMT-2.
My computer time is correct.
My computer time zone is correct.
My time zone on hotmail is correct.

So, everything looks OK - what to do??

Who knows what internal glitch in conversion caused this problem, LOL!! So I fixed it as follows:

Change my hotmail time zone to something incorrect and saved it.
Then changed it to correct value and saved it.
I also added a work time zone with the same value - don't know if this was required but thought it wouldn't hurt.

Hope that this helps someone else.

Cheers
Jean

Dawn
March 14, 2008 8:03 AM

My Outlook Express e-mails show that they are being received 2 hours and 35 minutes later than they actually are, but they show that they are being sent at the actual time.

My computer time is correct.
My computer time zone is correct.

Any suggestions?!?!

L. Darville Jr.
March 20, 2008 6:42 AM

EXCELLENT ARTICLE. FIXED MY PROBLEM! GENIUS I TELL YA!

lisa
April 8, 2008 2:47 PM

I change the time on my computer and then it changes back to an hour earlier, by its self. How can this be corrected?

Rick
April 23, 2008 2:09 PM

I still have this problem.
I checked my time, I checked the Time Zone, I auto sync with time-a.nist.gov, and I still have the problem. I also have the same problem on the other computer in the house.

The e-mail I get from work is 1 hour ahead. When I log into web mail for work it shows an hour ahead. By=ut when someone in the office logs into my web-mail they see the time received correctly. Any other suggestions?

mehran
May 25, 2008 7:20 PM

to change the time zone you have to click on account summery and then personal info and then change the time zone

Imran
June 21, 2008 4:03 AM

Thanks, I couldn't figure out what was wrong because my PC time was correct.
I had Hotmail time set on 'Universal GMT' instead of 'London GMT', so i ended up getting emails that said 1:00 in the morning and I didn't know why!

RBCneon
July 31, 2008 9:35 AM

Please mention that for Outlook users and possibly other mail programs, the Daylight Savings Option must be checked off. If not checked then time will be shifted 1 hour even though time shows correctly on desktop.

Steve
August 6, 2008 8:29 AM

Finally fixed this annoying little problem. Just changing my hotmail time zone worked for me. Thanks a lot.

Ridgerunner
August 12, 2008 5:09 PM

This fixed the problem for me. I have Qwest Live Mail which is actually supplied by Microsoft. When I signed up for it they never mentioned setting this parameter and if you don't it apparently defaults to Universal (Zulu to us pilots) time, formerly known as Greenwich time. Just reset the parameters mentioned in the article to your time zone and it should fix the problem. Thanks again!

Roberta
August 20, 2008 4:10 AM

Thank you so much for the Hotmail Options suggestion. I had been putting up with the incorrect time since 2002 !!!! It was the time zone that was incorrect.

IanG
August 20, 2008 1:47 PM

So why can't Outlook or any other email app actually show the timezone name as well?

Outlook 2007 allows you to give a nickname for your local timezone, and for an additional timezone, s why not use this?

Paul
September 9, 2008 8:52 AM

My hotmail time stamps are 4 hours ahead. I have never left the US Eastern Time zone. My PC's clock is setup correctly and so are the settings in hotmail but the time is still 4 hours off. Something is awry...any help?

Diep
September 10, 2008 9:45 PM

I set everything correctly as above instruction and the time on my gmail is correct but yahoo mail time stamp is not correct. Don't know why!

Tom Tawoda
September 11, 2008 8:15 AM

How do I set my Yahoo mail acct to tell ME what TIME I receive my mail. PLEASE help I need to know what time people send me mail.

Zandra Green
September 11, 2008 11:33 PM

I've now sorted my problem thanks to this site, cheers.

Angela Homer
September 21, 2008 12:00 PM

Thank you! It's important my yahoo email sent shows the correct time for assignment ontime completion. As my computer clock/timezone was correct,I was tearing my hair to figue why my AM sent time showed up as PM.Your article showed me how the change the yahoo options where I had a timezone selected which changed my AM to PM on mail sent. I don't know it got there! Thank you Thank you! Clear instructions for once and my "time sent" is now correct.! Well done!

Venessa
September 25, 2008 6:07 PM

It worked!!! The time was wrong on my account and it was driving me crazy. I was constantly trying to calculate the difference. Thanks for the help!

abbas
October 8, 2008 10:30 AM

thanks.I solve my problem

Fred
October 29, 2008 4:16 PM

Absolutely awesome advice. After 9 freaking years I finally figured out how get the correct time on emails in my Hotmail account.

Thanks.

Njwise
November 4, 2008 1:16 AM

Thank You for your help this website ist great. It seems like it worked. I have been trying to update my hotmail time zone for a while now. ]

Once again thank You.

Ali
November 5, 2008 5:39 PM

Thank you very much I followed every step it worked I really appreciate this.

terry ann hays
November 7, 2008 11:38 AM

all my e-mail addresses have correct time when mail arrives---yahoo is not---about 6 hours off-tried to reset to no availe please help
thank you for your time
terry ann hays

Val
November 9, 2008 10:01 AM

Same here, after 100 years dealing with the wrong time, it now works. Asking MSN to help is like talking to the wall.

Alma
November 12, 2008 8:56 PM

Wow! I don't have to go crazy about the time now. I can't believe it was this easy. Thank you so much, you've saved me so much time!!

Rose Marie
November 15, 2008 4:35 PM

Thank you so much. It worked!!

Chrisann
November 23, 2008 5:31 AM

I read your article about my time on my computer was one thing, but my incoming time on my e-mail was 5 hours off. I was able to change my time so it reads the same. This has been bothering us for a long time. Thank you so much for your answer.

marianne irving
November 24, 2008 9:34 AM

The instructions above did not coincide with the options on my hotmail screen. My e-mail is off by 7 hours. Obviously it is a time zone setting in my email. Can you help?

Gail Edwards
November 24, 2008 3:14 PM

When I double click on the time The clock comes up but not Internet Time. Only date and time and time zone. Is ther another way to fix this?

radwa
November 26, 2008 8:26 PM

Hi Leo,
I read the article but still I need your help regarding setting my Yahoo time properly, because it drives me crazy and it affects my work because sending important documents is always noted with the wrong timing.
I am a yahoo user. I followed your advices on all but something is wrong still. I am located in Cairo, so my timing should be GMT+2. As I tested sending an email from the Classical yahoo interface, the timing shows as only GTM, which is to hours earlier, although my computer is properly time set and I made sure to edit this in my email account info as well.
Funnier still is that when I switched to the new yahoo interface (looking like the outlook), the timing shown in that of the US, which is entirely a day earlier than me with a difference of 7 hours back!! this is horrible! I tried it all, and when I send important messages needing immediate attention, people get confused as to when I sent them.
Can you please help?
thanks
Radwa

Carol
December 2, 2008 9:17 PM

For the last month or so the time on my Yahoo mail has been about 4 1/2 hours fast. I tried the things you suggested, to no avail. Any other ideas, please?

RA
December 3, 2008 9:10 PM

I used your procedures here for my yahoo account and it worked. This was really frustrating me and I am sure it was confusing to people sending and receiving emails. Thank you for caring

SANDRA
December 3, 2008 10:18 PM

I am on windows live and the results page did not look like your example. I still cannot find the option to change the time. My computer time settings are correct. I own a MAC and a PC. System time on both are correct. Please advise.

Ken Laninga
December 18, 2008 7:29 PM

I read the above tips but that does not work for me. I am in the Mountain Time Zone (Alberta, Canada) and have to use GMT-8 to show the correct time. You show GMT-8 as being for the PACIFIC time zone which is one hour behind us, being west of us. BUT SOME of my emails apparently show as being sent at 7PM whereas I sent them at 6PM which confuses me a lot! ;-(

Make sure your daylight savings time setting are correct. One hour off usually implies they're not.
- Leo
19-Dec-2008

Bob
December 21, 2008 6:52 AM

I read the comments above, but I seem to have a problem that is quite different than those listed.

We have AT&T Yahoo email service. The email times are reported correctly on our main account and all of our sub-accounts except for one sub-account. We live in the US central time zone. When an email is received by this particular sub-account on any of our computers, the mail preview screen lists the email time as two hours behind (PST). When we go to the actual email screen, the time is listed as six hours ahead. Mail sent by this sub-account also shows the incorrect time.

Why would only one sub-account be affected on our computers, when all other Yahoo email accounts on the same computers give the correct email times?

Bob
December 21, 2008 7:26 AM

Wa hoo! I just found the answer to my earlier question.

In the affected Yahoo sub-account, I went to the Member Center Home;
Sub Account;
Yahoo Member Center;
View/Edit Contact Info, marketing preferences, etc.;
Change personal information;
Edit Yahoo address/contact information.

The time zone can be changed at the bottom of this page.

Claudia Wallace
December 28, 2008 4:00 PM

THANK YOU I have been searching for the information to correct my email time stamp. ONLY YOU had the answer. Thank you!

JK
December 31, 2008 10:18 PM

I also encountered the time zone differences in my Hotmail account -- realized I had chosen a wrong time zone but could not easily find it. After reading your general descriptions for accessing time zone in Windows Live, I discovered the exact information needed for making the change in Windows Live. Do this. In your Hotmail account, choose Options/More options. You will be directed immediately to Windows Live. Now select Manage your Account, next View and Edit Your Personal Information, then Registered Information. In the Registered Information window, select Home Location and then Time Zone. You can now set the correct time zone.

Thanks, Leo, for your tips. You helped me correct a small but irritating problem with my e-mail. :-)

Janet
January 4, 2009 8:44 PM

Ditto on most comments. My PC's time and time zone is correct. There is no "option" option to change/correct the time. Other sites indicates there is nothing we can do to change the time in Yahoo. Anyone have a contact for yahoo for their comments. Thanks for the above info; at least I know it is not me.

Anonymous
January 6, 2009 7:21 AM

Thanks to Leo and Posted by: JK at December 31, 2008 10:18 PM. My long lasting time problem has been resolved.

Abu Jamal

Ellen
January 15, 2009 4:22 AM

I have a mac and my yahoo time stamp is wrong. These instructions don't work.

Christian Hume
January 15, 2009 4:15 PM

Thank you Claudia Wallace! Your post was most helpful...

Daryl Edwards
January 21, 2009 2:56 PM

This article is outdated. The new Windows Live style is a maze of option pages that do NOT seem to have a time zone setting buried anywhere in them.

The article is outdated, but you're wrong about there not being a time zone setting for Windows Live Hotmail. New article shows you exactly where: How do I correct my Windows Live Hotmail time zone?
- Leo
22-Jan-2009

HJB
January 26, 2009 8:18 AM

I have been trying to correct my time for about a year. Not until I found your site was I actually able to correct. It's nice to see the actual time on my e-mails. To Daryl follow the directions of JK on 12/31. Follow the exact steps and you'll be allset. Thanks Leo

Dolores
January 29, 2009 6:11 AM

Thank you Bob! It has made me absolutely nuts, trying to figure out why my time stamp was wrong on my email. Yay...it's all fixed now. YAHOO!

Diana D'Amico
February 10, 2009 7:59 AM

I have a Yahoo account and I changed it to the correct time zone to match my computer and still the time is incorrect. The box is checked to synchronize with the server time.windows.com and I updated as well. Still, the time is 5 hours ahead on my Yahoo account. Am I doing something wrong? Please help!!

Debbie
February 12, 2009 10:01 PM

How can I change my time on my email of my yahoo?

It is 5 hour off. If it was I hour ahead it would be okay but not 5 hours.

Could you help me?

Regards,

Debbie

Kathy
February 18, 2009 7:22 AM

Most annoying when you do not see the correct time the emails were sent... do they actually take that long to reach your INBOX?

Adm
March 3, 2009 3:18 PM

I am on Firefox 2.0.0.20 on a Mac OSX 10.3.9. I have a Yahoo address I use for business and the time stamp is off 5 hours. The Date and Time info and the time zone is set correctly on the Mac. The time zone setting in the Yahoo account had been the correct time zone. Even if I change the time zone to a wrong zone there is no change. What to do?

David R
March 3, 2009 7:05 PM

I am with Rogers Yahoo. I am also having the same problem with a email time 5 hours later than when I send it . I read the initial article and checked things out. Computer clock is set correctly, with auto update and time zone. I have reset my Rogers account for time zone also. Still have the same 5 hour time difference. However, on another account running on the same computer under the same overall account, the time is correct. Any ideas?

Karla
March 4, 2009 12:01 PM

For Yahoo email incorrect time stamp: To fix time zone go to Account Info. Then to Member Info. Under Member details it asks for your time zone. I will fix it immediately!!!

j
March 5, 2009 5:27 AM

Thank you Karla, sometime on March 4th, yahoo reset my internal time clock to US pacific time when I am on central. This article was really helpful and fixed the problem! now on to resending this morning's emails!

Clifford
March 8, 2009 8:23 AM

Time on PC "drifts" exactly 6 minutes. If I sync using MS, 6 minutes off. If I use the other time server, will fix the time.
What's going on? How come MS time server off by 6 minutes?
Thanks

Wendy
March 22, 2009 3:31 PM

My att email is fine, my computer time & time zone are fine, but my new q.com (qwest) email is 5 hours off.The tabs that you show aren't there to click(no options button, no personal button & no profile button or anything similar).How do I fix it?

Laurie
March 23, 2009 11:48 AM

Thank you for this posting. I have been going nuts trying to figure out how my pc time was off by exactly 3 hours every time I have to reset it. After a hard drive crash and replacement I had to reset everything and that was the little wonder I missed.

jemps
May 12, 2009 6:16 AM

my time stamp in my hotmail is still wrong. been a hotmail user since 1997 but i think ever since they moved it to windows live, the time stamp got messed up with. i've gone to the manage my account section and chose the right location (manila) but there were only these choices: manila in the USA, Mexico and plain manila. the profile recognizes that i'm from the philippines, but still my time stamp is wrong :o( hope you can help (bec. microsoft help isn't really helping! :o( ) thanks!

anirudh gupta
June 4, 2009 1:42 AM

correct your computer timing settings:
time zone
time update
current time

if still the problem is not alleivated then change the time zone settings in your mail account info.that would certainly solve your problem.

Paul
June 10, 2009 10:59 AM

Hello, I currently am running a 16 bit application on Windows XP. When I intially start the 16 bit program the time is displayed properly. When I login into the server the time on my application changes to 3 hours behind..exactly. Any thoughts....

Marty
June 12, 2009 2:29 PM

Thank you, this fixed a problem I've been having for years. This corrected the time stamps on my incoming and outgoing emails through hotmail's web access.

Sheryl
July 3, 2009 12:56 PM

My settings are all correct like stated above in he directions, however my email is still 1 hour behind. This is an AOL email address. Any help would be great.

cccc
July 21, 2009 8:43 AM

thank you so much. it works.
I live in Utah, i just need to choose it right one.

Selena
September 9, 2009 12:02 PM

Under options I did not have "Personal" on the left. My Profile was listed elsewhere, however change your name, location and other personal information was not listed. Is there anything else that can be done?

Gary
September 9, 2009 6:51 PM

for those of you running hotmail under windows live you need to scroll down on the home page and in the lower right corner choose account. Under your name choose registered info. Under home location select the correct time zone. Scroll down and save. You should now have the correct time zone for your emails.
Good luck.

Gary
September 9, 2009 6:56 PM

when I say home page I am refering to signing on to your hotmail account page (like you do when you check your email account). Scroll down and select account in the lower right corner.

dianne
September 24, 2009 9:23 AM

hey thanks - i also had this time problem on my received emails for years and sometimes, for work emails, it can be a real problem. thanks once again!!

David
September 27, 2009 8:16 AM

It is now fixed ! Had the wrong time zone, I guess this computer came from the west coast. I had set the time but not the zone, who'd a thought that would matter?
Thanks

Linda Marie
October 5, 2009 10:41 AM

Many thanks!! I couldn't figure this out!! My computer time was correct but not my incoming and outgoing emails! Thank you for these easy instructions! :)

Debbie
October 15, 2009 12:46 PM

Thanks so much. I could never figure out how to correct the time on my emails.

john hall
October 20, 2009 1:54 PM

I have the problem with the email time beihg always pacific time and I am in the eastern time.
I have tried all of the comment that I have found.
I have checked and double checked all the setting several time but the time remains the same. I use charter.net for my email. help me please.

Biola Toba
October 22, 2009 6:59 PM

I also had thid prolem for years!!! thanks Gary for the simple instructions that worked!!!

wahid
October 28, 2009 3:27 AM

it didn't work with me, the time on my computer is correct the problem i couldn't reach the place where i do have to change the hotmail site it self please help

Laurel
November 2, 2009 6:53 PM

I CANNOT thank you enough. This has bugged me about my e-mail for so long!!! I just could never figure out what was wrong since the clock on my computer was correct....I had my MSN e-mail account saved on universal time!!? Thanks a million!

C
November 24, 2009 10:03 AM

Thanks a lot. At last I can tell what time a mail came in and can verify the time I sent a mail out. I really appreciate.

Bob
December 8, 2009 4:21 PM

Thanks for your help. This was annoying me and your simple instructions made the correction so easy. Thanks again!

Dirav Patel
December 12, 2009 9:15 PM

It didn't work with me, the time on my computer is correct also changed the location and time zone in my Hotmail account but still showing me the UK time where i opened my Hotmail Account. Pls Help me.. I use Mac OSX 10.5.8

Mike D
December 14, 2009 9:46 AM

This was that! And thanks for making my work easy by posting all those screen captures! Thanks so much.

Nicole Zell
December 31, 2009 9:59 AM

I have hotmail. I went through all the instructions above. It didn't work. I also don't have a "Personal" or "Personal Options" tab to click. I do have the "Location", but there's no pull down menu to choose Eastern Time. Frustrating. Thanks anyway.

Vijay Gupta
January 4, 2010 5:58 PM

This is what I found for Hotmail, I am using Safari in Mac to access Hotmail.

Once logged in, on right where your name appears, click on Drop Down Button next to your name and select View Your Account.

Once in, click on link "Registered Information".

Ensure that the Time Zone is correctly set for "Home Location" as this is what by correcting I have been able to get the correct time stamp on the emails. Good Luck

Manoj
January 12, 2010 10:15 PM

Now it is working perfectly.

kathleen plesko
January 18, 2010 7:45 AM

I want to know if the time on a received e-mail is the time it landed on my computer or the time it is on the senders computer, please?

ronnie macneil
January 27, 2010 4:13 PM

my time is right on my computer but when i get an e-mail it is three hours before my time how do i fix it. 3hrs in difference between out west alberta. where i am in nova scotia

Leo
March 8, 2010 7:11 AM

Thanks, man. My name is Leo too and your post really helps me with Thunderbird. Cheers!

ellie
March 22, 2010 12:21 AM

HI...HOW CAN I HIDE OR CHANGE THE TIME, WHEN I SEND AN EMAIL?

sivaprasad
March 30, 2010 11:18 PM

Hi i done all the steps i.e setting time zone in gmail as well my system time but still its showing wrong time please help me...

Vicky
April 7, 2010 7:03 AM

I was having difficulties setting the right time in my email account. Thanks Leo, the descriptions you offer in your blog are fantastic even for a person with limited connectivity experience!. Cheers!

Tim
May 14, 2010 7:57 AM

I am getting e-mails from the future! My computer knows what time it is - its clock is correct - but for example I have received a message timestamped today at 2:25 p.m., and it is not yet 10 a.m. Is the time stamp generated by the sender, i.e. is it their clock that is off?? Or is it added by Hotmail itself?

It's typically the sender's computer. Spammers often do this on purpose to make their email's more likely to be looked at.
Leo
15-May-2010

BryanL
May 15, 2010 9:13 AM

OK, my computer clock is being correctly updated weekly via the internet , to GMT+1 for "summertime" in the UK. My Hotmail/Windows account live is stuck on GMT. Followed instructions only to find the choice for the UK as "Dublin-GMT" or "London-GMT". Don't suppose that the Yanks get only the choice of "Washington-GMT minus 5" or "San Diego-GMT minus 8" for all states! So there must be something awry here. Any advice, apart from living with it?
Thanks, Bryan

Jennifer
May 30, 2010 7:15 PM

THANKYOU ! I didn't think the time zone on my hotmail would be wrong but it was and my problem is fixed ! thankyou ! so simple !

Mike Wilhelm
June 1, 2010 5:24 PM

If Tim is receiving emails from the future then maybe they can email Tim with next week's lottery number!

matilda
June 2, 2010 3:30 AM

Hi there - I have done all of the above and still my time stamp on my email (hotmail) is wrong....
I know that I went from Australia to UK and changed/updated the time when there... but since returning and changing the timezone the time stamp still hasn't changed. What else can I do/chck. Many thanks

Melinda
June 10, 2010 12:15 AM

I have tried your tips and checked the time zones etc. but my Outlook 2003 is still saying that I have sent emails tomorrow.

Sheryl S.
June 15, 2010 5:51 PM

Quote :
THANKYOU ! I didn't think the time zone on my hotmail would be wrong but it was and my problem is fixed ! thankyou ! so simple !

Posted by: Jennifer at May 30, 2010 7:15 PM
End Quote

Ditto, I thought my time zone was set too and just thought Hotmail always had a quirk. It never really mattered that the time zone was wrong, but it's nice to have it finally correct after all these years, lol. So very simple. :)
Thanks Leo!

san
June 19, 2010 2:28 PM

i cant change the time yet because of the new homepage for msn

Peter
June 22, 2010 12:53 AM

Does not work for me - no option for BST

Carlos Coquet
July 11, 2010 12:24 PM

This highlights an interesting issue: years ago, Bill Gates said that the spam problem would be solved within a couple of years. We all know it has not been. In fact, spammers often send mail with "future dates" because many of us choose descending sort order by date and mail with "future dates" then appears at the very top.
Now, if Microsoft spent the man power they spend integrating into new versions of Windows things that already exist from third parties and that relatively few need, if they spent that manpower in addressing the spam and virus issues this world would be much better off.
Although the Internet is NOT Microsoft's "responsibility", as the largest software house they can exert considerable influence on its workings. eMails should have a "real date stamp" inserted by the very first server handling the message and a "user date stamp" which could be also be displayed but only as informational data. The mail software could, possibly, adjust the "real date stamp" (Greenwich time) to local time and display that date and time in the Inbox line. That would take care of the problem with which this page deals.

Shandy
July 14, 2010 8:36 PM

I have tried your method, but the next synchronization date & time is different from the date & time above. Pls help? Tks.

Jodi McCune
August 17, 2010 8:45 AM

I looked at your site to try to fix the problem with my hotmail emails saying a different time than they actually come. I went through the steps 1. options 2. more options 3. when I get to the step about "registered information" I don't have that option. I have spent so much time looking for a way to fix this and at a loss for what to do next. Any more ideas??? By the way the time on my computer is fine. And the hotmail accounts of my other family members show the correct time, it is just my account.

Roberto Jalandoni
September 3, 2010 10:12 PM

Emails from my friend bear advanced time, hence stay on top in my inbox. The articles you provided and advice on steps to do do not work. She already had her PC clock and time zone checked and double-cheched by the IT technicians in her office, to no avail. What can she do?

Lug
September 19, 2010 4:08 AM

Thanks for the article. It helped em a lot.

Alex
October 1, 2010 5:19 PM

If your looking for the basically the same information as 'Registered Information'... in the area you would find it in, try and change your country/region instead, it will allow you to change information just like the registered information link

yeo
February 16, 2011 9:05 PM

why email time far ahead of my actual computer time. I have try adjust time and date and even synchronised internet time and yet could not rectified the problem. What other course of actions to take to correct the gmail time as to actual computer time. Pls advicse in few simple steps as far as possible.

Lori Sue
April 2, 2011 2:33 PM

THANK YOU! Finally, a QUICK and straight forward answer that actually WORKS!! You are BRILLIANT!

Freeda
April 7, 2011 11:26 PM

My time on my email was almost 4 1/2 hours ahead! I have since corrected it as per your instructions. Thank you.. you had explained it so clearly.. no mumbo jumbo. thank you. (sorry, I meant - NO Mumbo Jumbo.... thank you again

Hannah
May 8, 2011 3:57 PM

Thankyou SO much.
It was bugging me why on my email, the emails I were getting was an hour behind the actual time.
But thanks to this its all fixed!

Carla
May 12, 2011 4:04 PM

Thanks a lot - this hour behind on my e-mails has been bugging me for ages and now sorted really quickly.

Alicia
May 18, 2011 11:54 AM

Why is it that only my sent mail in Outlook Express is ahead by a year and a couple of months? What's up with that? My computer time and date are correct. The settings on the instructions you so generously provided were also already correct. I don't get it. Help = ) Thank you!

Patrice
May 29, 2011 9:41 PM

Thank you SO much. This is straight forward and easy to follow. I had no clue how to get my emails on the right time when the computer itself seemed to be. I appreciate the info you've provided here.

Nabihah
July 13, 2011 8:52 AM

THANK YOU! This issue was bothering me so much and now it's finally solved! YES!

Sachin
August 9, 2011 10:00 PM

I have sent 5 mails like 10.30 am but time showing that all mails one time 10.00 am , pls let me know how to fix it.

Bob
September 29, 2011 4:58 AM

I get this sometimes, in both directions. And not just on e-mails. IM programs sometimes put time/date stamps on things. I know that messages have arrived before they've been sent, been hours late, or all kinds of other 'wierdness'.
It can all depend on the time/date/region on your PC, the time/date/region on the other party's PC and the date/time/region on the provider's servers.

Roxana
January 29, 2012 3:10 PM

Thanks! This problem been bothering for so long and I changed it until now, your steps were really straight foward!

manju
March 7, 2012 10:56 PM

I have Received 5 mails like 12.30 pm but time showing that all mails one time 6.04 am , pls let me know how to fix it.

Steve
March 31, 2012 1:42 PM

Followed the steps outlined and defined the TZ in Hotmail. Have also verified the time on my PC and in Outlook is set correctly, but incoming email is still stamped 1 hour behind. Any other ideas?

Thanks!

HELEN
April 30, 2012 7:23 PM

the sent is 9:50 am May 1 but the time appeared is 5:50 april 30?how to fix this?the time is not updated

manohar.j
June 18, 2012 12:04 PM

in web mail i am receiving in 11:25am but in my outlook express it shows an 11:32am, how to change the time zone in outlook express in windows xp

lindsay
August 12, 2012 7:41 AM

I have checked all these steps but my mail is still saying 1 hour earlier.
Anyone suggest anything else,
Lindsay, UK

Dee-Dee
February 7, 2013 5:00 AM

why is the full date including '2013' not showing in my emails for this year?

Mark J
February 7, 2013 5:15 AM

@Dee-Dee
You don't say which email program or webmail interface you are using so it's not possible to diagnose the problem.

jane
March 17, 2013 9:09 AM

Hi, I have double checked the settings you mentioned above yet my Gmail is still one hour off.
How do I change this?

Comments on this entry are closed.

If you have a question, start by using the search box up at the top of the page - there's a very good chance that your question has already been answered on Ask Leo!.

If you don't find your answer, head out to http://askleo.com/ask to ask your question.